These are the channel logs matching your query [m]
2023-02-08 | [05:07:25] <daviid> mwette: i also use savannah for all my projects, and use sxml, then copy the sxml->html generated pages to the local savannah web pages, then call "cvs commit -m 'Updating blablabla'", which shoud just work for you to, the last command i mean ... |
2023-03-22 | [01:29:58] <daviid> not doesn't matter, all lib should be installed in $prefix/lib/ - my 2c ... [and fwiw, i am against a 'by default' install libs in GUILE_EXTENSION_DIR, as well as i m against a 'by default' install in GUILE_SITE_DIR (which i didn't change in guile-cairo, but imo we should, just as i do in guile-cv, g-golf ... |
2023-06-12 | [05:32:24] <daviid> ok, let's just try with emacs, can you, M-x shell |
2023-07-09 | [00:47:59] <ArneBab> I���m not deep enough in the string part of the code to judge that, but it sounds like interesting avenues to try. |
2023-08-04 | [18:41:49] <samplet> mwnaylor: I have all of those (I���m on Guix). |
2023-08-04 | [18:47:35] <samplet> If ���apply��� were generic, it could be extended (maybe ��� I���m just guessing) to support impersonators and chaperones. |
2023-08-04 | [18:48:56] <samplet> In Scheme, ���apply��� is what dictates how procedures work. I don���t know how much Scheme background you have. Now I���m just nervously explaining everything! :) |
2023-09-09 | [03:38:07] <apteryx> 'C-h i m Guile R RET' |
2023-09-12 | [00:54:50] <haugh> typing out l-a-m-b-d-a is a nice reminder that procedure creation isn't free :) |
2023-09-12 | [00:56:48] <graywolf> C-M-S-s-l for lambda also works I guess :D |
2023-09-12 | [03:34:06] <dsmith> rlb, You know, typing l a m b d a is not that much harder than \ l a m b d a ... |
2023-09-29 | [10:27:05] <civodul> i haven���t seen the patch (i���m a bit swamped) |
2023-10-04 | [08:17:58] <flatwhatson> so you could (let ((m (make-module))) (module-add! m |
2023-10-04 | [08:18:29] <flatwhatson> (module-define! m 'frobnicate (lambda () ...)) |
2023-10-04 | [08:19:03] <flatwhatson> (eval-in-sandbox expr #:module m) |
2023-11-02 | [03:32:22] <euouae> This is my file, <https://termbin.com/nqhr> and I am using geiser-mode-switch-to-repl-and-enter which runs ,m (hello) and then the prompt becomes scheme@(hello)> |
2023-11-02 | [13:41:27] <rekado> I���m using fibers and inside of (run-fibers ���) I need to use popen. |
2023-11-02 | [13:42:15] <rekado> I���m writing to a temp file and then run a command with popen and read its output |
2023-11-02 | [13:42:50] <rekado> I���m guessing that this is related to suspendable ports. |
2023-11-02 | [14:12:38] <rekado> I���m using call-with-temporary-output-file from (guix utils) |
2023-11-02 | [20:23:38] <rekado> in Python projects I���ve used Jinja2 templates and I���m looking for something similar to that, but more schemey |
2023-11-21 | [03:44:49] <dthompson> Kolev: but you know what I mean right? add in -m manifest.scm |
2023-11-21 | [03:45:24] <Kolev> `guix shell -m manifest.scm --pure -- haunt --version` gives 0.2.6. ������� |
2023-11-21 | [03:52:38] <dthompson> if you have my site repo, what does 'guix shell -m manifest.scm --pure -- haunt --version' say there? |
2023-11-30 | [07:33:31] <ArneBab> There���s a draft SRFI on mixing defines and expressions within the body. I looked into it and commented, but I���m not sure I grasp all the issues, so please have a look! https://srfi.schemers.org/srfi-245/srfi-245.html |
2023-11-30 | [20:29:46] <samplet> dthompson: ���Building Interactive Web Pages��� is amazing! Congrats to you and the whole Hoot team. I���m shocked and impressed that you folks have progressed so quickly. |
2024-01-18 | [00:03:22] <dsmith> I had the z80 card for the C64. CP/M on that silly drive was a nightmare |
2024-01-18 | [00:05:07] <ieure> Used to have an Epson machine, I forget the model, but it was a Z80 CP/M box. |
2024-01-20 | [00:03:33] <jpoiret> I wish ",m" would let you use unexported functions |
2024-01-20 | [01:39:12] <pinoaffe> jpoiret: huh, I thought ,m did allow you to use unexported functions |
2024-02-21 | [15:51:00] <ArneBab> dthompson: and i���m looking forward to your blog post! |
2024-04-10 | [11:29:24] <civodul> i���m looking at the size of ���.rtl-text��� reported by ���readelf -a��� and comparing with what ���guild disassemble��� gives, and they don���t match |
2024-05-10 | [00:03:05] <ArneBab> (I���m sure I���m not the first, but I wanted to try whether it���s really that simple) |
2024-07-01 | [00:16:51] <ArneBab> it might be able to bootstrap and then only *emit* C, but I���m not sure. |
2024-07-01 | [00:22:15] <ArneBab> I���m testing with ad48d90d12a747489d74a0d7ee7aa53d12639a64 now |
2024-07-07 | [18:39:21] <dsmith> "/m..." or "./m..." |
2024-07-20 | [11:31:41] <ArneBab> I want to finally document enter-three-witches (the game engine behind dryads-sun�� ��� you may remember the natural script writing talk that cwebber held for me��), and I���m unsure what name to use. The simplest would be "enter three witches", the games I wrote with it are called dryads wake and dryads sun, so something with "dryad" would also be an idea. �� https://archive.fosdem.org/2017/schedule/event/naturalscriptwritingguile/ �� |
2024-08-28 | [10:44:38] <dpk> i���m looking at implementing identifier properties (a la SRFI 213) in Guile. the challenge is that this involves not only the psyntax expander, but top-level property definitions need to be integrated into the compiler all the way down to ELF level����� |
2024-08-28 | [10:49:45] <dpk> wait, hang on, i think i���m overthinking this |
2024-08-28 | [11:00:32] <dpk> i���m going to try thinking about this again when i���m not nursing a cold and headache ����������������� |
2024-09-02 | [10:17:59] <dpk> i���m still new to posix_spawn (studying examples i know of) so maybe the destroy function isn���t actually needed, though |
2024-09-12 | [12:50:38] <civodul> even a fair share of my day job has to with free software, so i���m lucky |
2024-10-17 | [00:33:53] <ArneBab> mwette: I rather think that I don���t know the replacement. I���m currently using a sledgehammer approach where I start binaries in a guix container with --emulate-fhs and lots of --expose and --share options and a manifest with all needed dependencies (and quite a few more that I don���t take the time to trim). |
2024-12-23 | [15:16:15] <civodul> lechner: dunno, i���m just mentioning it as a source of inspiration |
2025-01-12 | [21:07:01] <mwette> What architecture (e.g., via uname -m)? |
2025-01-15 | [18:08:55] <rlb> (M-x debbugs-gnu is handy) |
2025-01-31 | [10:38:07] <ArneBab> I���m not at FOSDEM, but as a small gift for the minimalist languages room I got the code examples of naming and logic converted from Wisp to regular Scheme now: https://www.draketo.de/software/programming-scheme |
2025-02-02 | [10:48:01] <ArneBab> shidima: I���m not sure about Geiser, but Guile has the ,debug command in the REPL. |