IRC channel logs

2024-07-20.log

back to list of logs

<ArneBab>I want to finally document enter-three-witches (the game engine behind dryads-sun² — you may remember the natural script writing talk that cwebber held for me¹), and I’m unsure what name to use. The simplest would be "enter three witches", the games I wrote with it are called dryads wake and dryads sun, so something with "dryad" would also be an idea. ¹ https://archive.fosdem.org/2017/schedule/event/naturalscriptwritingguile/ ²
<ArneBab> https://dryads-wake.1w6.org/sun https://hg.sr.ht/~arnebab/dryads-sun (source)
<ArneBab>What do you think? Do you have other naming ideas? Is there another place where i should ask?
<chrislck>sneek: botsnack
<sneek>:)
<cwebber>dryad-triad ;)
<sneek>chrislck: Greetings!
<ArneBab>cwebber: that’s fun ☺
<ArneBab>(is it a serious proposal? The dryad triple?)
<old>7 years ago was yesterday hmm
<rlb>dthompson: think I have srfi-1 fully converted now, just checking a bootstrap build. If that works, I'll consider merging it after I double-check test coverage (and augment it if needed), etc. So not immediately, but perhaps soonish.
<rlb>(assuming there aren't other objections)
<dthompson>rlb: wow, awesome!
<dthompson>thank you!
<civodul>wo0t!
<dthompson>at some point I will update the guile we are using internally for developing hoot and see how importing srfi-1 goes :)
<dthompson>rlb: it was only a handful of procedures, right? like <10 or so? my memory is fuzzy
<rlb>ish, yeah.
<dthompson>a common hoot complaint is lack of srfi-1 so this will be a big help :)
<dthompson>and we're trying to not have our own separate implementations of things unless we absolutely need to
<dthompson>and we need to do for some lower-level modules but it would be silly for srfi-1
<rlb>...most work was delete-duplicates because I was too cavalier -- ended up (unsurprisingly) backing up and just converting the existing approach. (C delete-duplicates had a bit of complexity because it (laudably) shares the suffix when possible).
<dthompson>a noble effort
<rlb>(If it helps to have it sooner, happy to paste the scm somewhere.)
<dthompson>no rush
<rlb>cool
<dthompson>I am using a stub srfi-1 for now with minimal implementations of only the things we need
<mwette>I'm working on foreign calls, and thinking the pointer->procedure should be broken up to equvalent (pointer->procedure func_ptr (make-cif return_type arg_types [va_arg_types))); reason: callbacks to scheme may include function pointers and it makes sense to reuse the arity-only cif part.
<mwette>I've written a Gtk class in 100% scheme and it has this type of issue.
<rlb>Just realized that remove can (re)use the same trick that delete-duplicates relies on, so now the scheme remove version is fancier than the C one was :) (Our current remove never shares structure.)
<rlb>(That's probably enough of that for now...)
<mwette>That's interesting. So, the idea is that lst (delete-duplicates lst) share the same tail?
<mwette>s/that lst/that lst and/
<rlb>Right, they'd be the same list in that case.
<rlb>(and they are in current guile)
<rlb>But they're not for remove in current guile, I think.
<rlb>The standard allows (but doesn't require) sharing a common tail for a number of the functions.