IRC channel logs

2025-01-31.log

back to list of logs

<ArneBab>I’m not at FOSDEM, but as a small gift for the minimalist languages room I got the code examples of naming and logic converted from Wisp to regular Scheme now: https://www.draketo.de/software/programming-scheme
<ArneBab>The explanations still need to be changed.
<ArneBab>And the autoconf/automake setup still has to be changed, too.
<ArneBab>But the core is there: all the Code examples work and are executed on export (so the output shown is the actual result of the code)
<ArneBab>The next step is adding a hoot REPL so people can try it interactively.
<rubujeto`>Dear ArneBab, thank you for gift.
<rubujeto`>I actually learn Scheme and foud this SystemCrafters website.
<rubujeto`>I will talk to my friends, that are interested in programming lannguage, to look at your book.
<rubujeto`>It would be interesting to add it on Guile website
<ArneBab>rubujeto`: please keep in mind that the book is not yet finished: most of the explanatory texts are still for Wisp. They are short, so I should get around changing them to match regular Scheme the next days, but as for now these could be confusing.
<ArneBab>rubujeto`: that said: the PDF is 64 pages and I have a pretty readable DinA6 book of it lying around here, so it really drives home how small the core of Scheme actually is.
<ArneBab>(other topic) Regarding define-typed¹, I’ve been thinking about how to avoid duplicate type-checks, but that thinking always led to pretty complex logic. Would it be a simpler way to always make these inlineable? That way the CPS optimizer could see and avoid the duplicated checks. Does that sound correct? ¹ https://www.draketo.de/software/guile-snippets#define-typed
<ArneBab>My goal is: when I call a typed proc from another typed proc that has the same typechecks, I want the typechecks to only be evaluated on the outer proc.
<ArneBab>MWE: (define-typed (inner x) (string? string?) x) (define-typed (outer x) (string? string?) (inner x)) (outer "Guile")
<rubujeto`>ArneBab: Ok, I will wait before you finish your book about Scheme
<rubujeto`>ArneBab: I will wait you finish your book and then will send message to my friend
<ArneBab>rubujeto`: sounds good ☺ you can also forward them the Scheme Primer by Spritely: https://files.spritely.institute/papers/scheme-primer.html — that has a bit narrower focus, but should be easy to start, too, and goes pretty deep.
<graciousgnu>hello