These are the channel logs matching your query ssh
2023-01-31 | [07:55:20] <VesselWave> Hello, could someone help me? I am trying to use TRAMP with ssh. Client and server run guix. I can ssh via cli, but Emacs just stucks when I try to open a file: /ssh:user@192.168.x.x:1.txt |
2023-01-30 | [19:13:57] <gnucode> ssh: connect to host SOME.IP.ADDRESS port 22: Network is unreachable |
2023-01-30 | [19:14:24] <gnucode> but ssh user@SOME.ID.ADDRESS works outside in a normal termial. |
2023-01-30 | [19:19:10] <lechner> gnucode / are you running into this? https://stianlagstad.no/2020/03/learning-how-to-use-the-ssh-agent-with-fish/ |
2023-01-29 | [23:33:57] <nckx> seninha: It's part of the record definition of openssh-configuration, so (gnu services ssh). It is not itself a variable. |
2023-01-29 | [23:34:51] <seninha> nckx: so that's weird, because I already have (use-service-modules … ssh …) at my /etc/config.scm |
2023-01-27 | [11:39:47] <nckx> Do build nodes run the SSH ‘firewall’? I guess I locked myself out :) |
2023-01-27 | [13:20:44] <nckx> (Trusting 11 people with berlin SSH access counts as decentralisation, right?) |
2023-01-27 | [15:16:42] <civodul> it could be that the SSH connection used for offloading went bad, and the thing just got stuck |
2023-01-27 | [15:18:15] <nckx> I mentioned a(n interactive) SSH failure to an offload node earlier. It could have been a fluke, but who knows. |
2023-01-27 | [15:19:08] <nckx> (Which will keep my SSH connection to berlin from timing out, which is good.) |
2023-01-27 | [15:21:03] <nckx> lechner: I have that in my .ssh/config and… it's commented out. With no note explaining why. Hmm. |
2023-01-25 | [23:24:31] <ham5urg> When I boot the install-iso, is there something else I have to do except passwd & herd start ssh-daemon ? When I try to login via ssh root@... I just get an time out. |
2023-01-25 | [23:26:27] <tricon> ham5urg: Are you able to ping the booted device from the SSH client device? (assuming ICMP isn't filtered or blocked on your network...) |
2023-01-23 | [16:54:58] <gnucode> mirai: that's what I used, except that I forgot that I set up ssh to use a nonstandard port... |
2023-01-23 | [16:55:38] <gnucode> I had an ssh session going on the non standard port, and I figured that " ct state { established, related } accept" would let me current ssh session stay alive. Apparently not. |
2023-01-23 | [16:59:55] <mirai> I see that %default-nftables-ruleset comes with this description: This service comes with a default ruleset %default-nftables-ruleset that rejecting all incoming connections except those to the ssh port 22 |
2023-01-23 | [17:03:34] <gnucode> mirai I set up my ssh to run on a non standard port. It's not accepting connection on port 22. :) |
2023-01-23 | [17:04:18] <gnucode> ssh -p 24953 joshua@gnucode.me That's how I connect. Except I use a different port. :) And no I'm not really familiar with nftables. Trynig to get better at it. |
2023-01-22 | [10:54:06] <normeo> guix system image builds a blank VM image, there's no SSH host keys in it right? |
2023-01-20 | [14:43:48] <gnucode> oh, well, basically I can't ssh into the server anymore. I can put the nftables.conf into a pastebin if you like. |
2023-01-20 | [14:47:08] <gnucode> I could ssh in, my website still worked. But after I reconfigured, I can't ssh in and my website is down. |
2023-01-20 | [14:47:34] <gnucode> I am pretty sure that link I put up is the nftables configuration that I reconfigured with, but I can't ssh into the box to verify.... |
2023-01-20 | [14:56:36] <lechner> gnucode / i'd try this LISH Console via SSH |
2023-01-20 | [14:59:19] <gnucode> and lish console via ssh does the same thing. :( |
2023-01-20 | [16:44:59] <bost> Hi. I'm playing with the Xvnc. The docs says try `ssh -L5910:localhost:5910 -- guix shell xclock -- env DISPLAY=:10 xclock`, however I get 'ssh: Could not resolve hostname guix: Name or service not known' |
2023-01-20 | [16:45:48] <bost> ACTION Or is it a bug in the ssh? Ugh. |
2023-01-20 | [16:48:13] <bost> gnucode: my question is about the syntax of the ssh command. SRY for misleading you (Xvnc questions will come later, most probably :-) |
2023-01-20 | [16:48:54] <gnucode> bost does ssh -L5910:localhost:5910 work ? |
2023-01-20 | [16:52:20] <bost> BTW, `ssh localhost` works |
2023-01-20 | [17:25:10] <bost> gnucode: FYI seems like the correct syntax is `ssh -L 5910:localhost:5910 [<username>@]localhost -- guix shell xclock -- env DISPLAY=:10 xclock` |
2023-01-20 | [17:27:39] <gnucode> bost nice. What were you trying to do? why do you need to ssh into the local machine? Are you messing with virtual machines? |
2023-01-20 | [17:28:13] <apteryx> it's transport is insecure, so it's typically used via an SSH link |
2023-01-20 | [17:29:17] <apteryx> bost: ah, I see it, there's no host in the manual for that SSH command |
2023-01-20 | [17:29:42] <gnucode> hmmmm. If you are messing with a physical machine? Why is there a need to ssh into it? Just practice? |
2023-01-20 | [17:31:37] <bost> gnucode: I'm not having and extra monitor for the machine. Only an ssh-access. (Or maybe VNC later, if I succeed in setting it up) |
2023-01-20 | [17:54:24] <apteryx> you can check if gdm is running via ssh (pgrep gdm) |
2023-01-20 | [18:35:35] <apteryx> bost: the mistake you spot earlier in the SSH command is now fixed; it now reads: "ssh -L5910:localhost:5910 YOUR-HOST -- guix shell xclock -- env DISPLAY=:10 xclock" |
2023-01-20 | [18:40:57] <apteryx> unless a physical user is connected, it suspends (even while there are active remote connections such as SSH) |
2023-01-20 | [23:26:04] <apteryx> looking at dmesg I only see SSH brute force attempts ;-) |
2023-01-18 | [13:34:54] <nckx> I don't mean QA is bad, just that this kind of thing could previously only happen if someone trusted with SSH access was using bayfront to speed up their development. It was very limited in scope. If it can now happen by accident through any old ML post, that's objectively worse. |
2023-01-18 | [16:29:22] <nckx> Even if you're directly copying, Guix uses ssh compression by default IIRC, making it equivalent (or worse than zstd nars, depending on how you're counting). |
2023-01-18 | [20:25:11] <dthompson> anyone else having guile-ssh issues with 'guix deploy' lately? |
2023-01-14 | [03:10:27] <mirai> looking at your endless ssh configuration, it looks almost the same thing |
2023-01-14 | [14:46:47] <mirai> boot computer, SSH into it with X forwarding and xdot opens (from SSH client side) |
2023-01-14 | [14:47:48] <mirai> and using ssh to launch xdot opens it in the remote GNOME session |
2023-01-14 | [22:42:07] <gnucode> hmmm the $(guix build vm config.scm) is stuck at generating the ssh keys... |
2023-01-14 | [23:39:53] <podiki[m]1> ssh access works, so something funky with cgit browser I'm guessing |
2023-01-13 | [00:20:25] <Apo11o[m]> I’m trying to install guix in gnome boxes but it’s stuck on ssh-keygen: generating new host keys: RSA |
2023-01-13 | [00:21:53] <Apo11o[m]> waits for the response while watching ssh-keygen xD |
2023-01-13 | [07:13:36] <cobra> Hey, I'm having trouble with Xorg on my Guix System installation. When I try to run Xorg for any purpose, my video output freezes until i SSH into the machine and kill Xorg. My Xorg log says that it couldn't load driver "intel", and I have an i965 GPU |
2023-01-12 | [04:16:57] <dirtcastle> I figured out how to ssh into it. I use qemu. |
2023-01-12 | [14:04:04] <ecbrown> zshrc it is not sourced on ssh but only for logins or some such combination |
2023-01-11 | [01:04:13] <lechner> you may need ssh on top of desktio, but that's it |
2023-01-11 | [17:00:24] <the_tubular> SSH sends a connection reset |
2023-01-11 | [17:50:40] <lechner> the_tubular / maybe try Host * ServerAliveInterval 300 in ~/.ssh/config |
2023-01-11 | [17:51:36] <the_tubular> ssh isn't the problem, the machine isn't responding at all |
2023-01-11 | [22:49:55] <gnucode> hey guix, in order to use guix deploy do you need to set up ssh-agent ? |
2023-01-11 | [23:01:21] <gnucode> well apparently you do need to set up ssh-agent. |
2023-01-11 | [23:02:01] <gnucode> in .bash_profile eval `ssh-agent -s`; ssh-add |
2023-01-11 | [23:02:28] <gnucode> so now at every login, it is asking me for the password for ~/.ssh/id_rsa . |
2023-01-10 | [19:27:11] <nckx> The reason I asked for the exact name is because you said this was somewhat urgent for you, and I wanted to see if I could find a copy for you to import, at least [assuming you trust me, but then I have SSH access to ci.guix to begin with]. |
2023-01-07 | [00:37:29] <bl0rt_tmp> gnucode: I'm a little confused about the step '("root" ,(local-file "janedoe_rsa.pub")', do I really need to save my ssh public key somewhere on the server if it's already in .ssh/authorized_keys? |
2023-01-07 | [18:48:29] <rhn> how do I find the name of the service? guix edit: error: ssh-daemon: unknown package |
2023-01-07 | [18:48:50] <civodul> rhn: try "guix system search ssh" for example |
2023-01-07 | [19:22:01] <rhn> best I found is gnu/store/bv2qjwhm3zzl2ymgb93fx5ih62y853bl-shepherd-ssh-daemon-ssh-sshd.scm but it's clearly generated from something else |
2023-01-07 | [22:57:39] <rhn> yay, I can ssh into my podman container :) |
2023-01-05 | [11:42:44] <cbaines> bayfront is having problems as the Guix Build Coordinator is using excessive amounts of memory (64GiB heap). This'll affect things like the website. I'll kill it, once I can SSH in... |
2023-01-05 | [11:48:57] <cbaines> I actually didn't manage to SSH in before it seems to have died on it's own, maybe the OOM killer |
2023-01-05 | [18:19:36] <ham5urg> mirai, I did not installed ssh but it works as in config.scm |
2023-01-05 | [18:20:19] <nckx> ham5urg: Which service installs ssh? |
2023-01-05 | [18:22:42] <ham5urg> (service openssh-service-type ... will install ssh as I understand |
2023-01-05 | [18:26:37] <nckx> But that shouldn't make ‘# ssh’ work. |
2023-01-05 | [18:27:29] <bjc> nckx: i don't install openssh seperately in my config, yet it exists in /run/current-system/profile/bin/ssh |
2023-01-05 | [18:30:14] <nckx> That would mean o-s-t extends profile-s-t. Which is possible, but it is *wholly separate* from running a ssh service. It's a ‘oh and also do this’ move. Maybe for a reason; I can't easily check. |
2023-01-05 | [18:31:00] <nckx> You don't need to install ssh(d) to run sshd, is what I should have soid. |
2023-01-05 | [18:33:32] <mirai> that's what's causing ssh, scp and the likes to show up under your profile |
2023-01-05 | [18:33:44] <bjc> i don't know why openssh is like this; it doesn't need to be. guix wouldn't be the first distro that allowed you to run sshd without providing ssh |
2023-01-05 | [18:34:29] <mirai> https://git.savannah.gnu.org/cgit/guix.git/tree/gnu/services/ssh.scm?h=v1.4.0#n614 |
2023-01-03 | [18:47:06] <ham5urg> Did anyone installed Guix inside a remote VM? I've ordered a VPS but am not allowed to boot my own ISO, neither do I have a terminal besides SSH. All I have is a fall-back-debian-10 and the mounted harddisk under /repair. How should I try to install Guix into it? I would like to use a /etc/config.scm while inside the fall-back-debian-10. |
2022-12-31 | [22:20:45] <haugh> I find it really annoying to manage complex SSH configs with Guix |
2022-12-31 | [22:22:34] <nckx> What does a complex SSH config look like? |
2022-12-31 | [17:08:48] <mirai> with file uri it complains: error: cannot run ssh: No such file or directory |
2022-12-30 | [11:38:12] <axelbdt> Hello, I wish to deploy Guix System on a cloud instance supporting custom images (iso, qemu...). How can I find or generate an image that would allow basic ssh and subsequent `guix deploy` to the machine? I am a bit overwhelmed buy the manual and cookbooks. Thanks! |
2022-12-30 | [17:08:22] <jas4711[m]> lechner: https://dev.gnupg.org/T5935 -- i can't SSH into modern boxes any more without disabling the new PQ crypto |
2022-12-30 | [17:23:19] <nckx> jas4711[m]: There's no reference from openssh to gnupg I'm missing, right? That is, ssh uses gnupg from PATH (or some other environmental place) if it's installed? |
2022-12-30 | [17:24:36] <nckx> <i can't SSH into modern boxes any more> So does this imply that Guix's OpenSSHd isn't modern? (I didn't check.) |
2022-12-30 | [17:24:39] <jas4711[m]> nckx: ssh talks to gpg-agent and all this is working, I get the error from scdaemon which is running under gpg-agent. so the call path works but there is a bug in scdaemon |
2022-12-30 | [18:31:18] <KarlJoad> Does guix deploy respect verbosity and debug flags? I cannot make figure out why the deploy fails SSH authentication when I can SSH there myself. The necessary information is in .ssh/config too. |
2022-12-30 | [19:26:15] <KarlJoad> Does guix deploy not read SSH's config file (somehow)? Deploy says it cannot reach the machine, but everything is correct; I can manually SSH there. |
2022-12-30 | [21:23:50] <KarlJoad> lechner: "Throw to key `guile-ssh-error` with args ... ("channel-get-exit-status" "Parent session is not connected #<unknown channel (freed) ..." Ellipses indicate omitted parts. |
2022-12-30 | [21:26:31] <KarlJoad> I'm pretty sure this one is a non-issue because I sent the command to reboot, so the SSH server and connection just died. |
2022-12-23 | [01:31:59] <attila_lendvai> lechner, isn't it somehow related to SSH trying to ask for interactive confirmation of the site identity? |
2022-12-23 | [01:35:34] <lechner> attila_lendvai / no clue, but it's never happened to me before. not sure if it is related to a recent update of guile-ssh, but this needs to be elevated to level 2 support. it's above my abilities |
2022-12-23 | [08:34:04] <rekado> I’d like to offload builds to a machine that is behind two(!) bastion servers. “guix offload” does not seem to care about the settings in ~/.ssh/config. |
2022-12-23 | [08:35:35] <rekado> guix/scripts/offload.scm explicitly ignores ~/.ssh/config, but I don’t understand why. |
2022-12-22 | [01:55:07] <attila_lendvai> could this be due to some ssh configuration? |
2022-12-22 | [01:58:17] <lechner> okay, i use the first and the last, and have never seen the error. that leaves guix-crypto. do they use an obscure or extra secure SSH algorithm? |
2022-12-22 | [02:10:29] <lechner> attila_lendvai / apparently the name channel has a special meaning with SSH, but I'm not sure how to put that into our context here https://unix.stackexchange.com/a/459051 |
2022-12-22 | [02:13:07] <attila_lendvai> lechner, oh, that guix issue looks very much like mine! lemme turn off my ssh config... |