IRC channel logs

2022-12-23.log

back to list of logs

<kinhy>Hey guys, is it possible to declaratively configure gnome in guix? Something like what one would do with dconf, set keyboard shortcuts etc
<rekado>kinhy: not yet, but I’ve always wanted something like that.
<rekado>would be nice to have
<kinhy>What do you think, would it be hard to implement something like this?
<rekado>I don’t know.
<rekado>is it enough to use dconf?
<kinhy>I think in nix they have dconf2nix
<kinhy>Maybe we can start from that
<rekado>kinhy: would you like to work on it? I can review or answer questions.
<vagrantc>/26/
<kinhy>Would love to. Will try to figure out what they do in dconf2nix, which is written in haskell, and then try to implement a guix equivalent
<rekado>from a first look I don’t think it would be all that useful for use
<rekado>*us
<rekado>there’s no point for us in converting dconf files to anything other than s-expressions
<kinhy>I see
<rekado>and I think what we need is rather a way to *set* dconf key/value pairs, not convert anything
<rekado>here’s what they do: https://github.com/nix-community/home-manager/blob/master/modules/misc/dconf.nix
<rekado>stuff all the dconf settings in a file and load that
<rekado>before that unset all previous settings
<kinhy>Exactly, I see point
<rekado>this is done in home-manager, so in Guix it would likely be implemented as a Guix Home service.
<rekado>we could have that dconf service accept settings as strings and/or alists with the key being the settings path and the value being an alist of keys/values.
<rekado>this shouldn’t be too difficult
<rekado>the only unusual thing is that settings keys managed by Guix must be recorded somewhere, so that they can be unset by later configurations.
<johnabs[m]>Hi all, does anyone currently use Clojure? If so, can I get some help? Apparently clojure and leiningen can't find the appropriate java installation for some reason. Is there another package I need on top of these two?
<msgilligan[m]>johnabs: Did you install `openjdk:jdk`?
<johnabs[m]>msgilligan[m]: No, I figured that would be installed with them. I can try it right now
<msgilligan[m]>If you just install openjdk no compiler is present (as I just learned) and this was causing problems for a Gradle build I was attempting.
<johnabs[m]>Is this just "guix install openjdk"?
<johnabs[m]>Oh wait a minute
<msgilligan[m]>guix install openjdk:jdk
<msgilligan[m]>the :jdk is required if you need javac which I wouldn't be surprised Clojure needs
<johnabs[m]>Okay, got it, I'm installing now, and I'll let you know how it goes xD
<iska>I have a few packages that use the same steps but different names, how do I define both packages without code duplication?
<johnabs[m]>Yo, looks like it works! Thanks msgilligan 😁
<nckx>msgilligan[m], johnabs[m]: Should this be fixed in Guix's clojure?
<msgilligan[m]>johnabs: How did you install Clojure?
<johnabs[m]>I just ran "guix install clojure clojure-tools leiningen emacs-cider". Would this dependency need to be added to leiningen as well?
<johnabs[m]>Since it also couldn't find java?
<msgilligan[m]>johnabs: You're welcome! Thanks to nckx for helping me with the same issue just a few hours ago!
<nckx>iska: One possibility is (package foo (inherit bar) (name …) …) for each foo.
<nckx>Cheers! I'm off to bed. Be good.
<mbakke>efraim: thanks for fixing ipxe-qemu
<attila_lendvai>is there something like extra-special-file but to create a directory with a given user:group and perms?
<sneek>Welcome back attila_lendvai, you have 1 message!
<sneek>attila_lendvai, lechner says: now i have the same problem!
<attila_lendvai>lechner, did you mean the guix deploy issue?
<iska>nckx the problem is that there's more variables to be changed than the name
<lechner>attila_lendvai / yes
<msgilligan[m]>johnabs: I'm too new to Guix to answer your questions. I am interested in creating some OpenJDK-focused documentation with tips and best-practices. Things like how to set your `$JAVA_HOME` and how to switch between alternatives etc.
<msgilligan[m]>I should also note that I'm an aarch64 macOS user that is running Debian w/Guix in a QEMU VM and that I'm seeing some issues in this environment that I'm not seeing on my x86_64 mini-system.
<attila_lendvai>lechner, err... now i have the identity commented out, and i'm again getting the same error?!
<attila_lendvai>lechner, isn't it somehow related to SSH trying to ask for interactive confirmation of the site identity?
<lechner>attila_lendvai / no clue, but it's never happened to me before. not sure if it is related to a recent update of guile-ssh, but this needs to be elevated to level 2 support. it's above my abilities
<attila_lendvai>lechner, it's strange, because commenting out identity clearly fixed it for me a couple of days ago, when we last spoke. since then i may have pulled, though.
<msgilligan[m]>nckx: I created an account on Savannah and made a personal Github copy of the repo and pushed my work-in-progress change there: https://github.com/msgilligan/guix/commit/b23b718b5808f4243f7c87b199a8e21aee2638c7
<lightbulb>msgilligan[m]: Commit b23b718 in msgilligan/guix "guix-cookbook.texi: Add minimal Setting up OpenJDK section"
<sneek>Welcome back zamfofex :D
<zamfofex>sneek: 🎉 botsnack
<sneek>:)
<zamfofex>Hello, everyone! I’m in the mood to work on something related to Guix today, but I’m torn between three options: (option 1) Polishing my Ladybird (browser) package and submitting it. (option 2) Continuing to work on my Hurd endeavors, now that I seem to have gotten some feedback about it on the mailing lists. (option 3) Continuing to work on the npm importer project to see if I can bootstrap TSC like suggested on the mailing list.
<lechner>Hurd++
<AwesomeAdam54321>zamfofex: Continue your Hurd endeavors, I've been putting off packaging dak
<AwesomeAdam54321>I also want to help work on the Hurd
<zamfofex>Well, I was a bit afraid of that. I’m also very eager to work on updating the Hurd packages and getting usable networking on it, etc. But the problem for me is that everything takes so long to build! And sometimes errors are such that I have to start certain things again from scratch and wait for the whole thing again. I once set a build running over night, and it was still not finished for a few hours after I wake up.
<zamfofex>It’s speically frustrating because the builds slow my computer down until it’s effectively unusable.
<zamfofex>Though I suppose *someone* ought to do that kind of work, so I might as well.
<lilyp>zamfofex:
<lilyp>oops
<lilyp>zamfofex: for immediate gratification, submitting ladybird probably works the best. So I'd say work on the Hurd until you feel a little exhausted, submit ladybird, then work on the Hurd again or do npm
<rekado>I’d like to offload builds to a machine that is behind two(!) bastion servers. “guix offload” does not seem to care about the settings in ~/.ssh/config.
<rekado>guix/scripts/offload.scm explicitly ignores ~/.ssh/config, but I don’t understand why.
<yarl>Good morning guix.
<zacchae[m]>Good morning!
<pret7>heya! does anyone know how I can pretty print a bag in the repl? `,pp (package->bag <<package>>)` still looks like a big string
<rekado>weird: “./pre-inst-env guix offload test” works, but “./pre-inst-env guix build ceph” fails to connect to the offload server
<rekado>ssh_socket_exception_callback: Socket error: Connection reset by peer
<rekado>pret7: you need to get at the contents of the bag first
<pret7>ok, I've done that, (define mybag (package->bag node))
<pret7>unless im misunderstanding
<pret7>like I see all the stuff
<pret7>it just looks like this
<pret7>```
<pret7>```
<pret7>$24 = #<<bag> name: "node-10.24.1" system: "x86_64-linux" target: #f build-inputs: (("source" #<origin "https://nodejs.org/dist/v10.24.1/node-v10.24.1.tar.xz" #<content-hash sha256:032801kg24j04xmf09m0vxzlcz86sv21s24lv9l4cfv08k1c4byp> () 7f54051c7240>)....
<rekado>access the contents
<rekado>,pp (bag-build-inputs $24)
<civodul>Hello Guix!
<abcdw>civodul: o/
<civodul>hey abcdw, how's everything?
<pret7>@rekado thanks!
<abcdw>civodul: Pretty busy, but good. I finally found an appartement for rent, preparing rde graphical livecd and first release, onboarding conses as rde maintainer.
<pret7>it'd be nice if I could pretty print the whole thing with its other properties too though
<yarl>Hello civodul.
<pret7>I guess I can write that myself, thanks again :)
<civodul>abcdw: busy indeed!
<civodul>sounds nice
<yarl>civodul: about bug 59845, I answered this morning. I'll take a shower then I am available to chat if you will.
<lightbulb>yarl: Bug 59845 in guix-patches "[PATCH 0/4] Add PMB (Integrated Library System)" [Normal, Open] https://issues.guix.gnu.org/59845
<yarl>The shower device is busy.
<rekado>FYI: pankow is down as I’m moving it from my home to the data centre. Will also take grunewald down for a few minutes to swap the disk.
<danialbehzadi[m]>What do you think about adding Guix as an entity in LinkedIn, so contributors could add it to their volunteer experiences? This may bring a broader audience for Guix between coworkers an colleagues.
<rekado>ACTION has never used LinkedIn
<rekado>danialbehzadi[m]: what needs to be done to make this happen?
<danialbehzadi[m]>rekado: Create a company page like this:
<danialbehzadi[m]> https://www.linkedin.com/company/debian
<haugh>We're not allowed to talk about how to install wifi drivers. We're going to shill with the tech recruiters and corporate re-education?
<civodul>i hadn't visited the new issues.guix.gnu.org, kudos rekado!
<yarl>civodul: Did you /ignored me? :/
<civodul>yarl: hi! sorry, no!
<civodul>i'm busy with other things though
<yarl>civodul: Ok np :)
<yarl>I'll be there most of the time today.
<yarl>(Things are not perfectly clear for me and a live chat could be useful)
<rekado>pankow is back in the data centre
<rekado>grunewald has booted from the replacement disk
<omlet[m]>One question, gnu deneno have spanish translate?
<rekado>grunewald was fine, then I accidentally pulled the power cord while placing it in the rack, and now it won’t start… :*
<rekado>:(
<rekado>booting from a different disk to run fsck…
<rekado>when the dirty bit is set on the vfat EFI partition the thing won’t boot
<rekado>ran fsck, but this would require a visit to the data centre in the future
<rekado>unless we can set up a) remote serial access and b) PXE boot to run fsck
<rekado>another great idea: cable relief.
<rekado>the power supply is so eager to get detached from this case, it’s not funny
<mekeor[m]>دانیال بهزادی: arent there other ways to mention guix on your linkedin profile than linking to its (currently non-existant) company-profile, like just mentioning it in your profile or tagging your skills with it? personally, i cant imagine gnu guix, as a radical gnu free software project, to join a commercial proprietary microsoft-owned platform :D
<mekeor[m]>is lightbulb a (new?) bot?
<AwesomeAdam54321>mekeor[m]: I think so, it's been around for a few days
<mekeor[m]>pretty useful :)
<mekeor[m]>lightbulb: help
<lightbulb>mekeor[m]: (help [<plugin>] [<command>]) -- This command gives a useful description of what <command> does. <plugin> is only necessary if the command is in more than one plugin. You may also want to use the 'list' command to list all available plugins and commands.
<mekeor[m]>lightbulb: list
<lightbulb>mekeor[m]: Admin, AutoMode, Bugtracker, Channel, Config, Misc, Network, NickAuth, Owner, Services, User, and Utilities
<mekeor[m]>ACTION will stop flooding now
<rekado>aarch64 build nodes are all good now
<rekado>grunewald always resets its clock to the epoch when it boots up. We may need to work around this problem in the system config.
<rekado>ACTION leaves data centre
<rekado>apteryx: all big SSDs are now in node 129.
<gnucode>morning guix!
<civodul>rekado: yay, thank you for the build farm maintenance!
<civodul>test: #60052
<civodul>bug 60052 maybe?
<lightbulb>civodul: Bug 60052 in guix-patches "[PATCH 1/2] gnu: libbacktrace: Add patch." [Normal, Open] https://issues.guix.gnu.org/60052
<civodul>neat
<itd>Is it possible to request a QA build for an issue? E.g., for https://issues.guix.gnu.org/58250
<nckx>I think patchwork. looks only at guix-patches@, not bug-guix@.
<nckx>Seems so: https://patches.guix-patches.cbaines.net/project/guix-patches/
<Kolev>I forgot how to inatall Guix on Fedora. I know I have to disable SELinux and install some daemon.
<rekado>Kolev: use the script at https://guix-install.sh to install
<rekado>in addition to running the script you’ll have to disable (or debug) SELinux
<Kolev>rekado: Right, but on Fedora, I have to install a daemon and disable SELinux before running it.
<rekado>as I said, run the script
<apteryx>rekado: great!
<rekado>Kolev: to disable SELinux you can run “sudo setenforce Permissive”
<rekado>ACTION is working on an update to the daemon policy for Fedora 36
<Kolev>How is Podman right now? Currently my server runs a bunch of Podman containers. Wondering if I could put Guix on it even tho there are no service defs for The Lounge and Jellyfin
<Kolev>Maybe i should just stick to RHEL on server
<rekado>what do you mean by “How is Podman”? We have a package for it.
<civodul>efraim: hi! did the Julia package updates go through qa.guix? :-)
<civodul>rekado: https://guix-install.sh/ is a thing!!
<rekado>it’s super! Thanks to mbakke.
<civodul>well done
<pjalsDanielv[m]>whats guix-install anyway?
<ecbrown>pjalsDanielv[m]: i believe it is a script that installs guix on "foreign distros" e.g. trisquel, debian
<ecbrown>apparently now with a convenient url that leaves little to the imagination
<Kolev>rekado: IIRC, Podman doesn't work even tho it's packaged.
<Kolev>rekado: Another thing I miss from systemd is the feature of encryptinf home on suspend.
<parnikkapore>Just sent in my first patch :D, how long should I wait for debbugs to send me a reply?
<mirai>parnikkapore: up to 9h
<nckx>msgilligan[m]: Nice! The Savannah account is only required from those with commit privileges to Guix, but not to submit patches to guix-patches@. I'm sorry if that wasn't clear.
<parnikkapore>mirai: Ah, thanks! I didn't receive anything back and was worried I did sth wrong
<nckx>And if you don't get a reply after 9h, you need to wait 15h.
<parnikkapore>why is that?
<nckx>Because debbugs and/or gnu.org mail are very naughty laggy bois, unfortunately.
<nckx>That said, your mail's already in my box? So you should have got a confirmatio.
<nckx>I've approved it but that wouldn't have delayed the response.
<jas4711[m]>hi guix! how do I use a linux-libre 5.15 kernel? I've found the operating-system kernel parameter, but I don't know what to put there to get the 5.15 version
<jas4711[m]>got it - (kernel linux-libre-5.15)
<gnucode>parnikkapore: You can always check guix patches archives.
<gnucode> https://lists.gnu.org/archive/html/guix-patches/
<gnucode>jas4711[m] just curious...why do you want to use 5.15 ?
<parnikkapore>nckx: Yup, I got the confirmation ID already! 🎉
<parnikkapore>* confirmation email
<gnucode>nckx: you are probably getting tired of opensmtpd updates...but I am using opensmtpd-records for my opensmtpd server, and it's doing dkimsigning.
<nckx>I am not.
<nckx>Oh, I didn't see there was a V3.
<gnucode>I literally just sent it. :)
<gnucode>it also has a corresponding blog post with a link to documentation.
<gnucode> https://gnucode.me/submitting-opensmtpd-service-to-guixrus.html
<nckx>Thanks.
<gnucode>anytime.
<jas4711[m]><gnucode> "jas4711 just curious...why do..." <- I ran into a problem with a wifi card that works fine with trisquel's 5.15. it also worked fine with guix 5.15 but spam kernel log with guix's 6.0
<nckx>I can't apply <https://issues.guix.gnu.org/issue/56046/raw/15>, partially because it has ‘Content-Type: text/plain; charset=y’.
<nckx>Like a 17-year-old writing ‘sex: yes please’ on their fake ID. Any idea what could cause that, gnucode? Do you have a misplaced ‘y’ in your git configuration?
<mrvdb>I have spent a day to get qmk working under GUIX. the manifest i am using https://github.com/mrvdb/qmk_atreus/blob/main/manifest.scm may contain some useful package specs to include in GUIX (some python packages which were not packaged yet)
<nckx>gnucode: I still can't apply it even with an edited charset. Could you send future patches with ‘--base=auto’?
<gnucode>nckx: I'll send it again. and yes, I'll do that.
<nckx>gnucode: Thanks! You can add ‘[format]’ <newline> ‘useAutoBase = whenAble’ to your ~/.gitconfig (or ~/guix/.git/config) to do so automatically.
<gnucode>sounds good.
<gnucode>nckx: I'm pretty embarrased to admit that it is really far behind guix master branch.
<nckx>The new issues. CSS is nice but noticably slows down the site on a heavily loaded machine. Pity.
<nckx>gnucode: Ah, that might explain why I can't apply it. Hope you don't have to go through merge hell.
<gnucode>the last time I tried to merge two diverging branches via emacs, I couldn't manage it. I ended up with A >>>>>>>>>>> artifacts all over the place.
<gnucode>nckx it's not a ton of differing things. It's mostly the same.
<gnucode>I just don't know how to handle merge conflicts apparently.
<Electnick>Hello I installed gnu guix sd on 64GB usb 3.1 thumb drive. I am using only i3 as a window manager. Only 8 packages I installed: netcat ffmpeg font-gnu-unifont
<Electnick> font-gnu-freefont vlc emacs ungoogled-chromium and scrot.
<nckx>It takes some practice to get fluent, I don't think there's a substitute.
<gnucode>Electnick: welcome aboard!
<gnucode>nckx: bummer. :(
<gnucode>I am going to go wrap some presents. Let me know if that patch that I just send to guix-patches cannot apply cleanly... It probably won't. :(
<Electnick>gnucode: Thanks. I am learning. Is there a max number of characters to be written in this chat? If so what is it?. It seems to me my previous message was splitted.
<gnucode>Electnick: not so much max number of charaters, but irc does'nt like when you send newlines. \n .
<gnucode>That encourages people to NOT paste in long paragraphs of text.
<nckx>gnucode: Same error: https://paste.debian.net/plainh/04c9b820 I tried removing the doc/guix.texi hunk previously, but still failed.
<nckx>Happy wrappin'.
<nckx>I'll try using your notabug repo directly, later.
<Electnick>gnucode: thanks. I'll keep it in mind. I am writing on Guix SD 1.3.0. Nowadays using the same version on both SDD and usb thumb drive. The SO on the thumb drive will be for educational purposes. I prefer hardware more than virtual image installations
<Electnick>trying to get acquainted with hexchat and libera.chat
<Kolev>Can't stop using thelounge.chat!
<jas4711[m]>how do i pass parameters to linux modules? i want to load ath9k with parameter btcoex_enable=1. any pointers to existing configs? i've read https://guix.gnu.org/manual/en/html_node/Initial-RAM-Disk.html but it doesn't seem to talk about parameters
<nckx>Try (kernel-arguments (list "ath9k.btcoex_enable=1")).
<nckx>Pragmatically, documenting standard Linux features in the Guix manual would overwhelm our modest manual many times over, and be unmaintainable.
<nckx>And Linux doesn't really have a coherent manual we can link to, beyond Documentation/ . ☹ Not great.
<lfam>Where can I see how the gnuzilla-updates Cuirass jobset is defined?
<rekado>Kolev: how does it not work? Is there a bug report about it?
<rekado>nckx: re CSS: is that in firefox, icecat, or chromium?
<ConvolutedSquare>Hey all. I am attempting to install Guix System on a TS-453U-RP QNAP with a BTRFS RAID 10 setup. First, I would like to note that the graphical installer doesn't seem to allow BTRFS RAID, so I got stuck on the partitioning screen. When I did the installation manually(and set up the RAID 10), I configured grub-bootloader to get installed to a 500MB DOM(Disk on Module), but booting the system results in grub failing with the
<ConvolutedSquare>following: "error: no such device: (UUID)" and "error: unknown filesystem" and it drops me into a rescue shell. Any ideas what I did wrong or how I can debug this?
<nckx>lfam: I did not define it declaratively, only in the Web UI. https://www.tobias.gr/tmmp.png
<nckx>rekado: Firefox.
<rekado>I think this might be due to transparency / blur that I don’t even notice. I’ll gladly disable whatever makes it slow.
<nckx>I'm transcoding holiday video, or probably wouldn't have noticed.
<rekado>it was just supposed to move off bootstrap (and clean up a few annoying things), not to make it “fancier”.
<nckx>I have no idea how to profile CSS, but assumed it was something blendy like that. Shadows, perhaps?
<nckx>ACTION shrugs.
<rekado>we had shadows before as well; I think it might be the blur / transparency on the header.
<rekado>it doesn’t show in icecat
<rekado>but firefox probably supports that
<mirai>ConvolutedSquare: you need to do the partitioning manually
<rekado>ACTION made a few changes to the guix-daemon.cil; works now
<nckx>rekado: I wish it were that, but no, no transparency in FF either (which gives me pause, because I've definitely seen the effect before).
<lfam>Thanks nckx
<lfam>I see, it just builds everything
<lfam>Same for my requested kernel-updates jobset, I suppose
<nckx>I changed that at mhw's explicit request.
<rekado>should the guix-daemon.cil be installed on “guix pull”? It’s not in the current-guix profile.
<nckx>My initial offering only built icecat and some related stuff (that was probably implied anyway, but hey).
<ConvolutedSquare>mirai: I set up a single partition on the boot drive and formatted it to ext2.
<rekado>nckx: in chromium I see a little transparency/blur. Hard to spot. Only visible when the header covers the green “Open” badge.
<nckx>Oh wow, OK. I was explicitly looking for that effect but still missed it when there's only text. Indeed; subtle :)
<nckx>I notice the slowness the most when resizing the window. I guess that re-renders everything, so everything's suspect, but I noticed it now also resizes the text. That might be innocent though.
<mirai>ConvolutedSquare: can you share your config.scm?
<nckx>By the way, if you reduce the window width to 683px, you'll notice that the main table rows get ‘clipped’ on the right (the badges are almost on the border) until you mouseover them.
<nckx>Disabling backdrop-filter doesn't give the performance boost I was hoping for.
<rekado>there’s also the “body > nav” rule with background-color
<rekado>does it help to set that to anything opaque?
<nckx>I tried unsetting it, but not setting it to something opaque. Se.c
<n8henrie>Hello -- I'm trying my first guix install on hardware on an old Acer laptop. The installer image seems to work fine, but when I reboot into the installed image I try to log in with `root` and it flashes `Error in service module` and returns to the login screen. Any ideas? https://paste.debian.net/hidden/78313f40/
<Kolev>rekado: I will try it and report.
<rekado>I can reproduce the clipping. Not sure why it happens. Will investigate.
<jas4711[m]><nckx> "Try (kernel-arguments (list "ath..." <- Ah, of course, thank you! I ended up appending it to %default-kernel-arguments, is that usually not used? Anyway, it felt safer
<rekado>the table contents just spill over the article container.
<n8henrie>Using v1.4.0, built locally from source.
<nckx>jas4711[m]: Good catch. ‘Safer’, meh: IIRC it's just ‘quiet’ and some hardware blacklist stuff, both of I prefer controlling myself.
<nckx>*of which
<nckx>rekado: It's really hard to say… maybe? Maybe placebo? It takes multiple seconds to render in both cases. I'm looking at https://issues.guix.gnu.org/56046 specifically. The home page renders faster.
<nckx>The context is an i7-3520M CPU running at 2.90GHz with a load average of 12 for 4 cores, so I don't expect it to be ‘fast’. But it does seem noticably slower, at least on that page.
<nckx>Would be nice to have the old CSS to compare, but that's probably too much effort.
<nckx>8, not 12.
<rekado>nckx: ah, good, I can reproduce this here with icecat.
<rekado>(I’m compiling ceph in the background, so I guess this is somewhat comparable to your situation)
<nckx>:)
<rekado>the page itself is very heavy
<morganw>I was also having some weird rendering issues with issues.guix.gnu.org in icecat. It seemed to break the rendering, even the tab titles stopped being drawn. Other sites seemed OK though.
<ConvolutedSquare>mirai: https://privatebin.net/?d4754aa71ecb7e90#5GzENQhtJPvzuVUqLmrNSoxZwXNwapPK3bhu6AvgDPrR
<rekado>morganw: any particular URL?
<ConvolutedSquare>mirai: lsblk -fs output: https://privatebin.net/?e2ddb8bcb13f234c#3SrSWQnoBFrSpjN76E5oTmyiM6gEpHcdGutyPrQ57EaB
<nckx>Now that I haven't noticed (yet?).
<morganw>rekado: just the front page would break it
<morganw>lechner: Thank you again for your help with submitting a patch, the mail did get picked up the next day.
<nckx>rekado: Does it render that much faster on Chromium?
<nckx>On a different note: has anyone created a regular video DVD using software in Guix? Ideally — very ideally — from the command line. It doesn't need to have menus, it can go straight to playing video, but it has to be compatible.
<singpolyma>I have done this with free software, I am not sure if it is in guix or no
<patrick26>+Hey I just got a Taurinux X200 for Christmas for my wife. It only has 2GB of Ram and 160 GB Harddrive, is this enough to build guix from the source?
<nckx>So not just an MPEG-2 stream on an ISO even if the hardware could technically play it.
<nckx>singpolyma: Ah! Which?
<nckx>s/stream/file/
<rekado>nckx: I don’t know about chromium. Just fired it up to see the blur.
<nckx>Ah, there's a package called dvdstyler in Guix that promises to do this…
<rekado>I’ll try later tonight to figure out why this issue page in particular renders so very poorly.
<singpolyma>nckx: yes, pretty sure that's what I've used
<rekado>a little surprising because it’s *less* markup than before.
<rekado>and fewer CSS rules, too.
<nckx>Thanks singpolyma, good to know I won't waste time at least. The drawback of a GUI tool is that I can't run it on a much faster server. Let's hope it doesn't need one.
<nckx>rekado: Interesting. It doesn't look that way! (=good.)
<gnucode>nckx, I liked your mark 'y' for ___ on your driver's license joke earlier. :) Also, I feel like it's probably my job to try to get my patch to apply. Rather than you to go out of your way to pull a commit from my guixrus repo. :) I'll try to do some merge stuff later. BUT I feel like I should probably be spending time with the family right now. Merry Christmas by the way! Do you want anything this year? Movie recommendation?
<gnucode>Book recommendation?
<nckx>patrick26: I think you'll just about manage, but it's on the very lowest end of hardware that's realistically able to do so. You'll definitely want to add some swap, and since this is a HDD, it will be doubly slow.
<nckx>And that's just for Guix + a basic system. You won't be able to build a mOdeRN brOWseR.
<patrick26>nckx: okay thanks, so I better go the binary route then. It currently running trisquel
<mirai>ConvolutedSquare: usually targets is /boot/efi (for EFI systems)
<mirai>and if EFI, needs to be fat32 formatted as well
<nckx>gnucode: I don't mind pulling from your repo, or helping you get your patch merged, but yes: resolving someone else's conflicts is almost always an order of magnitude harder than resolving your own. You know your code. Someone else will have to cross-reference each change, basically re-applying your patch by hand.
<nckx>And yes, family time now. Guix is for the 51 other weeks of the year. Go!
<ConvolutedSquare>mirai: so I have to use EFI?
<nckx>patrick26: I think I'd recommend installing Guix on Trisquel first (https://guix-install.sh). It's less integrated, and has some weird edge cases, but at least you can get used to some of the concepts first.
<nckx>Ef. https://paste.debian.net/plainh/5a134109
<patrick26>nckx: what do you mean, running it on Trisquel?
<nckx>Never mind, I thought you wanted to run Guix System (Guix as an OS, rather than a package manager).
<nckx>But you did not say that.
<nckx>When you say ‘from source’, do you mean using a Trisquel toolchain to build Guix from a git checkout?
<patrick26>nckx: I just got this laptop today it came pre-installed with Trisquel and I wanted to try out Guiz as an OS on it. From reading it seems everything has to be built from source which I prefer. Just didn't know if my system could handle it
<nckx>OK, so. Guix can be used as a package manager on top of Trisquel (so you can install packages with Guix or Trisquel). There's also a complete OS built with Guix, called Guix System. But the operation of both is the same: when you ask Guix to install a package, it will first check whether a binary has already been built by our servers. Only if no binary is available yet, will it build the package(s) from source. Unless you disable this feature, you will not be
<nckx>building *everything* from source, but you will occassionally build something that the servers haven't finished yet.
<nckx>To mitigate this, you can run ‘guix pull’ (which is like ‘apt update’, I think), then wait a day or so, then run ‘guix install’ or ‘guix upgrade’ etc.
<nckx>(There are other ways around this, but they are more complex.)
<nckx>There is currently no easy way to ask Guix to always build some packages from source, but not others, or to refuse to build certain heavy-weight packages (like Icecat) from source.
<lilyp>There is actually a quite easy way to certain packages from source always: Transform them to add a noop phase at any point :)
<nckx>> (There are other ways around this, but they are more complex.)
<nckx>To us, it's ‘quite easy’, but… :)
<patrick26>lol, I continue reading the reference manual for now.
<ConvolutedSquare>mirai: I formatted my /dev/sde1 as FAT32, how would guix know that /boot/efi should be on /dev/sde1? Do i need to mount it there?
<nckx>Yes.
<lilyp>ConvolutedSquare: In your config.scm, add (file-system (device ...) (mount-point "/boot/efi") (type "vfat"))
<nckx>As /mnt/boot/efi (but use /boot/efi in your system configuration).
<ConvolutedSquare>Got it, thanks guys
<ConvolutedSquare>How come every time I run "guix system init" it needs to download all the packages again? Shouldnt they all be in the store already from previous runs?
<nckx>Mostly, yes, assuming they are the exact same builds. The installer image's store is ephemeral, though (/mnt/gnu/store is *not* authoritative during installation and will not be re-used). You're not rebooting between runs?
<nckx>ACTION has to run.
<ConvolutedSquare>I am rebooting between runs, so that explains it. I assumed it would be checking the destination for an existing store. If I have to run it again, can I cp -pr /mnt/gnu/store /gnu/store to save time?
<ConvolutedSquare>mirai: Booting with EFI ended up giving me the same grub error :<
<ecbrown>nckx had to run, so i will muse: is /mnt emphemeral?
<ecbrown>(during install)
<ConvolutedSquare>Nope, I mount my BTRFS RAID 10 to /mnt for installation, and all the files definitely persist
<ConvolutedSquare>It feels like grub just doesn't know what BTRFS is? Do I need to configure some additional module for it or something?
<lilyp>Grub should definitely know about btrfs, though it might not know about your raid 10 setup
<lilyp>For the record, what's your config.scm look like?
<ConvolutedSquare>lilyp: https://privatebin.net/?6dab51cc764ae9e6#LLrqJtaKs5EQ2A9Vuk1f1p1Qybzw2chuVq8RVJKMVhh
<lilyp>and you made sure to actually label your filesystems, right?
<ConvolutedSquare>Yep
<ConvolutedSquare>Grub says "error: no such device f7700ce8..."(correct UUID), and "unknown filesystem"
<lilyp>what about the raid thing? why is that not mentioned in the config?
<lilyp>see raid-device-mapping in 12.4. Mapped devices
<ConvolutedSquare>... it needs to be? When I mount it manually I just run "mount LABEL=root /mnt" without any options
<ConvolutedSquare>Ok I'll check it out
<ConvolutedSquare>lilyp: that section doesn't mention BTRFS at all, only mdadm raid
<civodul>ACTION tries updating guile-fibers
<Kolev>Installing Guix on server. Testing Podman.
<the_tubular>You'd probably be better with Docker Kolev
<GNUtoo>ok, still now news of my patches, I'll try to send them 1 by one separately then
<GNUtoo>ahh there are several addresses in the manual, maybe the one in the commands doesn't work while the old one works
<Kolev>the_tubular: Docker :(
<the_tubular>Podman relies heavily on systemd
<Kolev>:(
<the_tubular>What's wrong with docker ?
<Kolev>the_tubular: Podman is better.
<Kolev>the_tubular: No root.
<Kolev>I guess if I have to use Docker...
<the_tubular>I mean, you can try podman
<GNUtoo>About docker the main issue I found is more with dockerhub: (1) It has non-fsdg compliant images, (2) it's controlled by a company so it doesn't have the same security/trust model than community projects. And it's also widely used so that create issue for us. But we at least can generate perfectly fine docker images with Guix.
<the_tubular>You don't have to use dockerhub with docker
<GNUtoo>indeed
<the_tubular>Podman on guix is barely usable
<the_tubular>I've tried for months lol
<the_tubular>Too reliant on systemd stuff, can't even restart a container without it ...
<the_tubular>Plus all the networking stuff was borked last I tried it
<the_tubular>Can't bind a port to your host
<the_tubular>Also the daemon doesn't have to run as root AFAIK.
<GNUtoo>So if I send a patch to guix-patches@gnu.org I've the acknowledgement really fast, witin minutes
<the_tubular>On another subject, is there any program about guix mentorship ?
<GNUtoo>If I send to guix-patches@debbugs.gnu.org instead, I can wait so many days, and nothing happens
<the_tubular>I feel like i hit a cap :(
<Kolev>I'm having issues with Secure Boot. It won't let me boot Guix.
<GNUtoo>The second address is in examples commands in the manual, for sending the first patch, in the "Multiple patch" section
<civodul>the_tubular: hi! re mentoring, there's a "mentor" team, see https://guix.gnu.org/manual/devel/en/html_node/Teams.html
<ConvolutedSquare>Isn't singularity a viable alternative to docker on guix?
<the_tubular>Thanks civodul, also congratz for 1.4 release :)
<civodul>congrats to all the geeks :-)
<civodul>the_tubular: re podman, did you report an issue?
<Kolev>My server needs to run Jellyfin and thelounge.chat.
<civodul>i saw something about subordinate IDs somewhere
<Kolev>I think I'll put RHEL on the server and Guix System on the laptop.
<nckx>the_tubular: Mentors, but little in the form of ‘program’.
<ConvolutedSquare>Been playing with it for a few hours now and I still can't figure out why grub doesnt like my BTRFS setup :<
<nckx>ACTION has taken the time machine to 2021 but still no building dvdstyler.
<nckx>I think milano (a Guix build machine) uses raid10, but apparently also BIOS. Not that that should® matter…
<nckx>(I certainly dont suggest going through the trouble of checking just based on that.)
<ConvolutedSquare>Well i was originally using BIOS, but someone here suggested I tried EFI. Both dont work.
<nckx>ACTION wonders if lechner's bot could ask people not to use privatebin and similar arbitrary blob executioners.
<nckx>ConvolutedSquare: Hah. OK.
<ConvolutedSquare>nckx: apologies, where should i paste code snippets in the future?
<the_tubular>civodul I think i've seen an issue related to podman, not made by me though
<GNUtoo>ACTION has sent a bug report as I didn't find another people who also reported that.
<nckx>ConvolutedSquare: We generally recommend paste.debian.net, but it was not meant as criticism of you.
<the_tubular>But yeah podman, the package is broken in multiple ways
<civodul>bug report, bug report! :-)
<the_tubular>Let me check, but there's already one AFAIK
<nckx>Privatebin is just particularly nasty as it tries to run arbitrary binaries in the viewer's browser.
<ConvolutedSquare>I was under the impression it's open source software
<_Random>Hi, I've successfully installed 1.4 Guix, Managed to get past the guix pkg settings. What do I need to do be able to edit my fstab, unable to save regardless, even if i'm in # or sudo
<ConvolutedSquare>But I will use paste.debian.net from now on, thank you :)
<nckx>Possible, but I'm not going to disassemble blobs to verify that.
<the_tubular>What really nckx ?
<_Random>I'm new here & not that technical, I've come from a gentoo binary flavour Redcore (openrc)
<GNUtoo>_Random: you want to do that permanently or temporarily?
<lechner>ConvolutedSquare / please don't use privatebin. just kidding! do you have all GRUB modules installed? Can you boot manually from the GRUB shell with insmod normal and then ls ?
<the_tubular>You are at the right place _Random :)
<_Random>permanently
<GNUtoo>_Random: Basically the fstab is generated by Guix configuration system, so you should have a system.scm or config.scm somewhere. You need to edit that file to get fstab modified.
<GNUtoo>That configuration is probably in /run/current-system/configuration.scm once your system is booted
<lechner>nckx / Hi, following rekado's suggestion, i am switching the bot to wonderfully simple and reliable guile-irc. will accept feature suggestion once its deployed
<lechner>sorry about the typos
<GNUtoo>So you can copy that, edit it, and run sudo guix system reconfigure configuration.scm and after that I'm not sure if you need to reboot or not
<_Random>I will need help down the track need top learn how to use scripts to install; pkg's, but that will be after I configure my printers, Firewall & iether install torbrowser or configure a browser so I don't have dns leaks
<GNUtoo>For torbrowser I've something that works but it's a bit rough
<nckx>guix time-machine is eaten by a dinosaur: ‘error: %environment-options: unbound variable’
<nckx>ACTION goes deeper.
<_Random>thanks GNUtoo :) will look for it now, to you & everyone thanks for the help
<ConvolutedSquare>lechner: how do I verify that I have the GRUB modules installed? I haven't manually configured anything about GRUB. Running "insmod normal" returns "error: unknown filesystem", "ls" returns "(hd0) (hd1) (hd2)". That second output is quite curious, I should only have 2 filesystems.
<GNUtoo>btw, the tor-browser has an issues with addons: it points to a repository that also has nonfree addons, but it also advise people not to install addons (because addons can deanonimize people)
<lechner>ConvolutedSquare / Hi, how about ls (hd0) ?
<_Random>GNUtoo: so how can I modify a browser so I don't have dns leaks
<lechner>the extra disk is a christmas gift
<ConvolutedSquare>lechner: "(hd0): Filesystem is unknown."
<ConvolutedSquare>i wish santa would give me some 4TB SSDs as a christmas gift ^^
<GNUtoo> https://framagit.org/GNUtoo/machines_configs/-/raw/guix/system.scm/primary_laptop/usr/local/bin/tor-browser is what I use
<lechner>they left
<GNUtoo>ah ok
<GNUtoo>ACTION bookmarks the link to be faster next time
<lechner>ACTION is googleing the command to list the available GRUB modules
<GNUtoo>hmmm I probably need to fix the #!
<Mystified>oops, dropped out, Forgot tah I'm runnning konversation via console
<GNUtoo>lechner: is it lsmod (ideally after PAGER=1) ?
<GNUtoo>*set PAGER=1
<lechner>in GRUB?
<lechner>could be. i'm brushing my teeth at the same time
<nckx>That lists the loaded ones.
<nckx>Now, if you don't have $prefix, there are no ‘available’ ones, so problem solved :-/
<GNUtoo>ah right
<nckx>(Have as in accessible.)
<nckx>Can you ‘ls $prefix’, ConvolutedSquare?
<ConvolutedSquare>"Unknown command `lsmod'."
<ConvolutedSquare>nckx: error: unknown filesystem
<nckx><lsmod> Chicken, meet egg. Must be a loadable module.
<nckx> https://www.gnu.org/software/grub/manual/grub/html_node/lsmod.html
<ConvolutedSquare>I dont like GRUB :<
<nckx>What does ls say for the other two drives? (hd1) and (hd2)? (No trailing ‘/’).
<ConvolutedSquare>(hdX): Filesystem is unknown. error: unknown DISKFILTER device hd2
<ConvolutedSquare>(it says hd2 for both ls commands)
<GNUtoo>what about "set root=hd2,gpt1" and "ls /" ?
<GNUtoo>usually you have partitions on disks, if it doesn't see the partitions there is probably something wrong
<GNUtoo>you could try "normal" and some insmod
<nckx>(What is $prefix, anyway?)
<GNUtoo>it's needed for finding modules
<nckx>Sorry, I meant ‘what is its value’. I wonder what GRUB thinks the world should look like.
<ConvolutedSquare>When I use a btrfs raid, are there supposed to be partitions? Earlier I dont recall seeing any.
<nckx>Depends on what you added to the ‘raid’?
<nckx>It's generally recommended to use partitions, but not mandatory.
<ConvolutedSquare>and running the "ls /" returns "error: no such partition"
<nckx>And ‘echo $prefix’?
<ConvolutedSquare>I added /dev/sd{a,b,c,d} to the raid 10.
<ConvolutedSquare>Unknown command echo
<ConvolutedSquare>Same for "normal"
<nckx><I added…> OK. That's unusual, but should work. Still, I'd try a more usual /dev/sd{a,b,c,d}1 (or whatever) set-up first.
<GNUtoo>on one of my computers with Guix, prefix is (cryptouuid/<some uuid>)/boot/grub
<Mystified>I've found "configuration.scm" is this where I edit & mount my partitions https://paste.debian.net/1265108 ?
<nckx>Yep.
<GNUtoo>and if I do ls $prefix/ it prints "i386-pc/ grub.cfg locale/ fonts/ grubenv"
<ConvolutedSquare>I'll try partitioning them then. Didn't think it would be an issue since Linux handled it just fine.
<GNUtoo>So the modules are in i386-pc/ somewhere so it matches
<nckx>GNUtoo: That's more or less what we'd expect to see here (although i386-pc is BIOS), and minus the crypto.
<GNUtoo>Mystified: are you _Random ?
<nckx>ConvolutedSquare: Yeah, and so should GRUB, but let's rule out at least one thing. Too many unknowns otherwise.
<GNUtoo>That computer uses SeaBIOS so that's why
<nckx>Is SeaBIOS a pun?
<lechner>ConvolutedSquare / Hi, have you operated Btrfs RAID volumes before?
<oriansj>ConvolutedSquare: are you trying to mount a luks2 partition with grub?
<GNUtoo>I've no idea but it's a BIOS implementation used with Coreboot, Qemu and it can even run as CSM (Compatibility software module) in UEFIs like Tianocore to provide the BIOS compatibility
<ConvolutedSquare>lechner: nope
<ConvolutedSquare>oriansj: nope
<nckx>GNUtoo: I know. I use it :)
<GNUtoo>ACTION didn't try to use it as CSM yet
<nckx>Wiki: ‘…to be based on an improved and more easily extendable internal source code implementation.’ So could be C.
<nckx>‘Written in C’.
<nckx>Another subtle hint.