IRC channel logs

2023-10-03.log

back to list of logs

<RavenJoad>avalos / mirai: A bit specific, but some people were talking about it and I have a QMK keyboard that would be nice to make reproducible too.
<minima>hi, sorry, i was looking at https://git.savannah.gnu.org/cgit/guix.git/tree/gnu/packages/irc.scm#n993
<peanuts>"irc.scm\packages\gnu - guix.git - GNU Guix and GNU Guix System" https://git.savannah.gnu.org/cgit/guix.git/tree/gnu/packages/irc.scm#n993
<minima>the `(chmod "snuik" #o755)' bit, shouldn't it rather be `(chmod "bin/snuik" #o755)'?
<minima>i'm not saying this is manifesting itself as a bug - i haven't checked - but if it doesn't... why?
<lechner>minima / i think i agree. maybe wrap-program also sets that bit.
<minima>lechner: ah i see, so that line might simply be some harmless leftover
<lechner>maybe snuik.sh from a few lines up is already +x
<lechner>or maybe this command originally applied to snuik.sh
<lechner>not sure why there is no error. it's also possible that ./snuik is a directory, which would likewise be +x
<minima>ah, i'm looking at `wrap-program', i think you're right, the way the final script is build... there might not be the need for the original program to be +x
<lechner>my personal preference would be to correct the line like you suggested. i am sure someone will accept your patch
<lechner>civodul / hurray for the cuirass changes!
<anthk_>guile has a posix library?
<civodul>let’s see if it’s good enough to avoid huge backlogs :-)
<civodul>anthk_: yes, in Guile proper
<RavenJoad>What were the cuirass changes?
<apteryx>mirai: I think 'S W' from an ephemeral Gnus buffer
<apteryx>for Debbugs doesn't do what I expected (which is send a wide reply)
<apteryx>C-h k W S suggests it does gnus-summary-force-verify-and-decrypt, which is unexpected
<mirai>`W S' or `S W' ?
<mirai>the latter is for replying
<mirai>no idea what the former does
<mirai>`force verify and decrypt' sounds like something completely unrelated to `reply'
<apteryx>ah, S W, brainfart, sorry :-)
<apteryx>ok, so S W in a Emacs Debbugs bugs *is* bound to gnus-summary-wide-reply-with-original
<apteryx>I'm not sure yet as to what causes its behavior to be different there compared to in my INBOX, say
<apteryx>i'm guessing gnus-summary-work-articles may have something to do with it
<apteryx>mirai: nope, I don't get it, even after tracing in edebugs
<apteryx>edebug*
<jaeme>How would one run guix lint -n on every package definition in a given source file?
<jaeme>I don't see a full file option like guix style
<jaeme>Must I write a shell script to do it for me?
<apteryx>mirai: ah, found the culprit
<apteryx>it's this condition in gnus/message.el's message-setup: (not (and message-this-is-mail mua))
<apteryx>it's true (considered not an email) thus skip the next block which would normally set things like the Subject field etc.
<lilyp>jaeme: don't
<apteryx>I think in the Debbugs article case it should consider it a message, I'll see if that can be changed
<lilyp>just don't
<jaeme>lilyp: wynaut?
<lilyp>you'll end up discarding many of the changes anyway (it's not particularly the best in terms of indentation, sadly, still)
<lilyp>style up the packages as you edit them, but watch out for gratuitous changes
<jaeme>I was just thinking of doing bulk lints because I have well over 300 crates that I'm sure I did not write good synopsis' and descriptions for.
<jaeme>But I see where thats coming from
<lilyp>guix style won't write better ones IIRC
<jaeme>I still don't know how I want to write patches for all those crates
<jaeme>Also its my first time writing patches haha
<lilyp>you could write a script that goes over your diff, extracts package names and passes those off as options to guix lint
<jaeme>I see
<lilyp>that should at least tell you where you need to watch out for incomplete sentences and stuff
<lilyp>or you could like remember their names
<lilyp>(shell history)
<jaeme>Im just kinda bummed out that the package I wrote all those dependencies for requires a newer rust compiler (waiting game) and has a broken toml file (also waiting game after writing an issue ticket). So I'm stuck with 300+ crates now.
<adanska>hi! does anyone know how to inspect a guile object's fields, ect in the repl?
<janneke>adanska: if an object is a record, then with record accessors
<janneke>(package-source $package)
<adanska>righhht. is there a way to simply show all of the record's fields without knowing the field names?
<adanska>ah. i guess if the record is opaque then no...
<janneke>adanska: you can always do something like (struct-ref $package 0)
<adanska>i guess. is there something like the common lisp debugger where you can interactively inspect data structures?
<adanska>i get the workflow (kinda) for working on packages in the core guix source tree. how do i go about doing a similar thing with user defined channels? do i have to add the channel to my profile and remove the upstream one or is there a better way of doing this?
<adanska>it just seems like a very big time waste waiting for guix pull to finish each time i want to test a change
<adanska>its not like that when using ./pre-inst-env
<efraim>you can use -L /path/to/other/channel, so 'guix build -L /path/to/other/channel my-other-package'
<adanska>ah, awesome! i was using the option wrong haha
<rekado>adanska: you can set GUIX_PACKAGE_PATH if you don’t want to pass -L all the time
<adanska>ahh cool :)
<adanska>thank you
<efraim>guix.vim uses GUIX_PACKAGE_PATH
<adanska>how do you deal with your profile including the upstream of the channel your hacking on?
<adanska>the channel thats part of your profile seems to have precedence over the one you supply with -L
<efraim>I guess I just don't, I've never added any other channels to my default guix and I've always just used -L
<efraim>or had a special purpose profile with the extra channels for use when deploying
<efraim>so I guess that's not so helpful
<adanska>i guess the only way id know how is just to create a bare guix profile and use that in conjuction with -L, but this seems unergonomic
<cbaines>woo, bordeaux has built gcc-11.3.0 for the hurd https://data.guix.gnu.org/gnu/store/8sb36kzy0jcdnrv7qji2gbkmc4xbhfil-gcc-11.3.0.drv
<peanuts>"Guix Data Service" https://data.guix.gnu.org/gnu/store/8sb36kzy0jcdnrv7qji2gbkmc4xbhfil-gcc-11.3.0.drv
<cbaines>I've got all the childhurds running with 4GiB of RAM now, so maybe that helped
<minima>hi, i get an error when i try to set up my project to build with `guix build -f guix.scm', i.e. paragraph "Level 1: Building with Guix" https://guix.gnu.org/en/blog/2023/from-development-environments-to-continuous-integrationthe-ultimate-guide-to-software-development-with-guix/
<minima>the error says: `no code for module (gnu packages)'
<minima>or whatever import is listed first in my guix.scm
<bdju>did someone break gcc recently? can't seem to build some stuff with `make` now. `cc` links to nothing (can't recall if it used to link to something but someone had me check that)
<minima>by looking at the logs, it seems that `guix build -f guix.scm' tries to build `guix.scm' itself
<minima>that might be because i'm using `(source (local-file "." "my-proj-checkout" #:recursive? #t #:select? (const #t)))'?
<minima>since this is not a git checkout yet i thought of using `(const #t)'
<minima>but maybe that causes the builder to "ingest" too much of my project?
<adanska>does anyone have any idea on when linux-libre 6.5 will become the default kernel?
<minima>ok, i've added a `#:select? (lambda (f _) (not (string-contains f "guix.scm")))' which would seem to bring me past the above issue
<minima>just a temp hack, ofc
<minima>ok, it's built successfully now, with `guix build -f guix.scm' - sorry, how do i launch a shell environment that contains that package now?
<minima>`guix shell --container --link-profile' (w/o any further args) will launch an env, but i think that's the development env, isn't it?
<minima>oh i probably need to make it a module
<minima>in guix.scm
<minima>let me try
<minima>ok, it works now - still unsure why i need to explicitly skip `guix.scm', i'm probably doing something wrong, but at least i have a min working version now
<jakiki6>Hey, I've been running plasma for a while now and I've noticed that it doesn't keep any settings I changed after I rebooted. Does anyone know why?
<apteryx>jaeme: adding a new rust compiler is not particularly difficult if you have a powerful
<apteryx>powerful enough machine to build rust
<apteryx>the
<apteryx>the manual labors involved are
<apteryx>are mostly moving the test specific / extra features to whatever latest rust you add from the current last one
<minima>(update re my issue with guix.scm being picked up by the build system - i think it's because i'm using the guile-build-system!)
<apteryx>the intermediate chained rusts should be as bare bone as possible (built for speed) and not be public.
<apteryx>what about the broken toml parser? is this a guix issue?
<phf>Hello #guix! I am building mix-build-system. I'm stumbling upon this error ~no code for module (gnutls)~. Here are a few logs: https://paste.debian.net/1293872/. How to have Guile to take into account ~(gnutls)~?
<peanuts>"debian Pastezone" https://paste.debian.net/1293872
<superkamiguru>Does anyone happen to have mobile broadband working on their install? I have a card that is supported/works in other libre distros like Trisquel, but in Guix the connection just resets over and over.
<anthk_>superkamiguru: could it be usb power related?
<superkamiguru>It is an M.2 card in a laptop, would that still be affected by usb power?
<anthk_>ah, I think not
<anthk_>but a lot of network devices have power related flags with ip/ifconfig
<superkamiguru>What's weird is after booting a live usb of Trisquel, I set up the mobile broadband connection and it worked, rebooted to Guix and it also worked......once. After reboot it went back to constantly resetting
<anthk_>and network manager had a flag for the config file
<anthk_>ah, just for wireless :(
<anthk_>in [connection], below
<anthk_>wifi.powersave = 2
<anthk_>but idk about other kinds of devices
<anthk_>I guess it uses modem manager right?
<superkamiguru>Yeah, I was looking through the docs and it seems that the modem manager service is included in %desktop-services
<superkamiguru>But the only config option I saw was for changing the package used in the service
<anthk_>could be permissions related?
<superkamiguru>I tried connecting with nmtui under the root user, is there another method I should try to resolve potential permission issues?
<mirai>apteryx: re emacs-debbugs: nice!
<mirai>phf: there's no (guix build-system mix) ?
<Guest76>yay, bumping elixir to 1.15.6 w/ base32 '19vhci9dxdm3sb937ba3np5gadgfcsnrnc30n17c4xk556mk473r' and it installed successfully, guix rocks :)
<phf>mirai: well, i'm trying to build one. So far, (guix build-system mix) looks like that: https://paste.debian.net/1293880/
<peanuts>"debian Pastezone" https://paste.debian.net/1293880
<mirai>you would need guile-gnutls (the package)
<mirai>it's what provides (gnutls)
<mirai>do you really need it in the build system though?
<apteryx>Guest76: run etc/committer.scm, ensure dependents (guix refresh -rl elixir) still builds and send a patch with 'git send-email -1' :-)
<mirai>ah, I see you're using a custom downloader `hexpm-uri'
<phf>mirai: it's for testing purposes. Using ~guix shell --check --pure -D guix~ and ~ls -al $GUILE_LOAD_PATH~ we see that ~gnutls~ should be found by Guile using UILE_LOAD_PATH but it does not.
<mirai>see what guix/build/download.scm is doing for handling gnutls
<mirai>my mistake, you're still using uri-fetch
<mirai>url*
<phf>mirai: what's frustrating is that: ~./pre-inst-env guile -c '(use-modules (gnutls))'~ works but not ~./pre-inst-env guix build --no-substitutes -f elixir-kv.scm~
<phf>mirai: ok, looking at guix/build/download.scm
<mirai>Is `mumi' package the web frontend for issues.guix?
<mirai>or is it the cli tool
<apteryx>both
<apteryx>mirai: when replying from my Gnus INBOX message-this-is-mail is t but from Debbugs it's nil, which causes the discrepancy
<apteryx>err, it's true in both cases... must be 'mua' then
<apteryx>eh, most strange, both code paths go through (message-setup-1 headers yank-action actions return-action), but in one case it does the right thing. message-this-is-mail is t and (message-mail-user-agent) nil in both scenarios
<mirai>I've hit some strange gnus bugs when I was getting started with debbugs-emacs (e.g. #66106)
<peanuts>"28.2; Undo on yanked message fills message body with headers" https://issues.guix.gnu.org/66106
<jaeme>apteryx: swww's Cargo.toml file doesn't list the version number for a local crate dependency. Thus cargo package fails. This is due to the fact that swww was never uploaded to crates dot io and thus it always stayed as a git repo. Not a guix problem I think.
<mirai>I wouldn't be surprised if there are other strange things lurking around
<avalenn>rekado: http://logs.guix.gnu.org/guix/search?query=guix is still stuck in January
<peanuts>"Search guix IRC channel logs" http://logs.guix.gnu.org/guix/search?query=guix
<minima>hi, i have a simple foobar.scm guile script that i've been trying to package with the guile-build-system
<minima>here's a section from my package definition https://bpa.st/L6UA
<peanuts>"View paste L6UA" https://bpa.st/L6UA
<adanska>hi! i sent an email to the guix-devel@gnu.org mailing list, but i dont think my email went through... it isn't appearing on the archive and i sent it about 3 hours ago. i'm signed up to the mailing list, and this is my first email that i've sent there. is there some sort of manual audit that takes place with new messages or has something gone wrong?
<minima>if it's a single scheme script, i'm not even sure it makes sense to use guile-build-system as opposed to copy-build-system
<adanska>is there some format settings i need to change on my email client? im using icedove
<minima>my package definition builds correctly but the script foobar is not in path
<minima>i've been trying to use various variations of wrap-program, install-file, etc... (and i even got it work at some point)
<apteryx>what's the url to fetch /gnu/store/fccvd7dvq38l63p487psaz4zzgqcp5sm-icecat-102.15.0-guix0-preview1.tar.xz from a substitute server?
<apteryx>manually via wget say
<apteryx>jaeme: fun ^^'
<cbaines>apteryx, the proper approach is to request the narinfo, then find the URL in that
<cbaines>but both bordeaux and ci use the form /nar/COMPRESSION/... and you omit compression if it's uncompressed
<cbaines>ci has the uncompressed nar, so you'd request /nar/fccvd7dvq38l63p487psaz4zzgqcp5sm-icecat-102.15.0-guix0-preview1.tar.xz
<apteryx>but assuming I know I want it through berlin, and I know berlin has zstd, I could use always the zstd url safely right?
<cbaines>and bordeaux has it compressed, so you'd request /nar/lzip/fccvd7dvq38l63p487psaz4zzgqcp5sm-icecat-102.15.0-guix0-preview1.tar.xz
<podiki>is there a trick when using e.g. guix build -L when the directory also has worktrees? (to not include worktrees)
<Altadil>adanska: There is a manual check for the first email
<adanska>ah, cool :) thanks for letting me know
<cbaines>apteryx, nope, because the available compressions can vary between nars
<podiki>adanska: yes, there is manual moderation to first posts on some lists (not sure if all or which if so)
<apteryx>oh? that's a bit surprising to me
<adanska>thanks podiki )
<apteryx>I found the url is https://ci.guix.gnu.org/nar/fccvd7dvq38l63p487psaz4zzgqcp5sm-icecat-102.15.0-guix0-preview1.tar.xz
<apteryx>by actually trying to download it
<rekado>avalenn: I’m not working on it so it’s likely going to stay this way until somebody does
<apteryx>that means source archives are kept right under nar/ and not under a compression subdir?
<cbaines>apteryx, I think in the guix publish case, the idea is not to bother with compressing already compressed tarballs
<cbaines>see the use of actual-compressions and compressed-file?
<cbaines>apteryx, and note that there's an entirely separate way of requesting source archives by name and hash
<apteryx>cbaines: I see! That makes sense, thanks
<minima>a slightly revised version of my package definition for a single-script package: https://bpa.st/T7WA
<peanuts>"View paste T7WA" https://bpa.st/T7WA
<minima>i was going to ask a question, but i might have solved it already (i was starting a guix shell environment taking advantage of a local `guix.scm' - i was forgetting that that's similar to using `--development')
<cwebber>I've never looked but how does Guix calculate the build % anyway?
<cwebber>seems like a very difficult metric to predict
<efraim>I assumed there was some black magic involved
<user11>Hello. I've got Guix installed on a foreign distro. I've installed Geany on Guix but for some reason I can't launch it from GNOME's applications list on Wayland, whereas launching it from console works fine.
<user11>Using Xorg I'm able to launch it both from console and using the app list. Any ideas on how to get it to launch in GNOME Wayland?
<apteryx>uh, https://ci.guix.gnu.org/nar/fccvd7dvq38l63p487psaz4zzgqcp5sm-icecat-102.15.0-guix0-preview1.tar.xz gives a corrupted archive
<apteryx>cbaines: ^
<user11>(for reference I'm using GNOME 38 under Devuan 4 (Debian 11).
<user11>*3.38
<avalenn>rekado: how can I find someone able and motivated to fix IRC logs search ?
<geri>hey, how is xinit's startx supposed to be used?
<geri>it complains about `"/gnu/store/j19cygzs4vsah0sgivnnn2vb0qamcj24-xinit-1.4.2/bin/X": No such file or directory'
<mirai>avalenn: power of money ; “itch to scratch” ; learning opportunity
<avalenn>mirai: thanks, I have the "itch to scratch" but no idea whatsoever of how the thing works
<avalenn>"power of money
<avalenn>"power of money" is indeed on my todo list for several years, to put aside some money to finance project I'd like to move, but I never did
<avalenn>is there any way to limit the CPU (via cgroups ?) available to containers spawn by `guix shell` invokation ?
<minima>in a package definition, when i see `(modify-phases ... (add-after 'build 'check (lambda* (#:key tests? ... (when tests? (invoke ...))', what does the `tests?' refer to?
<geri>in which file is that?
<minima>anything i need to do for the tests to be run as part of the build process
<minima>geri: hold on, let me find an example
<minima>e.g.: guile-raw-strings
<geri>it seems to be a special argument you can provide in (arguments ...), that's used to determine whether or not to run testing scripts
<minima>thanks geri
<geri>i might be wrong :D
<minima>i guess that depends on the build system then?
<geri>`haunt' has it, in the same file
<minima>i mean, whether that's set as #t or #f by default
<geri>most likely
<minima>cool, let me check haunt - ty!
<geri>)
<minima>by the way, if we're correct, guile-raw-strings' tests are not executed - i wonder if that's expected
<geri>beats me
<geri>lemme check if i can understand em at all
<rekado>avalenn: FYI here’s the code of the log viewer: https://git.savannah.gnu.org/cgit/guix/maintenance.git/tree/hydra/goggles.scm
<peanuts>"goggles.scm\hydra - guix/maintenance.git - Articles, talks, and documents for Guix maintainers" https://git.savannah.gnu.org/cgit/guix/maintenance.git/tree/hydra/goggles.scm
<geri>doesnt seem too complicated, maybe someone just skimped on it
<minima>geri: i think it's possible to add a `#:tests?' flag, like haunt does, if you're under some build systems - e.g. gnu-build-system, but i think that might not be as straightforward with the guile-build-system... i *think*
<jpoiret>minima: almost all build systems inherit from gnu-build-system so they'll have it as well
<minima>jpoiret: oh amazing, thanks - do you know if that's the case for the guile-build-system too?
<minima>i think i can simply skip the `(when tests? ...)' bit (leaving the body)
<geri>minima: i see guile-build-system-modules is using some stuff from gnu build system, but im honestly not sure what it means :D
<minima>geri: thanks, very kind of you checking
<geri>np
<geri>anyone using an X wm without a display manager here? I'm very interested in neat examples of setting it up :D
<minima>hey, i am - i've been using a few different wms
<minima>no display manager
<minima>let me see if i can send an example
<geri>👍
<minima>for instance, have you tried putting `exec i3' in your `~/.xinitrc' and launching `startx' from a tty?
<minima>(using i3 as an example here)
<geri>startx just doesn't seem to work on guix
<geri>i know you can create a script to use xinit directly but that kinda hurts
<minima>startx works for me
<geri>hm
<minima>are you on guix or guix home? are you on a foreign distro?
<geri>well, i use it like `startx $(command -v bspwm)'
<geri>maybe this way is borked
<geri>guix system
<geri>lemme try that
<minima>startx works for me in this setup: guix home on a foreign distro - but i suppose it should work as fine on guix system
<geri>did you install xinit (startx) w/ native pm or guix itself?
<minima>all via guix (guix home)
<geri>huh, okay
<geri>magic :D
<minima>hm let me double-check that though
<geri>you probably wont even have /etc/X11 if you use it via guix
<minima>oh... ouch... sorry, no, `which startx' says that comes from the foreign distro - i'm so sorry
<geri>is fine, dw
<minima>geri: i think in the past i experimented with https://man.sr.ht/~kennylevinsen/greetd/
<minima>which might hide or solve some of the startx-related issues
<geri>yeah...
<geri>but it hurts my soul :D
<minima>lol, as in... it's a bit too minimalist?
<geri>opposite!
<geri>that said, im an emacs user, i can't complain B)
<minima>:)
<pastor>guys I'm trying to make one minor improvement on `guix weather`. Does anyone know how could I get a list of the `substitute-urls' field from the `guix-service-type' from the running system?
<geri>first time hearing `guix weather'
<geri>try (guix-configuration-substitute-urls your-service)
<geri>idk much about your "running system" part though
<geri>i use all services explicitly, if you need to rip out guix service type out of something like %base-services, idrk what to do there
<vivien>Well, I had another thing to change in eudev, so here goes another round of webkits
<pastor>geri: Thanks, but I don't think this is what I need
<pastor>I'm not configuring my system
<pastor>I'm trying to prvide a feature to a guix command. I need a way to know what are the substitutes configured by the user on the current running system
<pastor>I imagine this should not be that complicated. After all there are some commands that already make use of the substitutes currently configured.
<pastor>Is there maybe a way to fetch the current system configuration?
<pastor>I was thinking that maybe I could fetch the configuration with the idea of geri from `/run/current-system/configuration.scm` but as I see this is not always the full configuration. In my case I have the system configured I two parts using the `-L`. Is there a place in the system where I can get the full picture of the running config?
<ryan77627>Question: I'm trying to override a package in the guix repo with a new version (so I can dogfood it for a bit before upstreaming), is there a easier way to re-define the version and hash for a package without redefining the _entire_ source variable? I know I can just inherit the package and define the version var, but the hash is the problematic part
<ryan77627>like is there some variable that I can use inside source or origin and then just selectively redefine the sha256 part?
<pastor>ryan77627: I guess you can use transformation options
<pastor> https://guix.gnu.org/manual/en/html_node/Package-Transformation-Options.html
<peanuts>"Package Transformation Options (GNU Guix Reference Manual)" https://guix.gnu.org/manual/en/html_node/Package-Transformation-Options.html
<ryan77627>I see, there doesn't happen to be anything like this but with actual scheme files? I don't use `guix install` really since it isn't declarative across my systems (I like my two systems to be in exact lockstep)
<podiki>you don't need to install, you can use guix shell (transformation options are the same)
<podiki>and transformations are just scheme procedures of course, if you want to dig that way
<podiki>(you can get the hash of a package by getting the source record, but requires a few steps and more than what it sounds like you need here anyway)
<vivien>Working on the eudev/udev update #66099, I noticed that eudev considers <prefix>/etc as its sysconfdir, so there’s no point in installing stuff in /etc/udev. What a shame, since the udev-service-type installs everything useful in /etc/udev! Let’s see if we can add --sysconfdir=/etc
<peanuts>"[PATCH gnome-team 0/3] Update upower" https://issues.guix.gnu.org/66099
<vivien>And so, another round of webkit builds. See you tomorrow!
<vivien>Tagging lilyp to show I’m not forgetting our issue, even if I send no patch revisions yet
<vivien>(there are a few tweaks required to install the hwdb files in libexecdir, and to disable sanity checks that eudev enforces in sysconfdir)
<graywolf>Does guile-build-system not support running a test suite?
<graywolf>Is there a simple way to do so?
<lilyp>graywolf: the canonical way is (lambda* (#:key tests? #:allow-other-keys) (if tests? … (format #t "test suite not run~%")))
<lilyp>vivien: should we perhaps make lib/udev or share/udev the "canonical place" to look for?
<lilyp>I got a similar question for bash completions, which also are split among etc and share :)
<graywolf>lilyp: thanks for the snippet, but I admit I am bit unclear how/where to plug that into my package definition...
<graywolf>Or would that need to go inside guile-build-system?
<lilyp>you'd add a phase
<lilyp>but IIRC, guile like emacs just has #:tests? #f by default
<lilyp>ah, no, it actually deletes check, so you need to add it back
<vivien>lilyp, the canonical place to look for rules and hwdb is <prefix>/lib/udev, and is overriden by <prefix>/etc/udev [I propose to replace with /etc/udev], and, for rules, /run/udev, is searched last. I don’t understand why we would need share/udev
<lilyp>lib/udev it is
<lilyp>don't read too much into my words – when I'm unsure about stuff, I tend to list more possibilities that I can think of
<Gooberpatrol66>i have a local git repo and i'm able to git fetch it into another directory fine
<Gooberpatrol66>but if i put (url "file:///repo/path") in a git-reference in guix, it gives "fatal: '/repo/path' does not appear to be a git repository"
<Gooberpatrol66>is there some way to use a local dir as the source?
<graywolf>One more question, am I able to disable offload for the repl? ,build does not seem to take such a flag, is there something global I could set?
<gnucode>does the guix security team know about this glibc buy?
<gnucode>bug?
<gnucode> https://www.phoronix.com/news/Glibc-LD-Nasty-Root-Bug
<peanuts>"Glibc Dynamic Loader Hit By A Nasty Local Privilege Escalation Vulnerability - Phoronix" https://www.phoronix.com/news/Glibc-LD-Nasty-Root-Bug
<Noisytoot>Guix does seem to be affected by it
<mirai>Gooberpatrol66: there's a guix issue open on this already if you search in the tracker
<Gooberpatrol66>mirai: do you have a link or a name or something, i'm not finding anything
<mirai>#60494
<peanuts>"Document git-checkout" https://issues.guix.gnu.org/60494
<Gooberpatrol66>thanks
<Guest78>hey there, if my help-guix email hasnt been added to the archive after 15mins and i havent had an email of my own message ( i have the option enabled). Is my subscription definitely broken or could the service be down. I dont want to spam people by mistake
<gnucode>Guest78: I would give it a half hour to be sure.
<graywolf>lilyp: Just wanna thanks for the help with the 'check phase. One I read up on modify-phases, it clicked together. I am sure there is more elegant way, but https://paste.debian.net/1293947/ work for me and that is enough for now. So thanks again :)
<peanuts>"debian Pastezone" https://paste.debian.net/1293947
<Guest78>its been roughly 6 so gonna unsub and resub
<gnucode>also, I would definitely encourage you to hang out in this irc channel. but you probably want to use a more memorable nick.
<Guest78>ah ok will do
<gnucode>I think you can change your nick via "/nick YOURNEWNICK "
<Guest78>what client do you use?
<Guest78>im new to the older based workflows
<graywolf>weechat here
<gnucode>I personally use erc from emacs.
<Guest78>ah nice ty both :3
<gnucode>if you are talking email client, then I use gnus.
<gnucode>for mailing lists.