IRC channel logs

2022-11-06.log

back to list of logs

<pkill9>among other graphical desktop programs
<nckx>They sometimes break if I don't keep system and user profile in sync, but yes, otherwise they should Just Werk.
<nckx>mpv: Using hardware decoding (vaapi)
<nckx>That actually counts against my mismatch hypothesis. Dammit.
<podiki[m]>my next idea: use that whitelist generated by the icecat build to try to add to ld_library_path
<nckx>Yeah, and maybe add mesa/libva/… (if not already a subset of what's there).
<podiki[m]>and perhaps the top level of the package, since it wants to read things in the share folders as well...
<nckx>It's vaguely interesting that it's (libva's) ‘va_openDriver() returns -1’, not ‘Firefox cannot find this libva of which you speak’.
<nckx>So you'd have to add /run/current-system/profile/lib/dri/ as well.
<nckx>Which is more ick.
<nckx>Or s/add as well/try first/, I'm not 100% sure.
<nckx>I'm resisting the impulse to strace a modern browser because I think it will be traumatic.
<nckx>Plus, I have other work awaiting.
<nckx>Guess I should've checked whether I'd written a wrapper once: https://paste.debian.net/plainh/8d4d03c4
<nckx>Even added a helpful comment, sigh: https://paste.debian.net/plainh/6cdf2639
<nckx>Maybe this sandboxing came later.
<podiki[m]>i have a 14meg ld debug output
<podiki[m]>the rdd one is relatively new I think, yes
<nckx>Yeah, this code is from the (low) 9x era at the latest.
<nckx>Well, enjoy.
<podiki[m]>mine searches in other places, directly going to mesa's dri, at least says on output
<podiki[m]>haha thanks
<podiki[m]>alas, actual human nourishment awaits, I'll let you know if I figure it out with firefox and then look at icecat as well
<podiki[m]>ok nevermind just had to run it once more...
<podiki[m]>it works! added that whole sandbox whitelist to ld_library_path and see massively reduced cpu usage
<podiki[m]>next will be seeing why I'm not seeing libva output from icecat and debug there
<podiki[m]>after sorting out what is in this list that I missed and eating the human food
<pkill9>what did you add podiki[m]?
<podiki[m]>There's a sandbox whitelist set in the icecat build to follow all what's needed for some libraries (ffmpeg? Libva?), so I added that to the library path
<podiki[m]>Will check later what I missed from what Firefox was actually adding for
<Kabouik>That thing is cool: https://github.com/tsl0922/ttyd (it will allow me to access my emacs in -nw mode from the web and other machines, wheen needed). I just tested the prebuilt binary for now, but that could make a useful package.
<lechner>unmatched-paren cwebber: Hi, I really liked https://spritely.institute/static/papers/scheme-primer.html Should we mention it in the Guix docs, if that did not happen already?
<podiki[m]>I think it got linked?
<podiki[m]>linked in the cookbook
<kitty1>yoyoyo, hows it all been?
<user_oreloznog>hello guix!
<anschlussy>ahoy
<anschlussy>gonna install guix today, i think
<unmatched-paren>morning!
<anschlussy>i need to watch some videos first
<anschlussy>Also, why is KDE not available? The docs say "for a variety of reasons," but I'm curious
<unmatched-paren>anschlussy: There are patches on the mailing list for it
<user_oreloznog>hello unmatched-paren !
<unmatched-paren>anschlussy: They'll be a lot of work to review, though, so don't expect them to be merged anytime soon
<anschlussy>unmatched-paren: Does that mean there are patches that make it work? That's fun.
<anschlussy>I'm only curious what the original reasons were
<anschlussy>Do people have pipewire running?
<unmatched-paren>anschlussy: There are patches that add packages for the KDE desktop and a service for it
<unmatched-paren>we *do* have packages for a variety of KDE apps though, just not the desktop yet
<unmatched-paren>anschlussy: It's just that it's a lot of work and until recently no one had done it
<anschlussy>Do we know about how many people are using guix?
<unmatched-paren>nope
<anschlussy>I was running alpine as my minimalist type of machine. Does guix use systemd by default?
<unmatched-paren>nope
<unmatched-paren>it uses the GNU Shepherd, which was originally created for Hurd
<anschlussy>There are so many reasons why I already like guix; I might explode
<anschlussy>Do you prefer shepherd to sysvinit?
<unmatched-paren>as far as we know, Guix System is the only Linux distro that uses Shepherd... We use it because it's configured in Scheme and easy to integrate with Guix's services system
<unmatched-paren>anschlussy: yes
<unmatched-paren>i don't like shell scripts :)
<anschlussy>Should I learn scheme before or during installation? :^)
<anschlussy>Scheme, like other lisps, seems so easily understood
<unmatched-paren>you maybe could take a look at https://spritely.institute/static/papers/scheme-primer.html first to learn the basics
<unmatched-paren>but it's quite easy to pick up as you go along
<silicius>if you want to, but learn guile too since it's a very specific kind of scheme
<unmatched-paren>yeah, scheme is unfortunately one of the leass portable languages
<unmatched-paren>less
<unmatched-paren>most implementations have no choice but to implement extensions, since the R5RS scheme standard provides so little
<silicius>I wonder what would happen if common lisp was chosen instead of guile for guix
<unmatched-paren>although the newer R6RS and R7RS standards make it easier to write portable code
<unmatched-paren>guile was developed before they existed, so it has many, many extensions that would be very hard to stop using
<anschlussy>In what ways has that limited youZ?
<anschlussy>s/Z//
<unmatched-paren>it's not too limiting for guix, but it makes it hard to write libraries that work across multiple schemes
<unmatched-paren>anschlussy: https://www.gnu.org/software/guile/manual/html_node/index.html <- here's the guile manual (it's quite big ;))
<silicius>it's big, yet some stuff like the gexp library are in the guix manual
<unmatched-paren>yes; https://guix.gnu.org/manual/devel/en/html_node/
<unmatched-paren>make sure to always use the devel manual
<unmatched-paren>it follows the latest commit
<unmatched-paren>the release manual is for 1.3.0, which is ancient by now
<anschlussy>Does the urge to implement everything yourself come often to someone programming with schemes, since the habit in the language itself is to break things down to edible chunks?
<unmatched-paren>anschlussy: Not really "implement everything yourself".
<unmatched-paren>There are a lot of useful Guile libraries, and the Guile standard library is mahoosive owing to all those extensions.
<unmatched-paren>as you might expect, guix packages a lot of guile libraries; ``guix search guile'' shows guile-lzma, guile-zlib, guile-reader, guile-lzlib, guile-lib, guile-for-loops, guile-cv, guile-bytestructures, guile-gnome, guile-zstd, guile-threading-macros, guile-sqlite3, guile-smc, guile-readline, guile-jwt, guile-json, guile-git, guile-g-golf, guile-fibers, guile-dsv, guile-dbi, guile-commonmark, guile-bash, guile-sdl2, guile-gcrypt, guile-cairo, gu
<unmatched-paren>ile-xosd, guile-xcb, guile-xapian, guile-udev, guile-termios, guile-tap, guile-syntax-highlight, guile-srfi-158... et cetera.
<unmatched-paren>I didn't even realise there were so many of them :)
<kitty1>Only thing I would like more with guile is just slightly better documentation tbh
<anschlussy>kitty1, have you met a single project with good documentation?
<unmatched-paren>what's the problem with the documentation?
<unmatched-paren>guile seems to do quite well on that front, judging by the manual
<kitty1>that is fair, the documentation is decent, just was spoiled when I was playing with racket a bit recently lmao
<anschlussy>racket is pretty insane; i agree the documentation is the first part
<unmatched-paren>Ah, the one thing I would change about guile is the error reporting
<anschlussy>it helps that the author is a piece of shit academic
<unmatched-paren>it isn't very helpful for actually tracking down what the error is...
<anschlussy>ah, i hate that; that reminds me of sepples
<unmatched-paren>that said, i haven't ever seen a scheme with good error reporting; i once had a look at chez and racket errors, and they didn't seem to have it much better
<anschlussy>is there a systemic reason why?
<kitty1>just write better code /s
<unmatched-paren>anschlussy: no idea
<kitty1>Yknow, what method should I use to just quickly and dumbly get a newer version of a package than the repository? I need to actually learn more proper packaging and package management someday lmao
<kitty1>well, obviously one that doesn't need any changes in packaging other than the version
<unmatched-paren>kitty1: updating a package in the guix repo is pretty easy
<kitty1>hm?
<unmatched-paren>you clone it, run ``guix shell -D guix -- sh -c "./bootstrap && ./configure --localstatedir=/var && make -j$(nproc)"'', find the package with ``guix show'''s location field, then open the file, change the version, update the sha256 hash, and build it with ``./pre-inst-env guix build PKG''
<unmatched-paren>if the package is complex you might need to make further edits, but usually you don't
<silicius>there are also package transforms that let you use for example the newest source without editing the package definition
<unmatched-paren>ah, yeah
<silicius>read guix package --help-transform
<unmatched-paren>though once you've made that edit, you can commit it using the project ChangeLog format, and use git send-email to send it in: https://guix.gnu.org/manual/devel/en/html_node/Contributing.html
<silicius>still waiting for my vkmark to get in :/
<kitty1>thanks for the help btw
<kitty1>figured it out via silicius method I think, although I may be speaking too soon because its mid building
<kitty1>unmatched-paren: will def mess with the more proper methods tommorow!
<unmatched-paren>silicius: sent review just now
<kitty1>aaaa yep spoke too soon the build failed dang it lmao
<unmatched-paren>okay, if that fails you'll need to update it properly
<kitty1>trying to set up a newer version of fastboot because the one in the repository won't work for a thing I'm trying to do with a phone lmao
<silicius>unmatched-paren: thanks. Guess it had some problems. Was the review sitting in the backlog or you're just that quick?
<unmatched-paren>silicius: i wrote it after you mentioned "still waiting for my vkmark to get in"
<kitty1>unmatched-paren: eh, going to try it now, what is the purpose of the first command? Think I kinda get it but just want to make sure, the rest I fully follow
<unmatched-paren>kitty1: ./bootstrap and ./configure just set up the autotools build environment
<unmatched-paren>well, ./bootstrap does, ./configure configures the build for your system
<unmatched-paren>btw, if you get any weird, inexplicable errors at any point, try ``make clean-go && make -j16''
<kitty1>unmatched-paren: And to clarify, what specifically should I be cloning?
<unmatched-paren>kitty1: https://git.savannah.gnu.org/git/guix.git
<silicius>you can see the git repo address when you do guix describe
<unmatched-paren>Hmm. Looks like the freeze I experienced yesterday may have been a GPU hang: GPU HANG: ecode 12:0:00000000
<unmatched-paren>this time it stopped hanging after a moment
<unmatched-paren> https://paste.sr.ht/~unmatched-paren/814133e895d5a3115b675ff79c3b3a6dfacade8b
<unmatched-paren>anyone know what i should do now?
<anschlussy>i've wondered about this often, recently; do most packages really just sit on servers at-will by helpful people? and anyone can host their projects on those services?
<unmatched-paren>aha, it seems to have a kernel patch: https://lore.kernel.org/all/DM4PR11MB5971A43B5E78F34B30EA5E1587729@DM4PR11MB5971.namprd11.prod.outlook.com/t/#m83e2f11fe89b9b63fb29d711dd3416ae297c1c11
<unmatched-paren>anschlussy: which services...?
<unmatched-paren> https://community.frame.work/t/hard-freezing-on-fedora-36-with-the-new-12th-gen-system/20675?page=3
<nckx> https://gitlab.freedesktop.org/drm/intel/-/issues/6757
<nckx>Which ends in a Mesa patch.
<anschlussy>unmatched-paren: distro repos
<unmatched-paren>anschlussy: guix doesn't store the package source code on servers (well, it does, but that's the substitute servers, they're not strictly necessary)
<unmatched-paren>s/on servers/on its own servers/
<anschlussy>are guix packages always built, never binary?
<unmatched-paren>anschlussy: Sort of.
<anschlussy>is it like gentoo, where there are binary potentials for things like firefox?
<unmatched-paren>They are built from source, but because they're in theory reproducible, you can use "substitute servers" to fetch pre-built outputs that are guaranteed to be exactly the same as what they would be if you built them from source.
<unmatched-paren>nckx: I'm not sure that's the same error
<anschlussy>ah, fun
<unmatched-paren>there's a different "ecode"
<unmatched-paren>anschlussy: the guix project has two build farms for substitutes; one in bordeaux, and one in berlin
<nckx>What does the ‘ecode’ mean?
<unmatched-paren> https://bordeaux.guix.gnu.org and https://ci.guix.gnu.org
<unmatched-paren>nckx: i guess it's an error code?
<nckx>
<unmatched-paren>hmm. it does look kind of like an address though.
<nckx>I meant what it designates.
<unmatched-paren>i don't know, to be honest, i'm just stumbling about blindly...
<unmatched-paren>Ah, right.
<unmatched-paren>I don't know that either.
<anschlussy>do you know the configuration of those build farms? are they singular boxen?
<nckx>Same! It's easy to get trapped in pattern matching (as the people in that gitlab issue demonstrate—I don't think those kernel options did much of anything).
<nckx>anschlussy: https://ci.guix.gnu.org/workers
<nckx>The hydra-guix- ones are x86_64.
<nckx>Anything else without a p in it is aarch64.
<anschlussy>are those simply cores? is this a big threadripper, or is it a set of computers all lumbered into the room? i assume you could do something like this with one large CPU and qemu, aye?
<unmatched-paren>anschlussy: i think they're separate machines...
<anschlussy>very interesting
<nckx>Some ~2000 cores IIRC. I haven't counted recently.
<nckx> https://logs.guix.gnu.org/guix/2022-10-12.log#160502
<unmatched-paren>100TiB storage. Wow.
<nckx>Much SAN.
<anschlussy>storage-attached network?
<nckx>Yes.
<anschlussy>mm, storage area network, lmao
<nckx>I can't get to 2000, maybe I was just mis-remembering 1000, which now sounds low, which is a shame.
<anschlussy>yeah, that's just 100 times the amount of cores i've ever had...;P
<unmatched-paren>nckx: the framework thread i linked had exactly the same error message, and they linked to that kernel patch, so i think that might be the one
<nckx>anschlussy: <storage area> But you'd got the gist, and nitpicking is not allowed on IR—oh wait.
<nckx>unmatched-paren: \o/
<unmatched-paren>nckx: the ecode there is the same, so i do think it's significant
<unmatched-paren>ecode 12:0:00000000
<unmatched-paren>this is really strange: https://paste.sr.ht/~unmatched-paren/814133e895d5a3115b675ff79c3b3a6dfacade8b#error-L82
<nckx>Heh, yeah, I wondered about that too. What produced that output? It doesn't feel like kernel output, but then I've never experienced an i915 hang that bad.
<nckx>I assumed it was just the ‘log buffer’ in BaseInsane.
<unmatched-paren>maybe a buffer overrun that spilled into the log buffer...?
<anschlussy>how do you get reproducible builds while also trying to compile for things like march=native?
<unmatched-paren>anschlussy: we have the "package tuning" mechanism for that
<unmatched-paren>we build for a baseline march
<unmatched-paren>not generic, iiuc, but one that includes only features so old that we can assume everyone has them
<unmatched-paren>but packages that could benefit from a more specific march get the tunable flag enabled, which allows you t
<unmatched-paren>to build them for a more specific microarch (and sacrifice reproducibility across machines) if you want to
<anschlussy>very interesting; thanks for the good explanation
<nckx>To add: the question assumes we ‘try to’, but we're not Gentoo, so we don't really. The mechanism above is rarely used AFAIK and supported by a relatively low number of packages.
<nckx>The initial reason for it was scientific HPC packages, not glxgears.
<haoms>hey
<unmatched-paren>haoms: hi!
<nckx>unmatched-paren: There's also a negative report for that kernel patch in the frame.work thread.
<unmatched-paren>nckx: Oh.
<unmatched-paren>Hm
<nckx> https://community.frame.work/t/hard-freezing-on-fedora-36-with-the-new-12th-gen-system/20675/85
<nckx>But like false ‘turning off ipv6 fixed it for me!!’ placebo, this might be the opposite, if you're lucky :)
<nckx>They wouldn't be the first to boot a patched kernel that's missing the patch.
<nckx>Are you going to try it?
<unmatched-paren>I'm not sure.
<unmatched-paren>It's not too serious; the system unfreezes after a moment.
<unmatched-paren>> This issue might get fixed in Linux 6.1, which will land in December: Intel Sends Updated GPU Firmware Handling, More Meteor Lake Graphics Code For Linux 6.1 - Phoronix
<unmatched-paren>looks like most people are experiencing it when interacting with gnome stuff
<anschlussy>system slowdowns or freezes on gnome? NOOOO
<anschlussy>snark aside, that's unfortunate
<unmatched-paren>anschlussy: this isn't guix-related ;)
<unmatched-paren>and i'm not on gnome...
<unmatched-paren>aha! https://gitlab.freedesktop.org/drm/intel/-/issues/6916
<civodul>i'll be landing a fix for https://issues.guix.gnu.org/58631 today
<civodul>cbaines: i'll reconfigure bayfront when it's available; sounds good?
<unmatched-paren>civodul: nice!
<civodul>unmatched-paren: the real test will be "on the metal" but my tests so far give green lights
<civodul>a relief!
<cwebber>lechner: I'd be all for mentioning it there! and glad you liked it!
<cwebber>btw there's an accompanying video https://www.youtube.com/watch?v=DDROSL-gGOo
<twopubsolar[m]>hi
<twopubsolar[m]>i had this error while updatig
<twopubsolar[m]>guix substitute: error: mkdir: File exists
<twopubsolar[m]>substitution of /gnu/store/pln6w36y1qd22rjakbscr7pakp6sq9nv-guix-manual failed
<twopubsolar[m]>guix pull: error: some substitutes for the outputs of derivation `/gnu/store/1kw0vywncbs6kky60y6rs3vxkxxgdplf-guix-97d565c78.drv' failed (usually happens due to networking issues); try `--fallback' to build derivation from source
<cbaines>awesome job chasing that bug civodul :)
<cbaines>and yeah, bayfront should be fine to reconfigure
<twopubsolar[m]>i am getting that again, on guix-packages-base
<silicius>I have a python package that uses setup.py's install_data which does not respect the prefix passed to it - it tries to put the files in python's store directory
<unmatched-paren>silicius: i guess you could patch it
<silicius>Yeah, that was my first thought, to make a snippet. But maybe someone made a workaround in guix somewhere already
<civodul>oooh, a "Scheme Primer" video!
<apteryx>rekado: I meant Class-Path, not CLASSPATH: https://docs.oracle.com/en/java/javase/19/docs/specs/jar/jar.html#class-path-attribute
<apteryx>I was able to abuse it to refer to system-installed jars via the file:// protocole, but it's clearly not how it's intended to be used
<civodul>cbaines: reconfiguring!
<cbaines>cool, I was thinking I might need to update the guix-build-coordinator package, but I realised I must have done already :)
<cbaines>are you thinking of rebooting as well civodul?
<civodul>yes, we'll have to
<civodul>is that fine with you?
<cbaines>yep
<civodul>i'll make sure to cross fingers, too :-)
<cbaines>I'll need to restart qa.guix.gnu.org since that's currently in a screen session, but that's fine
<civodul>oh, i see
<civodul>i wonder if goggles-bot is fully declared now
<civodul>maybe not?
<civodul>ah no, it's not :-)
<cbaines>I think some changes were made since the last reboot though?
<civodul>yes, it used to be that we ran znc and now we use goggles-bot instead
<civodul>but right now it's running in the session of a fellow hacker :-)
<civodul>hmm maybe i should fix it now, while at it
<phodina[m]>Hello, is there a way how to disable'-Wall' flag for gnu-build-system for specific package?
<phodina[m]>In the definition.
<lilyp>it's not added by gnu-build-system, so you'll have to edit the makefile
<lilyp>but it'd probably be better to just disable the particular failing warning or -Werro
<lilyp>s/erro$/error/
<podiki[m]>civodul: thanks for the fhs push and fixing the shepherd memory leaks
<podiki[m]>my task today is to see if I can get vaapi working in icecat (might be a me problem), having just figured out how to fix it in firefox (sandboxing issues)
<podiki[m]>does anyone here have vaapi in icecat working, for reference?
<phodina[m]><lilyp> "but it'd probably be better to..." <- This helps but building old glibc-2.25 on current master seems like pointless strugle as it throws other errors.
<lechner>cwebber: Hi, as a sequencing method Scheme's 'begin' is a little bit like Haskell's 'do'. Your paper states that "Prior to introducing effects ... there is never any reason for 'begin'." The 'never' caught my eye. Is the statement true outside of that section and example? Thanks!
<silicius>adding python as a propagated-input is ok for python script programs?
<singpolyma>silicius: should not need to
<singpolyma>Do you have shebang line for python in the main script?
<phodina[m]>So in order to build `glibc-2.25` I've looked into the `guix time-machine`. But it gives me some errors due to introductory commit. Any idea what to do? The `--disable-authentication` didn't help
<phodina[m]> https://paste.debian.net/1259751/
<civodul>podiki[m]: yw! BTW, how 'bout writing a blog post explaining --emulate-fhs? :-)
<silicius>singpolyma: Ok I found a bash script that calls python3 directly, I can patch this
<silicius>not a shebang, maybe that's why it wasn't picked up
<cwebber>lechner: yes, it's true afaik
<cwebber>the reason is that (begin pre-exprs ... last-expr) will throw away all pre-exprs values and return the last-expr
<cwebber>as such
<podiki[m]>civodul: yes, thanks for the reminder! any ideas for examples of usage people would find helpful? appimages (of free software) might be one, though perhaps straying too much towards just binaries?
<cwebber>a pure functional approach is performing a pure computation. but any computation aspects of the pre-exprs, if you don't have any effects, are just thrown away
<cwebber>this isn't true if you have effects, eg you might use (set! foo (do-bar)) in which case foo is mutated and the computation doesn't just get thrown away, it may affect future computation
<podiki[m]>I think apteryx had use for building certain kernels, will have to ask
<phodina[m]>> <@phodina:matrix.org> So in order to build `glibc-2.25` I've looked into the `guix time-machine`. But it gives me some errors due to introductory commit. Any idea what to do? The `--disable-authentication` didn't help
<phodina[m]>> https://paste.debian.net/1259751/
<phodina[m]>The commit `242c09274588d6f747b666da5e693f0f526460eb` is from 2017. Should there be some invocation of the guix time-machine?
<phodina[m]>I say this thread https://www.mail-archive.com/guix-devel@gnu.org/msg62437.html from Konrad Hinsen
<phodina[m]> * The commit `242c09274588d6f747b666da5e693f0f526460eb` is from 2017. Should there be some invocation of the guix time-machine?
<phodina[m]>I found this thread https://www.mail-archive.com/guix-devel@gnu.org/msg62437.html from Konrad Hinsen
<podiki[m]>other uses for FHS I've done tend to involve things that download binaries, even if in principle you could build it from source: rust projects that download rust nightly, web frameworks that download chromium for testing, etc.
<podiki[m]>anyway, I can sketch something out and share on the mailing list for suggestions
<silicius>another problem I noticed, after I patched the call to python with the python's store path I realized it loads a python module which isn't available without pulling in python too
<silicius>is augmenting the PYTHONPATH just before that /store/.../bin/python3 call to point to that module's store path a good solution?
<twopubsolar[m]>is there a forum for guix?
<unmatched-paren>twopubsolar[m]: Nope. There's the ML though, which serves the same purpose.
<lechner>cwebber: thanks! great article
<twopubsolar[m]>emails take hours to get to guix tho
<unmatched-paren>twopubsolar[m]: they do the first time
<twopubsolar[m]>is there somethis like discourse? maybe unofficial?
<unmatched-paren>no
<unmatched-paren>the emails are manually spam-checked the first time you send one to the ml iiuc
<unmatched-paren>you are unlikely to get an answer quickly on an unofficial forum
<unmatched-paren>just send an email to help-guix@gnu.org
<twopubsolar[m]>thank you
<silicius>I'm not sure how to continue. The program needs to import its own module and a bunch of others in a bash script. I could either add them all to pythonpath, or propagade python
<silicius>the mentioned bash script is -> https://github.com/roddhjav/pass-import/blob/master/import.bash
<unmatched-paren>silicius: just add that python package to propagated-inputs
<nckx>There are no e-mails pending human review.
<nckx>For blind-misleading-the-blind tier support, there's a subreddit.
<twopubsolar[m]>oh no
<unmatched-paren>twopubsolar[m]: Unofficial subreddit, of course. Which just amplifies your "oh no".
<twopubsolar[m]>i don't want to go to reddit
<twopubsolar[m]>i sent an email
<unmatched-paren>It even calls it "GUIX" D:
<nckx>I went a bit overboard with the snark, but the quality of answers *is* quite variable, and the number of active Guix contributors quite low.
<nckx>Sorry that you're mail's lost in limbo. It will eventuall arrive, but the gnu.org mail systems have been suffering from severe delays the past weeks/months.
<nckx>…your…
<nckx>unmatched-paren: I assume that's why ‘GUIX’ is a thing at all.
<podiki[m]>I don't know who named it that originally, but unfortunately you can't change it after the fact :(
<nckx>If you're two@, your mail has already arrived.
<podiki[m]>I chime in there (the subreddit) when I have something useful, but support is best via ML and here
<podiki[m]>(and it being unofficial non-free can and does get discussed, btw)
<nckx>‘You cannot even change spelling, or capitalization. However you type it in when you begin the subreddit, is the way the subreddit is going to be forever.’ — some reddit on rando.
<twopubsolar[m]>isn't caps GUIX a microsoft IoT thing?
<unmatched-paren>twopubsolar[m]: yup
<vivien>Will we get sued for using GUIX as the subreddit name?
<nckx>We do no such thing.
<nckx>Trademarks aren't case-sensitive (which is why some people still mistakenly believe ‘Unix’ is spelled ‘UNIX’).
<vivien>There was a time when if you ran a company, you would ALWAYS spell it ALL CAPS
<vivien>But we do it no caps
<nckx>sneek: !nickometer GUIX
<nckx>!nickometer GUIX
<sneek>"GUIX" is 73.67% lame, because the last alphanumeric character was lame, 4 extraneous caps
<podiki[m]>perhaps it is a reference to typical reader case in lisps? (sure, everyone will buy that)
<nckx>So it is, sneek, so it is.
<unmatched-paren>!nickometer guix
<sneek>"guix" is 0% lame
<unmatched-paren>Correct answer, sneek.
<vivien>I have seen relics of the past where HTML tags were ALL CAPS TOO
<vivien><BR>
<singpolyma>I did prefer all caps HTML, but have made my peace with reality
<nckx>You'll pry < /> out of my cold dead hands though.
<lilyp>!nickometer GuixSD
<sneek>"GuixSD" is 17.69% lame, because 1 extraneous cap, 2 case shifts
<lilyp>!nickometer guix-system
<sneek>"guix-system" is 0% lame
<vivien>!nickometer <BR>
<sneek>"<BR>" is 31.45% lame, because 2 extraneous symbols, 2 extraneous caps
<vivien>!nickometer <br/>
<sneek>"<br/>" is 80.18% lame, because 2 consecutive non-alphas, 3 extraneous symbols
<nckx>All symbols are ‘extraneous’ to you, you dolt.
<unmatched-paren>!nickometer (
<sneek>"(" is 15.66% lame, because 1 unbalanced bracket, 1 extraneous symbol
<unmatched-paren>noooo :(
<vivien>Now you must nick yourself "unbalanced-paren" :D
<vivien>Or unbalanced-bracket
<jonsger>hi guix
<vivien>Or extraneous-symbol
<unmatched-paren>jonsger: afternoon!
<twopubsolar[m]>!nickometer two
<sneek>"two" is 0% lame
<extraneous-symbo>Too late
<nckx>Is that like a himbo.
<twopubsolar[m]>hi
<extraneous-symbo>Oh I did not get the extra l :(
<podiki[m]>I just learned about himbo, what an odd coincidence
<podiki[m]>hi jonsger
<lilyp>!nickometer ()
<sneek>"()" is 38.44% lame, because 2 consecutive non-alphas, 2 extraneous symbols
<unmatched-paren>!nickometer a
<sneek>"a" is 0% lame
<vivien>!nickometer vivien
<sneek>"vivien" is 0% lame
<vivien>!nickometer lame
<sneek>"lame" is 61.63% lame, because matched special case /lame/
<vivien>He
<nckx>!nickometer nckx
<sneek>"nckx" is 0% lame
<vivien>!nickometer sneek
<sneek>"sneek" is 0% lame
<nckx>So ‘the last alphanumeric character was lame’ matches only X, not x, good.
<vivien>!nickometer sneek botsnack
<sneek>"sneek botsnack" is 14.49% lame, because 1 extraneous symbol
<vivien>!nickometer sneek, botsnack
<sneek>"sneek, botsnack" is 38.44% lame, because 2 consecutive non-alphas, 2 extraneous symbols
<nckx>!nickometer !nickometer
<sneek>"!nickometer" is 14.49% lame, because 1 extraneous symbol
<vivien>!nickometer sneek, botsnack
<sneek>"sneek, botsnack" is 38.44% lame, because 2 consecutive non-alphas, 2 extraneous symbols
<vivien>!nickometer " sneek, botsnack"
<sneek>"\" sneek, botsnack\"" is 99.90% lame, because 4 consecutive non-alphas, 5 extraneous symbols
<nckx>!nickometer Robert'); DROP TABLE Students;--
<sneek>"Robert'); DROP TABLE Students;--" is 99.98% lame, because 1 unbalanced bracket, 7 consecutive non-alphas, 7 extraneous symbols, 9 extraneous caps, 2 case shifts
<vivien>nickometer ,(string->symbol "sneek")
<vivien>!nickometer ,(string->symbol "sneek")
<sneek>",(string->symbol \"sneek\")" is 99.98% lame, because 8 consecutive non-alphas, 7 extraneous symbols
<unmatched-paren>!nickometer $ |\| 3 3 |<
<sneek>"$ |\\| 3 3 |<" is 100.00% lame, because k3wlt0k, 9 consecutive non-alphas, 10 extraneous symbols
<unmatched-paren>yess, 100% :)
<vivien>!nickometer é
<sneek>"é" is 14.49% lame, because 1 extraneous symbol
<nckx>And bonus escaping ‘bug’.
<vivien>:(
<vivien>!nickometer "\x00"
<sneek>"\"\\x00\"" is 99.99% lame, because k3wlt0k, 2 consecutive non-alphas, matched special case /[rkx]0/, 3 extraneous symbols
<vivien>!nickometer "\0"
<sneek>"\"\\0\"" is 99.99% lame, because k3wlt0k, 2 consecutive non-alphas, 3 extraneous symbols
<vivien>!nickometer "100% lame"
<sneek>"\"100% lame\"" is 99.99% lame, because k3wlt0k, 2 consecutive non-alphas, matched special case /lame/, 4 extraneous symbols
<vivien>!nickometer "99.99% lame"
<sneek>"\"99.99% lame\"" is 99.99% lame, because k3wlt0k, 2 consecutive non-alphas, matched special case /lame/, 5 extraneous symbols
<vivien>Can I find a fixpoint?
<vivien>!nickometer "99.99% lame, because k3wlt0k, 2 consecutive non-alphas, matched special case /lame/, 5 extraneous symbols"
<vivien>Woops
<nckx>\o/
<vivien>Sorry :(
<vivien>Welcome back, sneek! You have 1 message.
<vivien>sneek, botsnack
<sneek>:)
<vivien>!nickometer "
<sneek>"\"" is 14.49% lame, because 1 extraneous symbol
<vivien>!nickometer \
<sneek>"\\" is 14.49% lame, because 1 extraneous symbol
<vivien>!nickometer \o/
<sneek>"\\o/" is 25.65% lame, because 2 extraneous symbols
<vivien>!nickometer 🏴☠️
<sneek>"\U01f3f4☠️" is 97.05% lame, because 3 consecutive non-alphas, 3 extraneous symbols
<vivien>!nickometer 🇹🇼
<sneek>"\U01f1f9\U01f1fc" is 38.44% lame, because 2 consecutive non-alphas, 2 extraneous symbols
<cwebber>lechner: unmatched-paren: really the ideal thing would be to get the scheme primer in guix itself as an info manual
<cwebber>since the source is an org-mode file, that should be possible
<civodul>cwebber: +1!
<cwebber>civodul: :)
<cwebber>I don't have time atm but if someone wants to take a crack at it, here it is https://gitlab.com/spritely/scheme-primer
<cwebber>I'd be happy to review a guix package if someone makes one though
<civodul>great
<cwebber>actually I tried looking at it and realized I didn't know what the right thing to do to install an info manual was. in retrospect probably should have looked at the r5rs or sicp packages
<cwebber>it's probably similar with the exception of running a command in emacs to generate the .texi file first
<cwebber>lechner: btw I'm glad the "begin" section lead to enough of an a-ha for you
<cwebber>I tried to pack as many of the big a-has I hit while learning scheme over time into those short number of pages ;)
<cwebber>speaking of getting stuff of mine into guix... working on Terminal Phase's Guile port for the lisp game jam right now! if I get far enough, finally I'll be able to have a guix package of terminal phase people can play :)
<cwebber>only 11 hours left!
<cwebber> https://itch.io/jam/lisp-game-jam-2022
<cwebber>well, closer to 12
<podiki[m]>cool!
<civodul>good luck with that!
<podiki[m]>I saw that in one of your videos cwebber, very neat stuff :)
<cwebber>podiki[m]: :)
<podiki[m]>I was writing a whole text based (but with fancier graphics) engine/game in CL with the cepl package long ago, was a lot of fun to do that in a lisp
<podiki[m]>graphics programming really meshes well with a REPL approach
<cwebber>yes!
<cwebber>I really love it
<cwebber>it's also a lot nicer with Guile than it was with Racket
<cwebber>because Racket takes the "toplevel is hopeless" approach... live editing isn't really possible in the same way
<cwebber>you can still sorta live hack, but you can't change things that exist while the program is running. and games are when that *really* unlocks its power
<podiki[m]>any particular resources for exploring Guile in that way? or good demos?
<podiki[m]>doing stuff on the GPU via a REPL is a million times nicer (I once wrote a ray tracer in shaders before shader languages were much of a thing....wow was that hard to debug)
<podiki[m]>(but it worked, realtime ray tracing on a consumer GPU, before the whole GPU as computation card exploded)
<cwebber>podiki[m]: it's a bit awkward in the second half hour of the talk but https://youtu.be/o97g8DXGAZc?t=3079 onwards you can see me doing some live hacking
<cwebber>the part where I implement time travel live in the guile version is when things really took off again I think
<cwebber>that said
<cwebber>there are better videos
<cwebber>the common lisp folks have lots of good videos of this
<cwebber>which, as you said, you already have CL experience I guess :)
<cwebber>oh actually
<cwebber>the old mudsync video is pretty good for this
<cwebber>so actually I don't recommend 8sync any more, Spritely Goblins is pretty much fully surpassing it, and in the not too distant future you should be able to run old 8sync code in it too
<cwebber>but scroll down to the video on https://www.gnu.org/software/8sync/
<cwebber>however I think the best videos of *anyone* doing live hacking were david o'toole's XELF videos. but he took them all down. it's too bad.
<podiki[m]>Thanks!
<cwebber>np podiki[m] !
<cwebber>I hope it's fun
<podiki[m]>Love seeing this stuff, a lot of fun
<cwebber>speaking of videos
<cwebber>I did a live version of the scheme primer
<cwebber>it's both on youtube and peertube
<cwebber> https://www.youtube.com/watch?v=DDROSL-gGOo
<cwebber> https://share.tube/w/gdtnuipKbbVdR2u1murL4t
<cwebber>if watching a video would help you maybe
<cwebber>at any rate, back to hacking
<cwebber>podiki[m]: happy to hear you've enjoyed some of my talks tho
<cwebber>let's see what happens! if I'm focused enough, it'll be really cool to show off a *full* version of terminal phase on guile
<podiki[m]>I did see part of the earlier one you posted, will have to check out the rest for the details
<podiki[m]>Keep up the good work and showing us cool things in guile!
<cwebber>thanks podiki[m], good luck with whatever cool things in guile *you* will build! :)
<awb99>I manually created a swap file on my guix-system. And now I want guix to use it. I could not find any example for that. All examples I found use an entire partition. Deos someone know how to do that? Thanks!!!
<silicius>has anyone successfuly used browserpass with browserpass-native? I'm seeing the same error on both icecat and ungoogled-chromium...
<silicius>eh, the patch email had command that needs to be run for browserpass-native to work
<silicius>shouldn't this info be included in the package's description?
<rekado>I added another chapter to the cookbook, this time on MPD with bluealsa.
<rekado>it’s not terribly specific to Guix, but it includes an example of independent services working together, and of G-exps to reference package output locations in config files
<nckx>awb99: See <https://guix.gnu.org/en/manual/devel/en/html_node/Swap-Space.html#Swap-Space>.
<nckx>It explicitly documents both devices & files.
<nckx>If (target "/some/file") doesn't work, please report a bug.
<awb99>thanks @nckx. I tried that already. but I never got it to work.
<awb99> (file-systems
<awb99> (cons* (file-system
<awb99> (mount-point "/boot/efi")
<awb99> (device (uuid "167C-868D" 'fat32))
<awb99> (type "vfat"))
<nckx>awb99: When you're unquieted, please use a paste bin such as paste.debian.net 😉
<unmatched-paren>awb99: please use a paste site for code blocks, like paste.debian.net
<nckx>Jinkies.
<nckx>…that's taking too long.
<awb99>I would think that many people use a swap-file.
<nckx>‘for #guix, floodPermit: 5, floodLife: 3, floodMode: q, and floodDuration: 20’ — that was way over 20s, wasn't it?
<awb99>Especially since the guix installer does not create a swap-partition automatically.
<nckx>I dunno, they're kind of finicky compared to partitions.
<nckx>Anyway, paste yer code.
<awb99> https://paste.debian.net/1259760/
<awb99>this is the code.
<nckx>…why is it under /mnt?
<awb99>this is where I created the swap file.
<awb99>should I just create /swapfile ?
<nckx>No. I'm just curious why.
<awb99>sudo swapon /mnt/swapfile
<awb99>this worked.
<nckx>Sure.
<awb99>when I manually activated the swapfile.
<nckx>That's expected.
<nckx>(Assuming you created it correctly, which I assume.)
<nckx>Do you get any error message at boot, or any other message at any other time, when you uncomment that & reconfigure & reboot?
<awb99>I will run it again now, and paste the error.
<nckx>Thanks!
<nckx>civodul: Are you messing with goggles-bot?
<nckx>Eh: In procedure open-file: Permission denied: "/var/www/.well-known/all-logs/#guix/2022-11-06.log"
<antipode>Does someone know where to find a list of Guix maintainers? There is a blog post, but that's not really stable.
<antipode>Does someone know where to find a list of Guix maintainers? There is a blog post, but that's not really stable.
<nckx>awb99: I'm just guessing, but maybe Guix doesn't like the swap/btrfs/dm nesting.
<nckx>awb99: I'm just guessing, but maybe Guix doesn't like the swap/btrfs/dm nesting.
<nckx>antipode: https://guix.gnu.org/en/about/
<nckx>antipode: https://guix.gnu.org/en/about/
<nckx>wtf: https://logs.guix.gnu.org/guix/2022-11-06.log#200323
<nckx>wtf: https://logs.guix.gnu.org/guix/2022-11-06.log#200323
<nckx>Somebody didn't kill rekado's goggles :)
<nckx>Somebody didn't kill rekado's goggles :)
<nckx>goggles-bot_: Beer goggles discarded?
<nckx>Yes.
<nckx>sneek: later tell civodul: Had to chown -R goggles-bot /var/www/.well-known/all-logs .
<sneek>Will do.
<nckx>sneek: botsnack
<sneek>:)
<antipode>nckx: Thanks.
<antipode>No heksen anymore?
<nckx>Halloween is past.
<nckx>Carry high that torch. o7
<awb99>guix system: warning: exception caught while executing 'start' on service 'swap-/mnt/swapfile':
<awb99>In procedure swapon: "/mnt/swapfile": Invalid argument
<awb99>this is the error that I get after doing a guix system reconfigure.
<nckx>OK. Can you check dmesg for this invalid argument?
<nckx>(If any!)
<awb99>sure
<nckx>From a quick(!) scan of the code, obvious EINVALs are zoned devices (not you), empty files (unlikely), bad header (again, swapon(8) would fail :-/), nothing immediately relevant???
<awb99>[48247.681379] BTRFS warning (device dm-0): swapfile must not be copy-on-write
<awb99>I guess with BTRFS with default setup it will not work to add a swapfile :-(
<nckx>But you said swapon(8) worked.
<awb99>yes
<awb99>very strange
<nckx>Btrfs swap files can't be CoW.
<awb99>let me check again
<nckx>This is not a Guix restriction.
<twopubsolar[m]>can i manually remove a folder from /gnu/store?
<unmatched-paren>twopubsolar[m]: why?
<unmatched-paren>you should avoid doing so
<unmatched-paren>it's probably there for a reason
<awb99>@nckx found the error sudo swapon produces the same dmsg error message.
<awb99>so its the btrfs filesystem that does not allow a swapfile inside
<twopubsolar[m]>unmatched-paren: because it looks like the n*x daemon thinks it's not there, tries to create it, and fails
<unmatched-paren>twopubsolar[m]: are you trying to use the nix daemon and the guix daemon together in one store?
<twopubsolar[m]>unmatched-paren: no, i mean guix daemon
<nckx>awb99: Yes and no. CoW is optional, but you can turn it of *only* on new (empty) files that have never been written to.
<unmatched-paren>twopubsolar[m]: which directory is it?
<twopubsolar[m]>nvm i just wanted to say it's stupid
<nckx>Roughly, create empty file, chattr +C, then write the right amount of zeroes to it, then mkswap.
<awb99>ahhh
<awb99>very cool.
<twopubsolar[m]>unmatched-paren: the one i posted in my email
<twopubsolar[m]>/gnu/store/61aikkrkxcm07ajrzgl6531lvacb3b5h-guix-packages-base/gnu
<awb99>thanks @nckx - will try that immediately
<nckx>So it's not Guix's ???fault???, but some enterprising individual *could* write a Guix service that does just that, to make it even more convenient.
<nckx>ACTION is not that individual, partitions & hibernation FTW.
<nckx>ACTION had to manually herd restart goggles-bot again.
<cbaines>ah, I just reconfigured bayfront (in case that has anything to do with it)
<nckx>Do you see the quit message (and its timestamp)?
<cbaines>yep
<cbaines>20:39:39
<nckx>(For some reason my screen displays about half of timestamps in ZNC time, and half in laptop time, and they are not identical despite both running NTP, so I never trust my own timestamps. In case I sounded lazy.)
<civodul>nckx: no, it probably has to do with the separate mount namespace
<civodul>like it's writing to /var/www/.well-known/all-logs/#guix/2022-11-06.log but that's not the same one as the one i'm looking at
<civodul>also, i can't get nsenter to do anything these days
<civodul>hmm actually it's working
<civodul>ok, nevermind
<civodul>go figure
<civodul>alright, so now rebooting bayfront
<cbaines>so maybe don't switch it off...
<civodul>it's back!
<civodul>yay!
<civodul>so maybe it was fsck'ing or something?
<civodul>(for this long?)
<civodul>even goggles-bot is back without manual intervention :-)
<civodul>and https://logs.guix.gnu.org/guix/2022-11-06.log is up-to-date
<civodul>unbelievable
<lfam>I know it's a bit early to be planning for FOSDEM, but is there anything happening besides the booth?
<cbaines>thanks for taking care of this civodul!
<cbaines>I've now started the qa-frontpage thing, I'll write a service for that at somepoint as well...
<the_tubular>I really can't get docker to work :(