IRC channel logs

2022-07-18.log

back to list of logs

***mark_ is now known as mjw
<apteryx>fun, I could successfully migrate qpwgraph to Qt6
<apteryx>as a first test of the stack (qtbase + qtsvg at 6.3.1)
<apteryx>podiki[m]: In the same commit would make the most sense (the doc comes with the commands as they get added)
<PotentialUser-23>Hey everyone! How do I get bash completion using zsh in guix? I tried this
<PotentialUser-23>autoload bashcompinit
<PotentialUser-23>bashcompinit
<PotentialUser-23>autoload -Uz compinit
<PotentialUser-23>compinit
<PotentialUser-23>source /gnu/store/{long}-bash-completion-2.8/share/bash-completion/bash_completion
<PotentialUser-23>Still an error
<PotentialUser-23>`/gnu/store/kzv8id43y5nxzzmj34w9lsw9irx6s7l6-bash-completion-2.8/share/bash-completion/bash_completion:45: command not found: shopt
<PotentialUser-23>May be there is more guix'y way to do comletions?
<unmatched-paren>PotentialUser-23: Looks more like a bug in the bash-completion package to me
<unmatched-paren>if it fails to find a command it needs
<unmatched-paren>PotentialUser-23: hmm, wait, this is bash completion
<unmatched-paren>you're using zsh
<unmatched-paren>shopt is a bash builtin
<unmatched-paren>zsh does not have shopt :)
<PotentialUser-23>Thanks, I've just disabled error output from 'source'
<PotentialUser-23>autoload compinit
<PotentialUser-23>compinit
<PotentialUser-23>source /gnu/store/kzv8id43y5nxzzmj34w9lsw9irx6s7l6-bash-completion-2.8/share/bash-completion/bash_completion 2> /dev/null
<PotentialUser-23>Completion in zsh is fine using bash-completion!
<civodul>o/
<cnx>how to enable halt/reboot for normal users?
***duds-_ is now known as duds-
<PotentialUser-53>patch-shebang: ./setup.py: warning: no binary for interpreter `python' found in $PATH
<PotentialUser-53>HI all :)
<PotentialUser-53>Sorry to paste before asking, but does anyone know how to get around this ?
<PotentialUser-53>I am trying to convert my odoo docker to use guix instead :)
<PotentialUser-53>    (native-inputs
<PotentialUser-53>     `(("python-setuptools" ,python-setuptools)))
<PotentialUser-53>    (arguments
<PotentialUser-53>     `(#:python ,python-3
<PotentialUser-53>       #:tests? #f))
<cbaines>PotentialUser-53, I believe the python-wrapper package provides a python binary
<PotentialUser-53>hmm, interesting ... I did try , it came out with : no code for module (gnu packages python-wrapper)
<cbaines>PotentialUser-53, python-wrapper is a package, not a Guile module
<cbaines>so yeah, that error message sounds correct
<PotentialUser-53>sorry, this is all new to me :(
<cbaines>from the code you pasted in to the channel, you're specifying python-3 as the python package to use
<cbaines>the default is actually python-wrapper
<cbaines>so, I'd try removing the #:python ,python-3 bit
<cbaines>unless you need that specific python-3 package
<PotentialUser-53>ok, I added it to "inputs" and it seems to be doing more :) thanks.
<PotentialUser-53>wow, it's getting closer to build. This is great. thanks all.
<cbaines>you're welcome :)
<civodul>ekaitz: hi! do i get it right that tcc doesn't have a newer release with the fix we need?
<ekaitz>civodul: not yet
<ekaitz>they are planning to do one, but it'll take time
<ekaitz>also, if you try to build the package I shared, let me know if it fails the first time and works the second because it has happened to me but I was unable to replicate
<PotentialUser-53>Hey all, if I have some python packages that don't exist in guix, do I need to make separate package files scm for them, or can they be in the one that I am creating ?
<cbaines>PotentialUser-53, are you trying to package things for inclusion in to Guix?
<PotentialUser-53>no, just for my own personal usage for now .... I don't even know guix, I'm just running it on top of another distro
<PotentialUser-53>if I'm successful and all the licensing is right I would maybe try
<efraim>I can get nss-certs to show new upstream releases by pointing to Debian but I can't mangle it enough for mozilla's sources :/
<PotentialUser-53>I found a post by a guy that was trying to make a package for odoo v 10 in 2016.... he ran into similar errors with python dependencies, but I took his scm file from the support forum post and changed the code to v15, and I have fixed the python dependency issues mostly. But some of them don't exist in guix
<PotentialUser-53>oh gosh, I got: successfully built /gnu/store/nnnwbklf9fdx1n79xgppz4v64f592alm-odoo-15.drv
<PotentialUser-53>and it stops there
<efraim>with some helpful hackers at debconf last night we got nheko building and running on aarch64 last night
<PotentialUser-53>connection to database failed ... nice ! so I guess I just need to add postgresql into the package
<efraim>depending on how the test suite runs you might need to start postgresql before the 'check phase
<PotentialUser-53>It's quite interesting how there isn't much verbosity in the scm files compared to docker ... it's cool that it works but I don't really understand how
<efraim>looks like parcimonie disapeared upstream
<efraim>not sure if it's maintained upstream in Debain or if Debian just has a cyclical reference to itself for "new upstream releases"
<PotentialUser-53>can I install postgres as an input ?  or do I need to use the package that I've just built in another package with postgres  ?
<cbaines>PotentialUser-53, assuming odoo uses postgresql just as a database, it probably doesn't need to be an input (unless the client part of PostgreSQL is used)
<PotentialUser-53>because technically, yes, this is definitely running odoo.... maybe it does make sense to have that as a standalone thing, without bundling a DB, and then have another package that uses that package and postgres ?
<PotentialUser-53>I think you're right, but my goal is to create a specific odoo that sets up all my work stuff, like we do with docker-compose at the moment
<PotentialUser-53>I don't know if it's possible, but I think it should be
<cbaines>I'm a bit lost, have you got a package that builds yet?
<PotentialUser-53>yes, it does build the actual odoo ... amazingly :)
<PotentialUser-53>but now, you have to use a DB with it for it to work, and I'm not sure where to set that up. In a new package, or just do another guix install from the userland, or ...
<cbaines>ok, there is tooling within guix for services, including PostgreSQL, but that's more for entire systems
<cbaines>it doesn't particularly overlap with docker-compose in terms of use cases
<cbaines>I've never heard of odoo before, are you trying to deploy it on a server somewhere?
<PotentialUser-53>so basically it's a python framework, similar to django but it has a lot more dependencies
<PotentialUser-53>so I have the actually odoo program running as a guix package, but what I'm after is to set up my whole dev environment, including a DB connection and extra addons modules
<cbaines>what OS are you using for development?
<PotentialUser-53>so, instead of downloading my docker-compose folder with all the stuff in I can just add an scm to my channels and download a customized odoo
<PotentialUser-53>Pop OS
<cbaines>ok, I'd suggest installing PostgreSQL in Pop OS, and then using that
<cbaines>given systemd (I assume) is already managing services for you on Pop OS, using it for PostgreSQL as well seems the simplest option for local development
<PotentialUser-53>it would definitely be easier, but I was hoping that I could use Guix and then make it OS-independent
<PotentialUser-53>well distro-independent at least
<PotentialUser-53>so like anyone in the team could add the channel scm, and then download it and start using it, instead of using dockers like we are now
<jpoiret>cnx: do you know if you're running elogind?
<jpoiret>if you are, you should be able to use loginctl for those
<ekaitz>civodul: did you experience the issue with tcc?
<civodul>ekaitz: the one you fixed?
<civodul>ah no, it built fine from the first time for me
<ekaitz>civodul: try to build the package for the first time and tell me if it fails
<ekaitz>alright
<ekaitz>it was me then :S
*civodul tries --check --rounds=3
<civodul>works for me!
<civodul>and it's fast :-)
<ekaitz>good good
<apteryx>civodul: doesn't that leave you with a corrupted store entry?
<apteryx>at least if you add --keep-failed to the mix I think it will
<apteryx>see #51400
***Server sets mode: +Ccntz
<zrsk[m]>Hi people, I never used Guix but it's years I'm using Nix and I'm really interested into trying it (I'm a big Scheme fan). I was wondering, does Guix use the nix-store/nix-daemon? Or are they completely rewritten?
<zrsk[m]>And what about content addressed derivations? I'm very interested into this specific feature
<zrsk[m]>And is it possible to perform ifd using Guile?
<nckx>zrsk[m]: Daemon: neither, really, in that our daemon was forked from Nix long ago and has very little in common with the Nix daemon of today, but nor is it a shiny new rewrite (yet(?)). CAD: Alas, we don't have those. IFD: …I don't know what that is.
<nckx>Ah, this: https://nixos.wiki/wiki/Import_From_Derivation
<nckx>I'm… still not sure.
<civodul>not sure if i'm sad about not having "content-addressed derivations" :-)
<civodul>import-from-derivation is a kind of "dynamic dependency", which we have for example with grafts
***Server sets mode: +Ccntz
<nckx>bayfront-log: At least you're having fun.
<cnx>thanks jpoiret, i have elogind service declared, i'll try loginctl tomorrow when i have access to the machine
<civodul>zrsk[m]: content-addressed derivations are a complex beast; there are potential benefits, but they could be achieved by simpler means IMO
<civodul>put this way it's very hand-wavy though, so... to be continued
<podiki[m]>civodul: will respond in detail via email, but for FHS, I was approaching as "provide as much of the expected stuff"; in experience I've seen software only try to use the ldcache, for instance, or traverse PATH directly
<podiki[m]>civodul: in other words, yes it is messy (which is why we like guix) but was trying to provide that, isolated of course.
<podiki[m]>as a perhaps not great example, trying to run an appimage just to get it's offset to mount it manually requires running it (wonderful design, I know), which seems to only get libz if it is in the ld cache
<civodul>hi podiki[m]! i'm just getting the name/nick mapping now :-)
<civodul>i agree with the general approach
<civodul>i don't think software accesses ld.so.cache directly, right?
<civodul>or you mean if you run a pre-built binary in there?
<podiki[m]>binaries I've seen yes, but I remember once patching something (autokey maybe? a python package) that wanted to read 'ldconfig -p' directly too
<podiki[m]>I agree ld cache should be a nice convenience but not cause something to fail if it isn't up to date/doesn't exist
<podiki[m]>or is the fact that we have an ldcache now for many packages (so one will end up in profile) perhaps cause a problem if it is read but not up to date
*podiki[m] has to run for now, but will check the logs and followup via email
<davidl>HEllo Guix! Anyone who would like to review my patch for bash-coding-utils: https://issues.guix.gnu.org/51512#5
<maximed>Import-from-derivation sounds like bind/>>= to me
<maximed>Turning the store from an applicative functor(?) into a monad.
<efraim>consfigurator talk is about to start if anyone wants to watch it streamed
<efraim> https://debconf22.debconf.org/schedule/venue/2/
<efraim>civodul ^
<drakonis>oh, nice.
***lispmacs[work] is now known as forthmacs
<kaelyn>Hello #guix! I have a question about building packages when the guix daemon was started with "--cache-failures", which is how does one clear the cached failure so that the build can be tried again?
<nckx>kaelyn: guix gc --list-failures → guix gc --clear-failures FAILURE…
<nckx>So guix gc --clear-failures $(guix gc --list-failures) should delete all of 'em.
<kaelyn>nckx: awesome, thank you! For some reason I kept not seeing those flags ;)
<nckx>Fun with grep is inevitable.
<nckx>YW!
<drakonis>efraim: its a good talk.
<apteryx>with modify-inputs, are we to add one (replace "label" package) per replacement?
<apteryx>does it work with labels or package names?
<apteryx>I'm asking because it's not behaving as expected
<apteryx>seems to use package names
<apteryx>(I expected it worked on labels)
<apteryx>hmm, qtwebengine 6 wants node@12
<two[m]>guix-daemon is started with --substitute-urls=https://bordeaux.guix.gnu.org
<two[m]>guix weather ffmpeg tells it's built on bordeaux
<two[m]>guix install ffmpeg wants to build it from source
<two[m]>what's wrong?
<KarlJoad>I'm trying to pull guix on a freshly dd-ed ISO. But, there is a git error with the SSL certificate. "guix pull: error: Git error: the SSL certificate is invalid"
<apteryx>ah, there's something called node-lts
<nckx>two[m]: Missing #7D602902D3A2DBB83F8A0FB98602A754C5493B0B778C8D1DD4E0F41DE14DE34F# key in /etc/guix/acl?
<civodul>KarlJoad: could you check if /etc/ssl/certs exists and is non-empty, and whether "env |grep SSL" shows something?
<two[m]><nckx> "two: Missing #7D602902D3A2DBB83F..." <- thank you! i had to copy the (entry) and replace the key
<nckx>👍!
<nckx>That works fine; curl https://git.savannah.gnu.org/cgit/guix.git/plain/etc/substitutes/bordeaux.guix.gnu.org.pub | sudo guix archive --authorize (or a local file equivalent) works too.
<nckx>You can never curl | too much sudo.
<two[m]>still it wants to build updates when running guix pull... (full message at https://libera.ems.host/_matrix/media/r0/download/libera.chat/12bfd7fa2cfd6c26ae9812ba034d429058397e24)
<nckx>That's fine.
<nckx>Those look specific to you.
<apteryx>or 'wget -O-' (it's GNU, comes pre-installed on Guix System)
<ggoes>i'm having a similar problem to two[m] on guix system; weather says telegram-desktop is available, but guix package -u always wants to build it
<ggoes>and i'm on a laptop so old that that's very ill-advised :)
<ggoes>not a big deal though
<nckx>If it's the same problem, the same solution should apply.
<nckx>The key is authorised by default if you recently installed from the ‘latest’ ISO, which will become 1.4, but not if you installed from an older installer like 1.3.
<nckx>telegram-desktop is only on bordeaux, not berlin, so it may well be.
<ggoes>hmm
<ggoes>i did install quite a while ago
<ggoes>let's see what happens
<nckx>/etc/guix/acl will have the answer.
<KarlJoad`>civodul: /etc/ssl/certs is full of files, and the environment variables GIT_SSL_CAINFO, SSL_CERT_DIR, and SSL_CIRT_FILE are all set.
<nckx>To only one value (no ‘:’)?
<KarlJoad`>Yes. All of them are paths to a single.
<KarlJoad`>Single file or directory (as appropriate)
<nckx>OK.
<nckx>And your clock is set correctly? (Sorry, have to ask…)
<KarlJoad`>Ding ding ding. BIOS clock is set to 2014.
<KarlJoad`>No idea how to change it though.
<nckx>sudo date set=STRING; sudo hwclock --systohc (which is optional, but it will make the change persist across reboots assuming your CMOS battery ain't dead).
<nckx>You could also set up NTP as extra failsafe, although it's no substitute (unfortunate pun intended).
<KarlJoad`>I'll probably end up using NTP, but will also need to change the battery.
<nckx>Oops: --set=, but you probably figured that out.
<roptat[m]>something wrong with the website? we should see nowegian in the list of languages by now… is it failing to build? I tested it locally yesterday though
<roptat[m]>updated on 15/07, so I don't think it's my change from yesterday
*nckx .oO …3506627 inodes should be enough to build a Web site, no idea…
<nckx>How do I make ‘herd schedule mcron’ (or equivalent) spit out more than 5 jobs?
<dcunit3d>anyone else getting build failures for python-fontpens? it's a a dep. of abattis-cantarell
<nckx>Yes, it's known.
<dcunit3d>i was updating the same profile on two different laptops, but one passed, the other failed somehow
<nckx>I'd actually forgot about it.
<dcunit3d>i may not have ran hash guix and got lucky i guess
<dcunit3d>k, i'll just remove it for now
<nckx>dcunit3d: It's some weird rounding error by 0.000000001 or so, I'm not entirely surprised that it's not reproducible, although it fails reliably here.
<nckx>dcunit3d: Ah, also possible.
<dcunit3d>lol wow
*nckx is running /gnu/store/30mkappmc0mz153x61krqcp95lg8qfyw-update-guix.gnu.org manually on berlin :-/
<dcunit3d>it's showing me a DocTestFailure, but i haven't looked into it
<nckx>No, please tell me you get at least the same error, thanks :o)
<dcunit3d>ah ok i see it now. yeh, same one
<nckx>Thank god.
<dcunit3d>maybe the assertion should have some tolerance
*nckx bisects.
<nckx>roptat[m]: https://paste.debian.net/plainh/9ec59cd3
<nckx>I don't see the actual log file at first glance.
<nckx>Oh, that match-error *is* the output from de_DE.drv.
<nckx>I have no idea what the salsa.d.o business is about. Maybe you do.
<nckx>dcunit3d: Right, ideally an upstream fix but we can probably work around it.
<two[m]>i see an option to upload a .po
<two[m]>s/upload/download/
<two[m]>where's the option to upload it?
<roptat[m]>in the same menu. ?ou must be connected
<two[m]>roptat[m]: in Files?
<roptat[m]>yes
<dcunit3d>is there any way to get to the git repo(s) cloned for a *.drv file?
<nckx>roptat[m]: s/connected/logged in/ maybe?
*nckx knows the French good.
<two[m]>roptat[m]: which one? the first one downloads a file, the second one asks me which strings i want to download and in what format
<roptat[m]>the third one
<roptat[m]>yes, you must be logged in to see that option
<two[m]>roptat[m]: there are two
<roptat[m]>are you sure you're logged in?
<two[m]>no
<two[m]>sorry
<two[m]>i signed up but it didn't log me in
<roptat[m]>thanks nckx for the typo fix and for the logs. i don't understand the backtrace either
<nckx>It's not like I dug deep, but not finding "gbonds" in either guix or artwork was confusing.
***Dynom_ is now known as Guest703
***Leopold is now known as Jhonatan
***Jhonatan is now known as Leopold
<roptat>nckx, it's in guix
<nckx>Eh
<roptat>(gnu packages finances)
<roptat>(gnu packages finance)
<nckx>It's not here. The bisection is interfering.
<nckx>(9 steps left…)
<roptat>ah
<nckx>(I mean, I assume that's the reason, otherwise it's just cursed.)
<nckx>grep gbonds gnu/packages/finance.scm → ø
<roptat>gbonds was pushed on July 6 I think
<roptat>ah no that's the commit date
<nckx>Right. I'm somewhere before that.
<nckx>git bisect run makes you lazy.
<crono>Has anyone removed gdm successfully? I had removed it from my
<crono> desktop-services and deleted /var/lib. I had followed old irc logs and
<crono> email lists, did it all and still loads?
<crono>could it be from downloading the gdm package?
<nckx>No.
<nckx>It must not really be removed from your list of services.
<nckx>E.g., maybe your using some code intended to match gdm, but failing to?
<nckx>(Or you didn't reconfigure, but I'm assuming you did.)
<crono>reconfigured with deleting /var/lib but it still loads
<crono>Im able to load the KDE DM but never DM's all together
<nckx>/var/lib does not appear relevant here.
<crono>sorry /var/gdm
<nckx>Same.
<nckx>Could you paste(.debian.net) your system configuration?
<crono>yes one second
<crono> https://paste.debian.net/1247600/
<ryuslash>good morning Guix :)
<apteryx>interesting... in a 'guix shell -C -- make', with a makefile target recipe starting with $(CURDIR)/some-script something, it complains that /home/$USER/project/some-script doesn't exist
<crono>my config is there, tell me if any thing is wrong
<crono>But I was looking at the delete function and it takes an element and a list, but I only passed the gdm-service-type.
<crono>So im wondering if should put it at the top of the function.
<podiki[m]>apteryx: does there need to be an explicit glibc in the container?
<nckx>crono: No, your usage looks correct. That delete isn't a function (procedure), it's not the delete from srfi-1 or Guile, it's syntax from modify-services.
<nckx>Aargh, can't build a VM because of stupid Cantarell.
<crono>I gotta build the linux kernel again :/
<crono>I'll investigate later, the build will take forever
<nckx>…and your IRC client uses precious CPU cycles? 🤨
<nckx>Anyway, found the problem:
<nckx> https://git.savannah.gnu.org/cgit/guix.git/tree/gnu/services/xorg.scm#n1048
<apteryx>podiki[m]: good question; apparently ELF binaries embed their copy of the dynamic linker, so perhaps they do not need /lib/ld-linux.so to run; non-ELF probably wants to find /lib/ld-*.so, although I'm no expert
<apteryx>(talking about non-Guix FHS binaries)
<apteryx>it's probably a good idea to include it, in case some FHS binary has a use for it or assumption (all FHS systems would have it)
<podiki[m]>also not an expert despite my hours in the fhs container
<nckx>crono: Do not ask me why, I cannot fathom why, but there it is, shamelessly existing. So you need to (set-xorg-configuration (xorg-configuration (keyboard-layout keyboard-layout)) sddm-service-type)
<nckx>It's bizarre.
<nckx>sneek: later tell crono: https://logs.guix.gnu.org/guix/2022-07-18.log#201457
<sneek>Okay.
<podiki[m]>whenever I think I know what to expect I get surprised, so just covering everything is my plan: path, /lib directories, glibc with ld cache
<podiki[m]>non-guix binaries seem to go nowhere fast without glibc ld cache set up, in my experience
<nckx>‘cache’
<apteryx>OK
<apteryx>without the cache, wouldn't it just cause ld to scan /lib, then /usr/lib, etc?
<podiki[m]>I've also seen some build scripts decide to cache the /gnu/store/...profile/lib path it had libraries from, which led to confusion when I added more
<lilyp>set-xorg-configuration was a mistake
<podiki[m]>apteryx: that was Ludo's point in the email, but I haven't had much luck with binaries at least without the cache
<nckx>lilyp: IMVXTHO… probably yes.
<podiki[m]>hell even rustup's instructions to just pipe a curl to sh won't work (sh not in the path by default or something)
<lilyp>curl bash would work, but you're probably missing all the other stuff that bash script calls
<podiki[m]>all the FHS stuff makes me appreciate Guix more, seems crazy on the outside (all the symlinks etc) but is well defined in the end vs the chaos of global cache, /lib, etc
<podiki[m]>lilyp: in a container trying to run 'sh' won't work; with bash added to the container sh and bash will work
<lechner>Hi, does anyone have an issue with delayed keyboard input in lowriter?
<podiki[m]>a quirk of how PATH is set/not set in a container
<lilyp>podiki[m]: oh, sure, but you normally do have a shell in guix system
<podiki[m]>(since /bin/sh is created, but /bin not on PATH I guess)
<podiki[m]>yes, just meant in containers, you are correct in normal guix system
<lilyp>/bin ought to be in path tho
<podiki[m]>alas, just the profile/bin is
<podiki[m]>which is why in the fhs code I was setting up PATH with /bin, /usr/bin etc.
<lilyp>but the container sneakily calls the shell, it does not symlink the shell to /bin
<podiki[m]>the container also creates /bin/sh symlink to bash's bin/sh
<lilyp>brb rebooting
<podiki[m]>godspeed
<nckx>lechner: I'm not on bleeding master & don't have a ‘lowriter’ executable, but: no.
<nckx>It's as zippy as GUI applications ever get, which is relatively.
<nckx>lechner: Any specific key( combo)s I should try?
<apteryx>building qtwebengine: "ld: obj/third_party/boringssl/libboringssl.a: error adding symbols: file format not recognized" eh?
<lechner>nckx: locally i see a keypress delay of nearly one second, after which key presses are processed in bulk. i am not sure it's a new issue. I think it is related to my X setup or maybe libinput
<lechner>mouse too
<nckx>Does LO support Wayland? Otherwise I'm running it under Xwayland. Neither mouse nor keyboard have unreasonable lag.
<nckx>Your usual ms range, I mean, nowhere near a second.
<mbakke>apteryx: that error sounds similar to what prompted the "increase-resource-limits" phase of ungoogled-chromium (see the comment), probably worth a shot
<mbakke>if it was on the very last step, at least
<lilyp>lechner: does this only happen for the first few characters you type (as well as after you stop for a while) or is it more or less continuous?
<efraim>nckx: I'm pretty sure it runs on wayland. on my desktop at home it seems to inherit the UI style I apparently have set
<lechner>lilyp: the key strokes are processed in bulk (as if on a buffer flush) but the behavior is constant
<lilyp>hmm, could you monitor your cpu usage side by side? anything suspicious about the loffice process?
<apteryx>mbakke: checking, thanks. do you think building/linking with clang/lld would help? ungoogled-chromium uses that
<mbakke>apteryx: dunno, probably not
<gnucode>hello guix! What's going on?
<NaturalNumber>salutations guix
<NaturalNumber>i'm trying to install a crypto wallet, exodus, but i can't seem to run the executable
<NaturalNumber>the instructions are very simple ( https://support.exodus.com/article/36-how-do-i-install-exodus#linux-zip )
<lechner>lilyp: I do not see anything unusual about 'soffice.bin --writer' except that it runs with '--splash-pipe=5" and there is also a process 'oosplash --writer' open on the same file
<NaturalNumber>basically: unzip the file and run ./Exodus but i get: "Failed to execute process './Exodus'. Reason:
<NaturalNumber>The file './Exodus' does not exist or could not be executed."
<NaturalNumber>are there any other ways to run a crypto wallet on guix?
<nckx>NaturalNumber: Random binaries from the Internet don't tend to like Guix (hard-coded file names etc.). Soon there will be an FHS emulator, but for now you can use patchelf if you're desperate for crypto.
<nckx>sneek: later tell gnucode: Hullo :)
<sneek>Okay.
<apteryx>NaturalNumber: the typical answer to have something runnable on Guix not yet packaged: package it properly
<nckx>NaturalNumber: Well, plan A would be to package Exodus from source, if that's doable.
<nckx>It's not that hard in principle, but some software likes to make it hard.
<NaturalNumber>hmm, i actually started making a package for it :D
<NaturalNumber>it's not open source though so i'll probably abandon it
<nckx>> crypto wallet
<nckx>> ‘not open source’
<NaturalNumber>i know XD
<nckx>Well, everyone does their thing :)
<NaturalNumber>fortunately the guix channel provides bitcoin and monero which is all i need
<nckx>Fair warning, Guix isn't designed with proprietary software in mind.
<civodul>jpoiret: hi! i'm looking at https://issues.guix.gnu.org/53210 and what you proposed is pretty much ready to me
<nckx>It doesn't explicitly make it impossible or hard but there's no support or work to make it easy either.
<NaturalNumber>nckx, i know, i'm a fan of stallman :D
<jpoiret>civodul: do you think so?
<jpoiret>i haven't worked on that in a long time
<jpoiret>i don't remember it being ready for prime time, but maybe it's because i didn't feel like i had tested all the different combinations
<civodul>jpoiret: i replied with a few comments, and i'd say the same today i think :-)
<NaturalNumber>and i am somewhat desperate, a lot of online wallets/exchanges have been tanking lately
<apteryx>mbakke: I used lld/clang and this time it failed at linking in less bizarre ways: https://paste.debian.net/1247616/
<civodul>jpoiret: so it's not necessarily the end of it, but it's the first step
<jpoiret>i can look at that tomorrow then
<civodul>awesome
<civodul>let me know if the comments don't make sense or whatever
<NaturalNumber>does guix need help with people contributing packages?
<jpoiret>yes
<podiki[m]>civodul: back on the fhs question, I didn't follow what you tried regarding PATH; in `guix shell -C` if you then try to run 'sh' it fails (just a symlink from /bin/sh to bash's bin, but PATH is just profile/bin)
<nckx>NaturalNumber: both ‘yes, please contribute what you miss’ and ‘we really need reviewers almost more than packages’.
<jpoiret>civodul: i'll reply to it by mail too, but regarding the guix describe business, if guix doesn't find the info in the manifest it should fall back to guix/config.scm so i think it works fine
<NaturalNumber>nckx what is a reviewer?
<nckx>People who read and test patches and suggest changes, if needed, or give general advice.
<jpoiret>note that it doesn't need to be someone with commit access. Someone saying 'looks good' helps the committers work tremendously
<nckx>The unfortunate reality is that, yes, new contributors are *very* welcome but they might not feel like it because nobody replies to their patch. That's very unfortunate.
<nckx>(Did I say unfortunate enough?)
<podiki[m]>BUT there is movement to reduce friction for first time contributors especially
<civodul>jpoiret: noted!
<nckx>Doesn't change the fact that you're welcome, you just have to remind yourself, and we need to do better, and yes, there was some movement in that area which I still need to catch up with and am hopeful about.
<NaturalNumber>nckx where does one read/test packages and suggest changes
<jpoiret> https://issues.guix.gnu.org/ would be the place for that
<jpoiret>it's just a front-end to the debbugs issue tracker, that uses mail, so you're encouraged to use a text mail client to participate
<jpoiret>to test packages, you'll need a working checkout of guix, see https://guix.gnu.org/en/manual/devel/en/html_node/Building-from-Git.html#Building-from-Git
<jpoiret>to apply patchsets, you can download them with issues.guix.gnu.org/issue/<xxxx>/patchset/<n> i think
<jpoiret>and then just `git am`
<NaturalNumber>jpoiret: awesome, thanks!
<NaturalNumber>i'll keep that in mind as i familiarize myself with the system
<nckx>Don't hesitate to ask for more help at any step of the ay.
<nckx>*way!
<NaturalNumber>nckx: thanks! will do :)
<mbakke>apteryx: strange. Is NSS actually available at build time?
<nckx>Is this because we put it in /lib/nss for some reason?
<apteryx>it should be yes (nss is in inputs)
<antipode>bluetooth seems to be misconfigured or something on Guix System: https://paste.debian.net/1247621/
<roptat>nckx, how's bisect doing?
<nckx>Yeah uhm I *just* restarted it because I ran out of space on / 😒
<antipode>"Connection ":1.131" is not allowed to own the service "org.bluez" due to security policies in the configuration file"
<jpoiret>i don't have this issue personally
<jpoiret>but arf, good old dbus shenanigans
<antipode>I'll try the 'did you turn it off and on again'
<jpoiret>always good to double check
<antipode>not a proper solution but might cost less time
<nckx>Bluetooth works fine here, too.
<apteryx>nckx: if it uses pkg-config it should -L${libdir} in front, where libdir=${prefix}/lib/nss
<jpoiret>sneek, later tell antipode: weird, we don't have a dbus policy for bluetooth, so i don't think it should work at all
<sneek>Okay.
***antipode is now known as maximed_
<nckx>😮
<maximed_>After a reboot, it now finds an "Android TV" in the Bluetooth devices
<NaturalNumber>say i install a package with an unmet dependency that's available on guix, is this intended behavior?
<nckx>Often.
<maximed_>what does an unmet dependency mean here?
<nckx>NaturalNumber: If the dependency isn't strictly needed (‘optional’ as they say), it is left up to the user to install. If the package doesn't work without the dependency, it is a bug.
<maximed_>OOps I forgot to change the nick previously
<nckx>I'm relieved, I was just about to make a quip about another satisfied Telenet customer being disconnected.
<maximed_>Anyway the new laptop works with Guix System, at least with some supplements from elsewhere (didn't test without)
<NaturalNumber>maximed_: for example i install a package but it gives an error, until i do another "guix install"
<nckx>That would be said bug.
<nckx>Which packages?
<nckx>ABI mismatches make bisection a chore.
<NaturalNumber>nckx: a package called rbw requires pinentry
<nckx>Right, but Guix can't know *which* pinentry.
<nckx>So as long as rbw errors out with ‘missing pinentry’ or something similarly helpful, the user can just install their favourite.
<NaturalNumber>ahh okay cool
***maximed_ is now known as antipode
<nckx>Hard-coding a lowest common denominator (which would be pinentry-tty) might make it hard to use others. I don't know, I'm not familiar with rbw, this was a general answer.
*nckx waves hands generally.
<antipode>IIRC, they have different names
<sneek>antipode, you have 1 message!
<sneek>antipode, jpoiret says: weird, we don't have a dbus policy for bluetooth, so i don't think it should work at all
<antipode>pinentry-qt and pinentry-gtk etc
<nckx>antipode: Exactly.
<nckx>Even if they didn't, that wouldn't solve the problem.
<nckx>Well, a bit of patching probably would, but *waves hands*.
<antipode>So FWIW we could probably substitute the default pinentry->/gnu/store/.../ for a default, OTOH maybe closure size concenrs
<antipode>* concerns
<antipode>(unless it looks it up in PATH and doesn't expect an absolute file name)
<nckx>And which default? One that might not launch for some users? I know -gtk falls back to ncurses, but there are situations where even ncurses doesn't work well. Does it fall back to… raw pty, I guess, then?
<nckx>(We don't want it falling back *too* far and echoing the passphrase, of course.)
<nckx>OK, looking at the rbw recipe was wholly unenlightening.
<antipode>Does someone know how to use usbguard on Guix System?
<antipode>I thought there was a usbguard service, but there's only a package
<nckx>There's a promisingly-name default_pinentry that defaults to just "pinentry", I'll try patching it.
<antipode>I'll do without usbguard for now
***ChanServ sets mode: +o litharge
***litharge sets mode: -bo crk!*@*$##fix_your_connection litharge
<NaturalNumber>i have had a very difficult time setting up xmonad on guix, still haven't quite accomplished it. tried playing with .xsessions, installing lxde and setting xmonad as the wm, and other ways without much luck
<NaturalNumber>i noticed nixos has the option to set your desktop environment to something like "xfce+xmonad"
<NaturalNumber>i wonder if something like that would be possible on guix?
<dcunit3d>have pipewire/wireplumber been pretty stable in guix? i've been meaning to switch over, but i'm having some issues with wireplumber on arch
<apteryx>mbakke nckx a bit longer tail of build log, still failing: https://paste.debian.net/1247630/
<apteryx>this may be useful, it's what CMake used: https://paste.debian.net/1247631/
<nckx>‘use -v to see invocation’ because C++ builds are fast and pleasant to repeat.
<nckx>(I don't see the full linker command line in the log.)
<podiki[m]>NaturalNumber: you could try the package xinitrc-xsession; that's what I use to launch xmonad (via my ~/.xinitrc) and my environment from sddm/gdm/etc
<podiki[m]>NaturalNumber: and if it helps, you can see my X dotfiles here https://github.com/podiki/dot.me/tree/master/x11
<NaturalNumber>podiki[m], awesome! thanks
<podiki[m]>welcome! hope it helps
***the_tubular57 is now known as the_tubular
<apteryx>nckx: thanks, interesting running 'make VERBOSE=1' in the build environment rebuilds everything
<PotentialUser-17>Hi, I'm trying to set up mpd on Guix System. I've added the most simple default service configuration of mpd-service-type, but /var/log/messages shows that mpd keeps exiting with exit code 1. I'd like to fix this, but can't find any logs for mpd on my system. Is there any way to get service-specific log files on Guix System?
<apteryx>nckx: https://paste.debian.net/1247635/
<nckx>So that was a waste of your time. You said you were in the build environment; where's -lnss3 coming from?
<nckx>apteryx: I only have 4G of RAM on hand, if you're wondering why I don't actually help :) It would be a nice forced reboot but little more.
<apteryx>hmm, perhaps the -v didn't propagate down to clang
<apteryx>I put it in the NINJAFLAGS, which are baked following CMake so had to sed them in...
<NaturalNumber>podiki[m], what does specification->package do, other than create a package from a specification? can i just add xinitrc-xsession to my system packages?
<nckx>> guix build: error: executing SQLite query: database disk image is malformed
<nckx>Honestly…
<nckx>I got basically nothing done today. Thanks, computers.
<podiki[m]>NaturalNumber: yes you can add it to system packages, I believe I used specification-> so that I didn't need to include the module with the package in the config
<podiki[m]>but you can add the module and just use xinitrc-xsession by name instead of the specificatio-> procedure
<NaturalNumber>ahh, interesting. thanks
<nckx>‘wrong # of entries in index IndexDerivationOutputs’ — familiar to anybody? (Why's it always the bloody indexes?)
<apteryx>nckx: it's not the first time I see you post this kind of SQLite error
<apteryx>is something up with your drive/file system?
<nckx>That would've been on a different drive, machine, and file system, so I'm just cursed.
<nckx>My face makes SQLite sad.
<nckx>(No, I don't ever touch the DB or do things to it.)