IRC channel logs

2021-07-11.log

back to list of logs

<lfam>the_tubular: Are you using Guix System or Guix on another distro?
<the_tubular>Guix System, inside WSL though
<lfam>Okay
<drakonis>its inside a vm
<drakonis>wsl 1 or 2?
<the_tubular>2
<drakonis>well okay, that's a weird thing
<lfam>You should be able to do `export PATH=/run/current-system/profile/bin:/run/current-system/profile/sbin` and get many of the commands back
<lfam>It's not a fix, but it can get you moving again
<lfam>You could also add `/home/the_tubular/.guix-profile/bin`
<lfam>What is the value of PATH, by the way?
<lfam>`echo $PATH`
<the_tubular> /run/setuid-programs:/root/.config/guix/current/bin:/root/.guix-profile/bin:
<lfam>Huh
<lfam>It's missing /run/current-system
<lfam>You're root?
<the_tubular>Yeah, this is the error I'm getting
<drakonis>but why are you root?
<lfam>What method did you use to become root? Like, did you log in as root? `sudo -i`? `sudo su`? `su`? Etc
<the_tubular>This is the script that I used to start guix daemon : wsl.exe -d guix /bin/busybox sh -c "/mnt/c/Users/KHAOZ/Documents/WSL/Guix/guix-init.sh"
<the_tubular>Guix defautls the user as root
<lfam>Hm
<the_tubular>Errr
<Reinhilde>errr
<the_tubular>WSL defaults the user as root **
<lfam>I'm a bit confused but I don't think you need a script to start guix-daemon. It will be started automatically by Guix System
<Reinhilde>That doesn't seem like Guix System then?
<the_tubular> https://gist.github.com/vldn-dev/de379bf81a80ff0a53cd851bcc3bbff2#file-wsl-scm
<Reinhilde>WSL is more like a chroot, isn't it?
<the_tubular>This is what I did to get guix inside WSL2
<lfam>Your config.scm looks fine
<drakonis>you dont have to do this every time, do you?
<the_tubular>drakonis, No, only run this script : guix-init.sh
<the_tubular>But this script is failing cause of a missing symlink I'm pretty sure
<the_tubular>But I can't make symlink, when I ln it says command not found
<lfam>I'm out of my depth. I've never used WSL
<lfam>It doesn't seem like the installation of Guix System was successful, however
<the_tubular>Yeah, guix is installed, it used to work great for a few weeks
<lfam>What do you mean that WSL "defaults the user as root"? Do you get a login prompt after booting?
<the_tubular>No, when I launch guix from WSL, I'm root
<Reinhilde> https://umbrellix.net/~ellenor/ithinkibrokeit4.txt
<the_tubular>No login prompt
<lfam>Hm. That's something very different
<lfam>Did you install Guix from the installation image?
<the_tubular>I did exaclty like the gist I posted above
<drakonis>Reinhilde: oboi
<drakonis>are you sure this isnt being caused by setting the locale var?
<Reinhilde>fyi I'm on foreign-distro.
<Reinhilde>drakonis, should I unset all locale variables?
<drakonis>well, unset the one you're using when launching?
<Reinhilde>ok..
<Reinhilde>but none of this should be causing "substitution failed"
<lfam>What is `ln -s none /run/current-system` supposed to do, the_tubular?
<drakonis>there's a "unknown file" line
<drakonis>In unknown file:
<drakonis> 5 (symlink "NetLock_Arany_=Class_Gold=_F?tan?s?tv?ny:2.6?" ?)
<lfam>That's a locales problem Reinhilde, drakonis
<lfam>Your system's locales aren't set up to handle that filename
<the_tubular>I kind of follwed it blindly to be honest lfam, I'm not really familiar with every symlink that should be present on a guix system
<Reinhilde>So, is the filesystem not capable of handling it?
<lfam>Make sure that GUIX_LOCPATH is set correctly in the context where the guix-daemon runs
<the_tubular>But I think I'm making progress
<the_tubular>I started guix-daemon manually, and it seems to work fine ...?
<drakonis>the filesystem doesnt do utf-8?
<Reinhilde>I thought ZFS did UTF?
<Reinhilde>anyway, all this stress is giving me a vocal nodule
<lfam>the_tubular: That command is weird. It's supposed to link a file called 'none' into /run/current-system, but /run/current-system is kind of important
<drakonis>surprisingly not
<lfam>Reinhilde: No, the filesystem can handle it. Locales are configured at the system level
<lfam>How do you start the guix-daemon Reinhilde?
<drakonis>not by default lol
<drakonis>also why not toss it in a vm instead?
<drakonis>zfs needs some flag to do utf-8 it seems
<drakonis> https://rubenerd.com/forgetting-to-set-utf-normalisation-on-a-zfs-pool/
<lfam>the_tubular: That ln command could be paraphrased as "totally break my system"
<drakonis>perhaps this will solve the problem?
<drakonis>lfam: symlinks ahoy
<Reinhilde>lfam, Not the right way.
<the_tubular>I'm not even sure what the -s switch does on ln
<drakonis>symlinks
<the_tubular>Got it
<lfam>Reinhilde: Well, make sure to set GUIX_LOCPATH where you do it: <https://guix.gnu.org/manual/en/html_node/Application-Setup.html>
<the_tubular>It seems to work fine starting the daemon manually right now
<lfam>the_tubular: It's a symbolic link
<lfam>As opposed to a hard link
<the_tubular>It's just a bit "dumb"
<lfam>A rare case where a UNIX command doesn't work in the commonly used by default
<the_tubular>That daemon should start with WSL lol
<lfam>Commonly used way
<lfam>It's definitely a unique way of using Guix System the_tubular. We have methods for virtualizing the OS documented in the manual. Those are supported and people will help if something goes wrong
<lfam> https://guix.gnu.org/manual/en/html_node/Running-Guix-in-a-VM.html
<lfam>It's based on QEMU
<drakonis>and windows has qemu mind you
<drakonis>but none of the fancy pants integrations with the windows shell
<the_tubular>Yeah, that guide probably won't work under WSL, as the kernel is not the same, and there's some weird things with the bootloaders to do too
<the_tubular>Also WSL creates folder and files automagically inside the distro you import
<lfam>Huh. Well, that's a different operating system than Guix System :)
<drakonis> https://github.com/Trundle/NixOS-WSL perhaps this is an interesting way to go
<drakonis>for inspiration
<the_tubular>Let me take a look
<drakonis>oh
<lfam>Doing it in QEMU based on our instructions is the happy path
<drakonis>the problem here is that wsl2 has a different init
<Reinhilde>Right, let's try this black box change
<the_tubular>Yes drakonis
<lfam>It sounds to me like it would be better to use Guix on another distro on WSL2
<drakonis>^
<the_tubular>But I like guix system :(
<drakonis>that's a workable compromise
<lfam>But you aren't using it the_tubular :)
<lfam>You're using something else
<the_tubular>It's probably 1 symlink that I messed up :/
<the_tubular>What am I using then ?
<lfam>Something new
<drakonis>Reinhilde: you're welcome to come back to guix some other time
<lfam>I wish I knew more about WSL to give better advice
<lfam>I'm really in the dark
<Reinhilde>mm
<the_tubular>I wish I could leave Windows behind for good :(
<drakonis>wsl2 is a linux vm running under hyper-v, it provides various integrations with windows
<lfam>But, if WSL is automatically creating some things in the filesystem, and inserting a different kernel, that's just something different from Guix System.
<the_tubular>Well it is a Linux kernel AFAIK
<lfam>Maybe there is a nice QEMU GUI for Windows
<lfam>Well, yeah :) It would be really cool if it happened to work with a different kernel though
<the_tubular>Well I used WSL2 to run virt-manager to manage my other VMs
<lfam>Aha
<lfam>That's what I would do
<lfam>I think you could boot our QEMU image with virt-manager, right? https://guix.gnu.org/download/
<the_tubular>Yes, I also used guix system inside QEMU, those work fine :)
<lfam>I'm sorry to respond to your questions with "do something else", by the way
<drakonis>microsoft's running a custom kernel atm
<drakonis>its complicated
<lfam>Maybe I should keep my mouth shut when I don't have the answer to the question you asked
<the_tubular>It's fine, someone in here pointed my towards the tutorial I linked, I'll just wait for him to be online ^^'
<lfam>Okay, they will probably know what to do
<the_tubular>I forgot his name though :/ And I'm stuck using IRC with the webchat right now so no logs
<Reinhilde>let's try en_US rather than C
<lfam>Roughly how long ago was it?
<lfam>Reinhilde: That sounds right
<Reinhilde>idk why C isn't aliased to en_US internally?
<lfam>the_tubular: You could try looking it up here: https://logs.guix.gnu.org/
<drakonis>ask the glibc people :V?
<drakonis>also posix?
<lfam>Reinhilde: They are different things, if I understand correctly.
<lfam>The C locale predates UTF by a loooong time
<lfam>And yeah, nothing ever changes in UNIX land
<Reinhilde>wh@t >.<
<drakonis>okay what now
***newjuice[m] is now known as Skuwu[m]
<Reinhilde>I think we're getting further than we had been
<the_tubular>Next thing would be packaging WSLU for guix, shouldn't be that hard as it's just a bunch of shells scripts
<Reinhilde>wslu?
<the_tubular>It's a bunch of shells scripts that enable you to use emacs as a default windows text editor, for example
<Noisytoot>but guix doesn't run on windows
<Noisytoot>(at least directly)
<drakonis>its in a vm, my guy
<drakonis>wsl2 is a linux vm
<the_tubular>Well emacs is probably not a good example as it runs on windows (?)
<Reinhilde>this... might be wsl1
<drakonis>no, wsl2 has the same obnoxious init replacement behavior
<Reinhilde>oh..
<Noisytoot>How can a program in Guix change the default windows text editor?
<drakonis>because wsl2 lets you run graphical applications with a x client
<the_tubular>It's probably off-topic, but here Noisytoot : https://github.com/wslutilities/wslu
<the_tubular>My end goal would be to run pretty much everything inside WSL2, even my Browser, as I want to interact with Windows the least I can
<drakonis>Reinhilde: you good right now?
<Reinhilde>seems so
<drakonis>cool
<the_tubular>The only thing missing from Guix's repo is some pentesting tools
<drakonis>that can always be dealt with
<the_tubular>I'll get on that and try packaging 1-2 easy
<lfam>We have nmap, curl, openssh, telnet... ;)
<the_tubular>one *
<Reinhilde>={
<Reinhilde>=)
<the_tubular>True, but there's some big one missing like Metasploit, Zapproxy. I doubt I'll be able to do those though
<lfam>Also I packaged thc-ipv6 which has certainly got some sharp edges
<lfam>Alright. We have a guideline to not package "malware", which is definitely a gray area with some tools. Like, it depends what you are using it for
<lfam>So, how you present and describe the package does matter
<lfam>Oh, can't forget netcat! We have a bunch of netcat implementations
<Noisytoot>How can netcat be malware?
<the_tubular>You think Metasploit will break that rule ?
<drakonis>this is why we have channels
<the_tubular>If that's the case, I'll try making my own channel, with the few tools that are going to get rejected
<the_tubular>exactly drakonis
<the_tubular>Also, I'd guess that WSLU might be against the rules too, as it is not "for guix"
<lfam>If it's free software, then it's welcome
<pkill9>lfam: that's not entirely true, if the only purpose of the free software is to deliver nonfree software, then it won't be accepted
<pkill9>like MultiMC (launcher for minecraft)
<lfam>It's true enough
<the_tubular>lfam mind pointing me to those guidelines? I'd like to read them
<lfam> https://www.gnu.org/distros/free-system-distribution-guidelines.en.html
<Noisytoot>Is WSLU's only purpose to deliver nonfree software?
<Noisytoot>It only works with Windows/WSL, which is nonfree
<the_tubular>Yes, but it doesn't deliver it
<Noisytoot>It has a nonfree dependency (Windows/WSL)
<lfam>mingw could be described in a similar way
<the_tubular>I am not familiar with mingw
<dstolfa>yes but so does emacs on windows, that doesn't mean that you can't provide it for windows users in order to introduce them and educate them about free software
<the_tubular>Anyway, it's not a big problem, I actually had plans to start my own channels, I just wanted to read the guideline to have a better comprehension
<Noisytoot>Could mingw be used with reactos?
<the_tubular>I don't think that metasploit would go against that rule either "The distro must contain no DRM, no back doors, and no spyware."
<Reinhilde>I thought dependency was a one-way arrow usually? WSLU is depended on by WSL - not the other way round
<Reinhilde>WSLU is only needed if running inside WSL
<Noisytoot>Reinhilde, WSL doesn't require WSL
<civodul>comrades, simplified package inputs merged in core-updates! https://issues.guix.gnu.org/49169
<sneek>Welcome back civodul, you have 1 message!
<sneek>civodul, apteryx says: re on-line manual fix, thank you, you rock!
<Noisytoot>*WSL doesn't require WSLU
<civodul>the beginning of a new era :-)
<drakonis>noice
<dstolfa>civodul: woohoo!
<Reinhilde>Noisytoot: wouldn't it then be like guest additions?
<the_tubular>Wow, great news civodul!
<Noisytoot>Reinhilde, What do you mean?
<drakonis>oh a guix style command
<drakonis>finally, a linter
<dstolfa>drakonis: there's already `guix lint` :P
<Reinhilde>makes things substantially nicer if you must use WSL?
<drakonis>oh
<drakonis>huh
<drakonis>oh no
<drakonis>wrong word
<Reinhilde>one of us needs to start a non-free channel. it won't be me, i'm a bsd nut
<the_tubular>There is non-guix, but it is off-topic here
<Reinhilde>as all things are
<drakonis>i wanted to fix up the style
<drakonis>my parens look ugly :(
<Reinhilde>mine too
<the_tubular>s/ns/nts
<Reinhilde>the_tubular: ... ew.
<Noisytoot>civodul, Will input labels still be supported?
<Noisytoot>Reinhilde, WSLU itself isn't nonfree
<Noisytoot>so it would be more like a contrib channel (if WSL2 isn't FSDG-compliant)
<Reinhilde>ah
<Reinhilde>anyway, i'll leave for the week
<lfam>Wooow civodul
<the_tubular>But yeah, been exploring guix for about a week, and I must say, I am very impressed
<ebubekir-siddik>Hi, how do I automount a LUKS encrypted partition in guix?
<Noisytoot>ebubekir-siddik, add a luks-device-mapping
<Noisytoot>to your config.scm
<Noisytoot> https://guix.gnu.org/manual/en/html_node/Mapped-Devices.html
<civodul>Noisytoot: yes, input labels remain valid
***Kitty[m] is now known as KittyOwO[m]
<ebubekir-siddik>Noisytoot: many thanks
<Reinhilde>oh no...
<Reinhilde>zsh: /root/.local/bin/guix: bad interpreter: /gnu/store/3v93dzrmh978mljw65zvvydm2w8lqaam-guile-wrapper/bin/guile: aucun fichier ou dossier de ce type
<Noisytoot>What?
<Noisytoot>Why is "aucun fichier ou dossier de ce type" there?
<Reinhilde>"no file or folder of this type"
<Reinhilde>is what it means word for word
<Reinhilde>ENOFILE, basically.
<Reinhilde>also I always use linux in french, so that's why it's there
<lfam>~/.local/bin/guix is an unusual location
<lfam>Do you mean to use it?
<lfam>It's more typical for `guix` to be found at ~/.config/guix/current
<Reinhilde>oh
<Reinhilde>zsh: /root/.config/guix/current/bin/guix: bad interpreter: /gnu/store/3v93dzrmh978mljw65zvvydm2w8lqaam-guile-wrapper/bin/guile: aucun fichier ou dossier de ce type
<Reinhilde>still bad. Is this a known side effect of `guix system init` attempts?
<Reinhilde>on foreign distros?
<lfam>Not that I've heard of
<lfam>Well... hm
<lfam>Interesting question
<lfam>Hard to say
<lfam>I wonder if `guix system init` overwrote your /gnu/store
<Reinhilde>it probably did, yeah.
<lfam>That would cause problem
<lfam>s
<Reinhilde>yeah..
<lfam>In that case, you could just delete ~/.config/guix/current, and /var/guix and reinstall
<lfam>Not great...
<the_tubular>Also, I'm having access to a cloud VM, and I'd like to install guix system on it. There's currently a live CD on it with the disk not formated. How would I go about that ?
<Reinhilde>I'm fine with doing that lfam.
<lfam>There is also /etc/guix and ~/.cache/guix but I think they are harmless
<lfam>Oh, also ~/.guix-profile
<Reinhilde>I'm just blowing it all away
<Reinhilde>except maybe cache
<lfam>Yeah, that is just a cache
<lfam>It can only help
<lfam>I delete it sometimes, it doesn't make a difference
<lfam>The main things that are cached are substitute availability and the Guix git repo
<podiki[m]>civodul: awesome! that looks much nicer
<euandreh>"New `deb' format for the `guix pack' command"! Mind-blown!
<euandreh>I'm trying this immediately
<the_tubular>New deb format ?
*the_tubular is confuzzled
<the_tubular>Ohh I thought there was a new deb format, neverming. Ignore my last message :P
<Reinhilde>oops.
<MysteriousSilver>I accidentally deleted my /etc/profile, can someone share the GuixSD defaults?
<lfam>MysteriousSilver: It's here: <https://git.savannah.gnu.org/cgit/guix.git/tree/gnu/system.scm?h=v1.3.0#n887>
<MysteriousSilver>oops, i'm dumb
<MysteriousSilver>meant to say /etc/hosts
<lfam> https://git.savannah.gnu.org/cgit/guix.git/tree/gnu/system.scm?h=v1.3.0#n842
<lfam>On each line, the IP address, localhost, and your hostname
***Ellenor is now known as Reinhilde
<MysteriousSilver>thanks
<SubUser>Hello, I want to use opencv package for python, but there's an ImportError: "libstdc++.so.6: cannot open shared object file: No such file or directory". To my knowledge, it cannot find the C++ standard library which is weird because I can compile using g++ just fine. I've also found out through the Guix package repository that opencv is out-of-date and there's something wrong with its CI. does anyone else
<SubUser>have these issues?
<SubUser>Sorry, I had to reboot, so does anyone also have issues with opencv?
***avoidr_ is now known as avoidr
<mfg>hi, how do i use mingw on guix? `guix environment --ad-hoc mingw-w64-x86_64` has no compiler in it's `bin` directory.
<leoprikler>mfg: (let ((triplet "x86_64-w64-mingw32")) (list mingw-w64-x86_64 (cross-gcc triplet) (cross-binutils triplet)))
<mfg>leoprikler: how do you mean that?
<leoprikler>that's scheme code to work inside a (pseudo)manifest
<leoprikler>to get the mingw compiler, you need cross-gcc and cross-binutils
<mfg>ahh okay, i'm going to try it now
<mfg>leoprikler: thanks that worked :-)
<bricewge>Is there a procedure to append a string to a file-like?
<cbaines>I'm not quite sure what you're asking, but there's file-append
<bricewge>It's not file-append that I'm looking for
<cbaines>Ok, what's a "file-like"?
<bricewge>file-like :: https://guix.gnu.org/manual/devel/en/guix.html#G_002dExpressions
<maximed>bricewge: Are you trying to append/concatenate the contents of two file-like objects?
<bricewge>maximed: Yes!
<maximed>or a file-like and a bytevector, or a file-like and a string
<bricewge>I'm trying to modify nftables-service to be extendable by other service, ATM its configuration record ruleset is a file-like I'll like to append content to it
<maximed>and do you want the end result to be another file-like?
<bricewge>Yes
<maximed>bricewge: not quite what you wre looking for, but you can implement it with ‘computed-file’
<bricewge>s/'ll/would/
<bricewge>As in reading the initial file-like content in `compute-file`'s gexp?
<bricewge>I tought about that but I was hoping there was a more high-level procedure
<maximed>bricewge: You could write such a procedure
***Lightsword_ is now known as Lightsword
<dstolfa>if i'm updating a package (e.g. foo-0.2 to foo-0.3) and a couple of things depend on it (but all build successfully after it has been updated), is this done in 1 commit?
<ixmpp>> bricewge wrote:
<ixmpp>> But I don't know how to upstream such change, any guidance on how to go about this?
<ixmpp>Funny, i tried to merge this exact change into nixpkgs too
<ixmpp>I think it'd be easier, anyway. You can conditionally add a package transformation to the package list to replace all iptables with iptables-nft, right?
<rekado>dstolfa: make separate commits and push them together
<dstolfa>rekado: isn't this a bit... fragile?
<dstolfa>e.g. a bisect could land on a commit that just doesn't build some rust utilities
<bricewge>ixmpp: What a coincidence!
<ixmpp>maximed: http://dev.fron.io/rc/blob/master/rc/utils.scm
<soheilkhanalipur>Hello! O/
<soheilkhanalipur>Can non-free network cards be installed and used in GuixSystem without any problems?
<Noisytoot>Guix doesn't include any nonfree software
<Noisytoot>There are channels which include nonfree software, but nonfree software is off-topic in this channel
<dstolfa>rekado: i'm doing a roundabout thing where i add a package and let the old one inherit from it, and then update 1 by 1 with each commit
<Noisytoot>Why does a VM generated with https://bpa.st/462Q freeze at "error in finalization thread: Success" (with my patch to add a ZNC service <https://bpa.st/OHZQ> applied)?
<mekeor>Noisytoot: "error in finalization thread: Success" sounds bizarre xD -- does it output a working VM?
<Noisytoot>mekeor, It freezes at "error in finalization thread: Success" in the boot process
<Noisytoot>so the VM doesn't work
<mekeor>Noisytoot: looks like there can be a variety of reasons for this error: https://issues.guix.gnu.org/44257
<kraai>Hi! What is a good way to automatically start an mcron daemon when I log in?
<kraai>I tried putting `mcron -d` in `.bash_profile`, but that seems to start a daemon every time I open a terminal.
<MysteriousSilver>kraai: guixsd? use shepherd
<kraai>MysteriousSilver: OK, I'll try that. Thanks!
<mekeor>kraai: there's an mcron-service but i'm not sure if it's possible to use it as a user-service
<pkill9>also it will start it regardless whether you login or not
<pkill9>that's preferable thoughimo
***iyzsong- is now known as iyzsong
<MysteriousSilver>How do i suspend the system?
<mekeor>MysteriousSilver: i'm not on guix-system but iirc, it's "loginctl suspend"
<MysteriousSilver>thanks
<maximed>If you use a graphical desktop environment, there's probably a ‘suspend’ button next to the ‘power-off button’
<leoprikler>the questions is never “how shall I suspend?”, but always “how do I resume?”
<podiki[m]>hahah how and "will I be able to"
<tissevert>hi guix
<Jdaco>Has anyone gotten bluetooth audio working? I can connect to a bluetooth headset but no pulse output device is created
<maximed>Jdaco: try stopping gdm first
<maximed>There is a bug report on Debian's tracker about that somewhere I think
<maximed>‘GDM steals Bluetooth audio output sinks’ or something like that
<maximed>I got it to work once but I haven't been using bluetooth audio output lately
<lfam>New Linux config option for 5.13: Apple Silicon SoC family (ARCH_APPLE)
<lfam>We can start trying to use Apple M1 hardware with 5.13
<dstolfa>lfam: nice! that's a huge step forward
<drakonis>hello friend
<lfam>I got 5.13 to work fine, btw, in case anyone remembers my problems yesterday. It was a PEBKAC error
<ebubekir-siddik>Is there a firewall package in guix? ufw?
<dstolfa>are tests failing on master?
<dstolfa>syscalls.scm and build-utils.scm
<drakonis>ebubekir-siddik: no ufw?
<drakonis>that's a ubuntu thing afaik?
<lfam>UFW exists on distros besides Ubuntu
<lfam>I use it on Debian
<brettgilio>Do we have a VNC server service?
<brettgilio>I dont see anything in the docs
***hiruji is now known as armink
<brettgilio>what is the package with x11vnc?
<leoprikler>brettgilio: I don't think we have that, but we do have libvnc
<leoprikler>at least according to the libvnc git, x11vnc was split off from that at some point
<brettgilio>Im really just trying to find a way to get remote access to my guix desktop. Tigervnc is not the traditional arrangement on most other distros either
<jab>for a "simple" vpn, wireguard sure seems complicated.
<dstolfa>jab: it beats the alternatives quite a bit :P
<brettgilio>It doesnt have the vncserver binary
<jab>dstolfa: I'm having a really hard time following the example in the arch wiki. It's also really confusing because they don't distinguish very well between the client and the server.
<jab>They call both the client and the server peers.
<jab>That's confusing.
<dstolfa>jab: have you followed the guix manual for guix-specific wireguard configuration? is it missing something that you need perhaps?
<jab>dstolfa: not trying to be crass, but how can I follow the manual? There's hardly any information. Again, I'm not trying to sound rude. But following the guix manual is like trying to read Russian. :)
<brettgilio>leoprikler: not sure if you have any ideas :/
<brettgilio>im out of them lol
<jab>I mean, specifically the wireguard section for the guix manual is very short.
<jab>There's not much in the way of explaining how to set it up. :)
<jab>also wireguard's terms aren't helping either. It would have been a bit better in my opinion to use the terms clients and servers, vs. peers.
<jab>also, I'm reading online that we need to set up some iptables rules via: 'iptables -A FORWARD -i wg+ -j ACCEPT and iptables -t nat -A POSTROUTING -s 10.0.0.0/24 -o wg0 -j MASQUERADE'
<jab>does the guix wireguard server do that somewhere?
<jab>service*
<dstolfa>jab: https://guix.gnu.org/manual/en/html_node/VPN-Services.html does wireguard-configuration and wireguard-peer from here help at all?
<dstolfa>this also might help https://dataswamp.org/~solene/2021-05-22-guix-wireguard.html
<jab>dstolfa: no. It's like trying to read Russian. I'm not certain what a client vs. server wireguard-configuration looks like.
<jab>Thanks for the link!
<jab>I guess that link shows me how to set up a client wireguard...now I just need to figure out how to do the server config. :)
<jab>I'm trying to host my own wireguard server vpn.
<stikonas>I just have wireguard server vpn on my router...
<jab>stikonas: So you just have (service wireguard-service-type) ?
<jab>stikonas: are you running guix in your router? Or by router do you mean the vps server?
<jab>vpn*
<stikonas>jab: no, it's openwrt router
<jab>you're using openwrt? That's awesome!
<stikonas>well, I have openwrt one main router and also I have another wifi access point with libreCMC, although, it's not as stable
<lfam> https://www.wireguard.com/quickstart/
<stikonas>yaeh, this ^^ page seems quite helpful in general
<jab>lfam: thanks.
<lfam>It's even simpler if you use the wg-quick "example" program that comes with Wireguard
<jab>I'm just a nube. Trying to sort out how this all works in my head, is weirdly confusing.
<stikonas>other VPN servers are even more confusing...
<stikonas>wireguard is probably the simplest...
<jab>stikonas: so I've heard. :)
<lfam>It's definitely the simplest but it's still not "click and go"
<stikonas>I used to have openvpn for some time but only managed to get IPv4 working
<jab>stikonas: I was using openvpn with express vpn. I got that working. But I only had to worry about the client configuration.
***Reinhilde is now known as AmyMalik
<stikonas>well, client is easier, server takes more time to configure
<lfam>Wireguard is different from commercial VPN services, in the sense that you hvae to provide the server
<jab>now I have to do both client and server configuration. :) Still, I would agree that wireguard seems much easier.
<stikonas>in some sense wireguard server is just another peer
<jab>lfam: You mean the bit where you have to provide the server's public key?
<jab>stikonas: I find that confusing. It may be another peer, but shouldn't we call it the server?
<lfam>No, I mean you need to have a computer online somewhere that is the server
<jab>lfam: I have that. :) gnucode.me
<lfam>Okay :)
<jab>It's running guix system on a linode!
<lfam>And yeah, it's more like peer-to-peer than client-server
<jeko>Yoo Guixters!
<jab>honestly guix system is fantastic! It's been an absolute breeze and pleasure using nginx-service-type
*raghavgururajan sneeks in
<jab>hello raghavgururajan! Thanks for all your go-github work!
<pkill9>nice
<raghavgururajan>jab: Np! It was for Bitmask VPN.
***chkno_ is now known as chkno
<jab>raghavgururajan: what's bitmask VPN?
<raghavgururajan>jab: Bitmask (https://bitmask.net) by LEAP (https://leap.se). It is a generic VPN client.
<jab>ok
<raghavgururajan>jab: [1] https://guix.gnu.org/en/packages/bitmask-0.21.6/ [2] https://guix.gnu.org/en/manual/devel/en/html_node/VPN-Services.html#VPN-Services
<raghavgururajan>:)
***armink is now known as hiruji
<maximed>afaik wireguard isn't inherently client-server. I used it once a VPN (I mean ‘virtual private network’, not ‘tunnel the traffic to X’), which is rather P2P
<maximed>if you use it as ‘tunnel traffic to other country’ or something, then client-server makes more sense though I suppose
<jab>maximed: I guess I don't get the difference between tunnel traffic to another country vs. vpn.
<jab>aren't those the same?
<lfam>VPN is an acronym for Virtual Private Network
<lfam>You could think of it as a local network (LAN) that happens to transit the internet
<lfam>They are commonly used by large organizations to grant access to private resources to employees who aren't in the office
<lfam>The use of VPNs as a way to tunnel your traffic to another jurisdiction is a small use case delivered by this general tool
<lfam>Does that make sense?
<drakonis>rfc: should `guix home` be called `guix user`
<pkill9>yea
<pkill9>since it covers more than just managing the home directory
<dstolfa>+1
*dstolfa would also really like a systemd-homed like thing with guix home/user at some point
<pkill9>plus it's a nice complement to guix system
<dstolfa>drakonis: send it to the mailing list for discussion
<drakonis>sure
<pkill9>maybe the guix install/remove commands could be put under `guix user` as well
<dstolfa>pkill9: that's a good idea yeah
<dstolfa>though
<dstolfa>hmm
<dstolfa>it's per-profile in a way
<dstolfa>and one user can have multiple profiles
<pkill9>i think the `guix install` command is for the default profile, but yea
<pkill9>that's why i'd leave `guix package` on it's own
<dstolfa>ah i see
<dstolfa>yeah, that seems sensible
<dstolfa>so you'd have something like `guix user install`?
<pkill9>yea
<lfam>One aspect of having a CLI that makes sense is not changing it too often
<dstolfa>lfam: that's true, but it wouldn't need to change, it could just be added to start with
<pkill9>true lfam lol
<pkill9>it's kinda bikeshedding tbh, I'd choose consistency over this minor change
<dstolfa>it's absolutely bikeshedding
<dstolfa>:D
<dstolfa>but it's fun to bikeshed sometimes!
<pkill9>yes :)
<southerntofu>ok i sent the patches for the aparte package, let's see how long it takes to arrive :D
<southerntofu>(hello)
<drakonis>hmm
<drakonis>which one of y'alls have a regular mail server setup
<drakonis>the ones i've seen are too elaborate for my tastes