IRC channel logs

2025-02-13.log

back to list of logs

<theruran>thanks dthompson! I wonder if this code still runs on Goblins, and if it runs on Goblins on Hoot.
<theruran>FRP, constraint logic programming, theorem provers! :D
<dthompson>I suspect it would need tweaking but hopefully not a ton
<theruran>does Goblins Chat run on Hoot already?
<tsyesika>It does, it’s actually embedded in the 0.15 goblins release blog post
<dthompson>(try it in firefox ;)
<theruran>nice!
<jfred>oh dear, I've done something odd: https://paste.sr.ht/~jfred/14e0d3c49fc661b62e9d1f266a040af49f9f6a43
<jfred>and this only seems to happen when I run this in persistent vats
<theruran>so is there a way yet to have two browsers join the 'chat room' and talk to each other? locally, then remotely
<jfred>(it's also odd that the dummy-provider log message shows up twice...)
<jfred>theruran: With a Prelay server or a websocket server hosted outside a browser I believe that's possible now with the websocket netlayer: https://files.spritely.institute/docs/guile-goblins/latest/WebSocket.html (but browsers can't host websocket servers themselves)
<theruran>hmmm
<theruran>is it possible with WebRTC? https://peerjs.com/
<jfred>I think that came up in the Q&A for one of the FOSDEM talks and I forget exactly what the answer was. But I think yes, in theory, if someone were to write a webrtc netlayer (which IIRC would involve more work than writing the websocket one)
<jfred>Netlayers are expected to receive messages in the order they were sent: https://github.com/ocapn/ocapn/blob/main/draft-specifications/Netlayers.md#properties-of-a-netlayer ...and it looks like that's possible to achieve with RTCDataChannel (with the 'ordered' property)
<jfred>ACTION hasn't written webrtc code himself though
<jfred>IIRC it's also more complicated to use webrtc outside of a browser than it is websockets
<jfred>...welp, right... this error from before was *also* because I forgot to extend a persistence env: https://paste.sr.ht/~jfred/14e0d3c49fc661b62e9d1f266a040af49f9f6a43
<dthompson>yeah jfred is right about webrtc
<dthompson>it's appealing but more complicated
<dthompson>especially outside of the web browser which we are commmitted to also supporting
<dthompson>we want to explore using libp2p's js implementation, though that involves dealing with npm
<jfred>woohoo, got persistence working! :D https://paste.sr.ht/~jfred/9adbed91977bc0a86f49e49e17bacaa4f4eaf5e4
<dthompson>awesome jfred!!
<dthompson>congrats!
<jfred>thanks :)
<jfred>oh yeah interesting, libp2p does have a webrtc transport
<jfred>heh, the libp2p docs also mention rust-libp2p compiled to wasm as an option on this page: https://docs.libp2p.io/concepts/transports/webrtc/
<jfred>that probably doesn't mesh quite as well with wasm GC as the JS implementation I guess
<dthompson>cargo or npm... not sure which is worse
<jmes>I'm trying to run the guile-goblins-chat onion-server.scm but I'm getting this "no such file or directory" error: https://bpa.st/KEFQ. I notice that this is similar to a problem I had with the captp-bob and captp-alice example over tor yesterday. I tried making some of the parent directories manually but it passed the buck to more missing directories.
<jmes>I'm on the main branch of https://gitlab.com/spritely/guile-goblin-chat
<jmes>e94dd3ad24b3cd6a5ef5152d9b963784a57c959d
<dckc>I want to point some peers at all the FOSDEM talks. Want to update https://spritely.institute/news/spritely-is-going-to-guix-days-and-fosdem.html to point to the talk pages? (is there a way for me to submit a patch?)
<dckc>stickers! I want some stickers!
<jboy>there were stickers at fosdem??
<dpk>NLnet made some for us <3
<jfred>I also wish I could have gotten some stickers haha
<dthompson>dckc: that blog post has headers that link to all the talks in the schedule which now include the videos
<dthompson>jmes: that paste link 404s but sounds like you have an issue with your local tor daemon
<dthompson>regarding stickers, we brought some of our own and then we were surprised that nlnet made some as well since we are a member project
<dthompson>hopefully we'll have our merch store up before too long
<jmes>dthompson: The link is still working for me, maybe because of the '.' at the end? https://bpa.st/KEFQ
<jmes>But if I was supposed to run a tor daemon separately, then I definitely didn't do that 😅
<jmes>I just ran: guix shell --pure --no-grafts --manifest=manifest.scm; guile -L . goblin-chat/onion-server.scm jmes gobby-chat
<dthompson>yeah you are
<dthompson>the docs have a section on tor daemon setup
<jmes>Well that'll be the issue, whoops! Thanks for pointing that out
<dthompson>you're getting the no such file error because there is no unix domain socket file
<dthompson>np
<jmes>I missed the tor set up because I was skipping around the docs trying to find a netlayer example—my end goal is not to use the tor netlayer but maybe tls-tcp or ws (not sure yet).
<dthompson>if you feel comfortable doing so, swap out the tor netlayer in the example for something else
<jmes>Yeah, that's what I try after I get the example running over tor. On that topic, what netlayer makes the most sense for 2+ machines over LAN-only?
<dthompson>probably tcp-tls
<dthompson>it's the simplest one
<jmes>Cool, I'll try that one first :) I played with guile-websockets the other day and I'm happy that option exists.
<dckc>dthompson, were those links there all along? and I just missed them?
<dckc>TimBL used to advise against using headings as links. I can see why now :)
<dthompson>forgive our sins pls