IRC channel logs

2025-02-12.log

back to list of logs

<civodul>hey! i’m getting: Uncaught (in promise) LinkError: import object field 'weak_ref_deref' is not a Function
<civodul>for the Hoot code at https://www.gnu.org/software/shepherd/
<civodul>does that ring a bell?
<dthompson>civodul: perhaps your reflect.js is out of date for hoot 0.6.0?
<dthompson>(having to manually sync these files should be a thing of the past soon)
<civodul>ah, could be, lemme check
<dthompson>weak_ref_deref is the name of a imported function in to the wasm module which is used by the hoot runtime. the error is saying in a somewhat confusing way that there's no function bound to that name
<dthompson>sync reflect.js and reflect.wasm
<civodul>yes
<civodul>works better now, thanks dthompson :-)
<dthompson>civodul: you're welcome and also sorry ;)
<civodul>i guess i could also have something in haunt.scm to copy them automatically
<dthompson>gotta write the tool to auto-generate this stuff
<civodul>for another day
<dthompson>we're gonna have a little bundle generator at some point
<civodul>that’d be nice!
<jfred>Aha! It's taking a little bit for me to get used to the constraints/requirements of persistence but I think I'm starting to get it
<jfred>Was confused as to why one of my objects seemingly wasn't getting rehydrated, but there are two vats involved here... an object in one vat was returning a reference to a newly spawned object, but *wasn't retaining a reference to the new object itself*
<jfred>and I guess as a result the new object wasn't getting persisted
<dthompson>tsyesika should be able to help with cross-vat persistence stuff
<tsyesika>Heh yeah it has to be in the object graph on the vat which is persisting it
<tsyesika>I actually haven’t run into this personally and hadn’t even considered it before
<jfred>I'll just have to save it in a ghash or something on the one vat
<jfred>but it had me scratching my head for a while haha
<tsyesika>I’m excited that you’re playing around with it and getting a feel for it tho
<jfred>:)
<tsyesika>I feel like a lot of the “how do you write persistent actors” and all the pitfalls you can run into are stuck in mine and Christine’s head. Ideally I write some blog posts or something to go over them
<jfred>the context was a dummy machine provider, and in a real implementation the new object would actually live on a completely new machine: https://git.sr.ht/~jfred/gobs-of-machines/tree/feat/persistence/item/gobs-of-machines/providers/dummy.scm
<dthompson>I think there should be less pitfalls :)
<jfred>but for now I have to fake it a bit, haha
<tsyesika>Mmm I’d love to hear your thoughts on that Dave :)
<dthompson>I need to use it more