IRC channel logs

2025-02-10.log

back to list of logs

<dthompson>ACTION is back to work after a post-fosdem break
<dthompson>hey everyone
<dthompson>jfred: cool that you are trying the persistence stuff!
<dthompson>let us know what you think once you've used it enough to have opinions :)
<jfred>:)
<dthompson>seem dckc has been making his way through the FOSDEM videos
<dthompson>more of those should become available this week
<jfred>I'd have to go back and try to put together a reproduction, but I later got a more descriptive error message like "don't know how to persist this object" - I'm not sure why I didn't get that message the first time. (Maybe it had something to do with being unable to persist the root object vs. one further down in the graph)
<jfred>That would have helped me track down the problem earlier though
<dthompson>I think there's still some work to do to make it easy to get started with persistence and find issues
<cwebber>I will review my video in a few
<cwebber>jfred: I suspect you will enjoy puzzling through this unusual thing tsyesika and I put together this morning https://gitlab.com/spritely/pumpkin-soup/-/blob/main/unique-sword-xfer.scm
<cwebber>It's a combination of warding/incanting and the pebble bank
<cwebber>(pumpkin-soup is going to be a repo we put some experiments/prototypes in over the next few weeks before kicking off our next round of applications using our tech)
<jfred>ooh
<cwebber>And no that's not an NFT ;p well not in the money making scheme way. I guess it might be per the technical definition. That's not the intended use case though, this is meant to be "changing who can control something useful"
<cwebber>The interesting thing is that the idmint becomes the public Id to "talk about" the object
<jfred>the ^proxy body being a no-op function is a little funny. Think I'll have to stare at this a little more haha
<cwebber>Anyway, should put up some tests
<cwebber>Yup :)
<cwebber>It's a pebble which enables encanting
<jfred>oh that makes sense, you're just using it for the equality check
<cwebber>Yup
<cwebber> https://spritely.institute/news/pebble-bank.html
<cwebber>The names could probably be better :)
<tsyesika>There’s a version which uses warding and incanting ;)
<cwebber>Yes it's true. But it's not clear it's clearer yet :)
<tsyesika> https://gitlab.com/spritely/pumpkin-soup/-/blob/main/jessica-simple-slicer.scm?ref_type=heads
<jfred>Huh, yeah that's clever. So even if you handed someone a reference to the idmint the only thing they could practically do without the proxy is get the description
<cwebber>Yup
<cwebber>The funny thing is it's a mint with one pebble
<cwebber>And the pebble enables usage
<cwebber>This came out of a group conversation at a restaurant after FOSDEM with the Spritely engineering team :)
<jfred>and I suppose, hinted at by the fact that the argument names are different, the xchange-proxy and use-proxy don't have to be the same proxy. and then it's a mint with two pebbles :P
<cwebber>"could you use the pebble bank to do inventory management for unique items without using $"
<cwebber>jfred: there's only ever one pebble that's *valid*
<cwebber>A person handing control retains the old now-invalid pebble though
<cwebber>They just can't use it for anything once exchanged
<cwebber>I think the variables could use renaming
<cwebber>tsyesika and I figured this out on a 2 hour long call at 7am my time and then pared it down. I think it's a neat design
<jfred>I might need to think about this some more but what I was kind of getting at is that I think you might be able to split it up such that you could hand someone a pebble for usage without necessarily handing them the right to transfer ownership of the object away from you
<jfred>if for example you added a second proxy for that purpose in the ^slicer-idmint argument list
<jfred>I'm not sure if/when that might be useful
<jfred>but something like this, basically: https://paste.sr.ht/~jfred/e4f47bf2489bbe773cc0d0549866196785a49841
<jfred>of course in that case the act-proxy survives exchanges and you'd probably also want a way for the holder of the owner-proxy to change that, if you were to actually do something like this
<tsyesika>yeah it's interesting, I think you'd want to be able to revoke the act proxy. I think maybe individual revocable proxies might be a better way to achieve this given it'd allow tracking and revocation on a person/capability by person/capability basis
<tsyesika>but it's interesting to split the idea of using it and ownership up
<jfred>yeah
<binarydigitz01>I am using nixos, and i was trying to get hoot and goblins running on master branch of guile, but goblins fails some tests, is that natural or a nix thing?
<binarydigitz01>goblins works as expexted on release
<tsyesika>do you know which tests?
<tsyesika>they all should pass
<binarydigitz01>yeah gimme a sec i'll send a pastebin
<binarydigitz01> https://pastebin.com/ZwU61VyU this is the log of the entire build
<tsyesika>strange, these shouldn't be erroring like that...
<tsyesika>btw I notice the path is goblins 0.14, it's only 0.15 which works with hoot
<binarydigitz01>Oh yeah that's an interesting point
<binarydigitz01>Hmmmm now that I'm trying goblins 0.15, i'm getting a new error:
<binarydigitz01>checking if (web socket server) is available... no configure: error: required guile module not found: (web socket server)
<tsyesika>it sounds like it's missing the guile-websocket library
<binarydigitz01> do i need another library for web sockets?
<tsyesika>yeah
<binarydigitz01>oh I see thanks!
<tsyesika> https://dthompson.us/projects/guile-websocket.html
<tsyesika>^ this :)
<binarydigitz01>Yeah looks like this isn't packages for nixos yet, I have some work to do thanks :D
<tsyesika>no problem :) would be great to get that into nix
<tsyesika>for what it's worth those errors in 0.14 aren't known to us and it should have worked so I'm not convinced getting 0.15 will fix them, but I thought I should mention it
<tsyesika>not quite sure what's causing them to be honest...
<binarydigitz01>I'll definitely look into it more, should I open this as an issue on gitlab?
<tsyesika>yeah sure. I think guix has an equivalent of guix.scm file which includes the build instructions for a project right? It'd be good to attach that so we could try and reproduce it in the same environment and see if it's goblins or nix
<tsyesika>or other instructions so we can try it
<binarydigitz01>tsyesika: Yeah I'll open the issue with the relevant flake!
<tsyesika>awesome, thanks ^_^