IRC channel logs

2025-01-27.log

back to list of logs

<cow_2001>i am reading guile arrays bit. i wanna write a forest fire model https://en.wikipedia.org/wiki/Forest-fire_model for hoot
<cow_2001>the guile arrays bit
<cow_2001>,pp (make-array 0 10 10) is not very pretty :\
<cow_2001>well https://codeberg.org/kakafarm/kaka.farm/src/branch/master/kakafarm/dabbling/forest-fire.scm
<cow_2001>now, what do i do to make it go on screen?
<dthompson>cow_2001: I think I'm missing context. not exactly sure what you're asking
<dthompson>but you mentioned arrays. hoot doesn't support guile's arrays currently
<cow_2001>oops
<cow_2001>dthompson: what do you suggest in absence of guile arrays? i could just write pretend procedures over some other underlying data structure
<dthompson>just use vectors directly
<cwebber>so tsyesika figured out why the goblin-chat demo wasn't working for people on Chrome
<cwebber>it turns out we're using APIs which are widely available in Firefox but which you have to explicitly turn on in Chrome
<cwebber>for the encryption stuff for OCapN
<cwebber>and tsyesika had turned it on and forgotten about it
<cwebber>and so it got missed in terms of it not working on Chrome
<cwebber>tsyesika: could you repeat the instructions here on how to enable it?
<tsyesika>sure
<tsyesika>you need to go to about:flags and enable " Experimental Web Platform features". It'll prompt you to restart chromium which you need to do for it to work.
<dthompson> https://developer.mozilla.org/en-US/docs/Web/API/SubtleCrypto/generateKey#browser_compatibility
<dthompson>we use the Ed25519 algorithm
<jfred>oof, always fun - hopefully that makes it to stable releases soon
<dthompson>yeah same... I need to figure out how to track progress there
<jfred>on the bright side, y'all seem to be continuously working on the bleeding edge of what's possible in browsers :P
<dthompson>for better or worse 🙃
<jfred>yup, haha
<dthompson>I've got our crypto code detecting the failure to generate Ed25519 keys. now I need to bubble that up to the app so we can display a message.