IRC channel logs

2025-01-06.log

back to list of logs

<stdh>dthompson: those are useful tips, thank you! i'll have a look at the cirkoban code to see how it works 'in real life'
<stdh>for your first solution, that would look like something like:
<stdh>(define-actor (^side bcom side-args #:optional neighbours)
<stdh> ;; ...
<stdh> (methods
<stdh> ((accept-neighbours new-neighbours)
<stdh> (when neighbours (error "We already have neighbours!"))
<stdh> (bcom (^side bcom side-args new-neighbours)))
<stdh> ;; ...
<stdh> ))
<stdh>?
<clone>How do i tell if i still have a connection to a remote node?
<clone>i did end up getting it working with race and a timeout, but I found that calling <- on a far reference to an object on a node that is no longer connected stops the whole vat that the reference is in, so I had to use two vats on the local node. I put all of the references to objects from the remote node in one vat, then in the main vat for the local node I used those references with timeouts.
<dckc>after reading https://blog.cloudflare.com/workers-environment-live-object-bindings/ I was wondering what corresponds to live objects in the shell...
<dckc>file descriptors, I think...
<dckc>the shell is constantly turning strings into descriptors... or just passing strings to programs... like casting integers to pointers and back. it's all horrible...
<dckc>then I remembered efforts like plash ... and MarkM told me he had an E-based shell at some point...
<dckc>then I realized: a scheme REPL does The Right Thing
<dckc>likewise a browser console
<dckc>I've known that I want to move more of my work from shell / make to the browser console, but I haven't managed to really _live_ there...
<dckc>emacs is one of the places I call home
<dckc>and over the holiday break I did manage to set up a media PC running guix
<dckc>I'm really jazzed about the shepherd goblins thing. can't wait to start using it!
<dckc>^ IOU one blog article on this.
<dckc> https://social.coop/@spritely/113766309630854498 really resonates with me...
<dckc>> The analogy here can be seen with the emergence of powerful and wonderful frameworks like Django and Ruby on Rails at the beginning of the "Web 2.0" era. These frameworks not only provided the designs necessary to build "web 2.0" style applications, they taught users to *think* in them.
<dckc>> 2025 will be a big change for Spritely ...
<dckc>hear hear!
<dckc>here's hoping more of my https://www.madmode.com/2017/ocap-wish-list will come true :)
<dckc>I wished for "Object capability discipline for Docker" wish corresponds to the shepherd goblins stuff
<dckc>(sometimes I wish IRC supported editing)
<dckc>Congrats on the supporter drive, cwebber! It looks like lots of people are at the party :)
<dthompson>hey dckc :)
<dthompson>glad cwebber's spritely posts resonated with you!
<dthompson>we're hoping to have a little more to share about shepherd+goblins for fosdem at the very beginning of february
<dthompson>oh and glad you got your media pc setup!
<dthompson>I see a Pony mention on your old blog post. there was recently an article about it on lwn https://lwn.net/SubscriberLink/1001224/8bb517d5d0cdb5eb/
<cwebber>:)
<cwebber>dckc: 💜
<dckc>fosdem... never been... I think the genode folks go there too. well, I'll be there in spirit / async
<dthompson>this will be my first time
<dthompson>but the talks you can watch remotely
<dthompson>we should probably write a little blog post quickly that links to all the talks we got accepted because we have quite a few!
<jfred>I wish I could make it to fosdem, I thought about making last-minute travel plans, but it's the weekend after magfest and so I think that's too much travel for two weeks haha
<jfred>I'll be doing my usual tradition of waking up super early to catch the streams live though :)
<jfred>dckc: And that cloudflare workers post is one of my favorites. I've been writing up a blog post with some thoughts on managing multiple servers with service bindings via Goblins, need to finish that up soon
<cwebber>drewjose: goblins on Common Lisp would be really cool!
<Zarutian_iPad>what cloudflare workers post? link?
<cwebber> https://blog.cloudflare.com/workers-environment-live-object-bindings probably
<jfred>yep, that's the one
<Zarutian_iPad>thx
<dthompson>clone: what you want is something called on-sever. I was going to send you a link but unfortunately we forgot to document it. something we'll fix before our release later this month.
<dthompson>the best reference I have at the moment is our test suite https://gitlab.com/spritely/guile-goblins/-/blob/main/tests/ocapn/test-captp.scm#L268
<clone>Thanks, I'll check that out