IRC channel logs

2024-12-12.log

back to list of logs

<jfred>Oof that was the worst I've ever seen Jitsi misbehave... and I think I discovered at least part of what was happening. After my audio broke I tried to join from the mobile app, and immediately after I did I could hear cwebber briefly and then heard that you'd been muted. (So some of the later instances were probably a result of me trying to join - sorry!)
<cwebber>jfred: not your fault
<cwebber>jitsi for some reason just struggles past a certain number of users
<cwebber>regardless, it was nice that people seemed excited about the presentation :)
<jfred>yeah :D
<jfred>and I'm looking forward to hearing the rest of the Q&A that I missed in the recording
<jfred>the question I wanted to bring up (though my audio broke when I attempted to unmute) was around the possibility of applying Oaken to Guix package modules for extra safety
<jfred>of course I know Oaken still needs to be written ^^;
<dthompson>it would be great to eval guix channels in a restricted environment
<jfred>I'm curious how much guix would need to change to support that, if there was a sufficiently complete restricted environment to run in. My recollection is that package definitions themselves are mostly scheme records and probably most of the heavy lifting happens within the guix daemon, but I know `local-file` is used for e.g. patches so I guess you'd need a safe implementation of that
<dthompson>once it's in the daemon things should already be taken care of. the real risk, imo, is the client side code that defines the package recipes being able to do whatever as your user
<dthompson>the code that gets run in the build daemon is contained nicely already
<jfred>yeah
<dthompson>but yeah you wouldn't want a local-file record to be able to refer to just any old file
<dthompson>the code for the channel should have capabilities to access the files in the channel but nothing more
<dthompson>so safari 18.2 is out, with wasm gc and tail call support. however, cirkoban almost immediately crashes on safari with a type cast exception.
<dthompson>so I rebuilt cirkoban to see if a fresh binary had the same problem. that new binary doesn't pass validation on safari!
<dthompson>I'm leaning towards webkit being borked but I don't know for sure
<dpk>oooh
<dpk>ACTION secretly hopes it’s not a WebKit bug because she wants to play with it :D
<dthompson>to debug further, I went to inspect the binary by using our binary parser on it... and segfaulted guile!
<dpk>D:
<dthompson>just fixed that, so now I can parse the binary
<dthompson>but it's really just one problem after another here
<dpk>:D
<dthompson>jessica got some of our simpler demos working on ios
<dthompson>but it's a bummer that our shiniest demo is broken.
<dpk>ACTION upgrade her Safari and Mac OS
<dpk>(i am once again asking Apple not to break Magit with a minor Mac OS point upgrade)
<dthompson>🙃
<jfred>segfaults always make me leery, that's usually a result of an out-of-bounds memory read or similar right?
<cwebber>dthompson fixed it!!!
<cwebber>Oh wait
<cwebber>Fixed the parser heh
<cwebber> https://gitlab.com/spritely/guile-hoot/-/merge_requests/302
<dthompson>yeah, parser is fixed. will be a bit easier to debug random binaries now. still no idea what the webkit issues are.
<dpk>ACTION returns from the operating system upgrade
<dpk>well, the REPL demo on https://spritely.institute/hoot/ still tells me i need GC and tail calls support
<dpk>weirdly, the demo at the bottom of https://spritely.institute/news/scheme-wireworld-in-browser.html does work
<dpk>so it’s having trouble with something specific which the REPL and Cirkoban use but Wireworld doesn’t 🧐
<dpk>the todo list works too
<dpk>where do i go to play Cirkoban again
<dpk>uh, okay
<dpk>so Cirkoban works very briefly for me and then stops working
<dpk>after i press like three arrow keys it freezes and the arrow keys start scrolling the web page again
<dpk>and yeah, then the full screen button just makes it go blank
<dpk>ah, i see the error in the console
<dpk>hmm
<dpk>[Error]
<dpk>;; === Caught error: ===
<dpk>;; message: #<<message> from-vat: #f to: #<<local-object-refr> debug-name: procedure-name-unimplemented vat-connector: #f> resolve-me: #f args: ()>
<dpk>;; exception: 1. #<&assertion>
<dpk> 2. #<&message message: "value failed to match">
<dpk> 3. #<&irritants irritants: (#<<local-object-refr> debug-name: procedure-name-unimplemented vat-connector: #f>)>
<dpk> write_stderr (reflect.js:663)
<dpk> <?>.wasm-function[9396]
<dpk> <?>.wasm-function[122]
<dpk> <?>.wasm-function[51]
<dpk> <?>.wasm-function[52]
<dpk> 52
<dpk> call (reflect.js:301)
<dpk>[Error] RuntimeError: ref.cast failed to cast reference to target heap type (evaluating 'api.call(func, argv)')
<dpk> <?>.wasm-function[6852] (reflect.js:301)
<dpk> <?>.wasm-function[51]
<dpk> <?>.wasm-function[52]
<dpk> 52
<dpk> call (reflect.js:301)
<dpk>[Error] RuntimeError: ref.cast failed to cast reference to target heap type (evaluating 'api.call(func, argv)')
<dpk> <?>.wasm-function[7750] (reflect.js:301)
<dpk> <?>.wasm-function[51]
<dpk> <?>.wasm-function[52]
<dpk> 52
<dpk> call (reflect.js:301)
<dpk>uh, okay, that was more error than i expected, sorry
<dpk>there’s no error on the REPL and i don’t understand why it doesn’t start
<KraftTea>Hullo... I'm KraftTea@mastodon.social ... read your bit on contextual communication (the comments you made re: a bsky thread), and I thought your ideas were kinda interesting. (My background is basically being 2nd in command at LiveJournal, back when it was open source, volunteer run, and more egalitarian.)
<KraftTea>Things have changed a bit on the internet since then, haven't they?! (Sorry for the disaster(s).)
<KraftTea>I assume you're probably fairly busy, but if you have a bit of time to chat at some point about various things, please let me know. I can either hop on here, if contacted ahead of time, or can be reached on signal at Ciren.01