IRC channel logs

2024-10-08.log

back to list of logs

<mala>Interesting side-discussion after I posted Jonathan Rees' OOP post a while back on Lobsters: https://lobste.rs/s/zna0ob/jonathan_rees_on_what_is_object_oriented#c_dmyezg
<cwebber>mala: love references to the old E mailing list
<cwebber>which was full of gems
<cwebber>only possible to read through the wayback machine anymore, alas
<jfred>Goblins's design feels similar, and I guess that's not a coincidence :)
<jfred>I started poking at the persistence stuff last night, and it's very slick - though I have a feeling I'm going to need to refactor a few things to get Horton persisting ^^;
<jfred>I used a few tricks in there like this that I bet will gum up the works: https://gitlab.com/jfrederickson/guile-horton/-/blob/master/horton.scm?ref_type=heads#L230
<jfred>Also when I saw that genenetwork post yesterday I sent it to Melissa to see if she could make heads or tails of it. She knows what it does, I have no idea XD
<dckc>I forget: how do I add the current working directory to my load path so that (load "alice.scm") will Just Work? I'm in a repl, in guieser, in emacs
<dckc>dthompson, I guess what I need to do is change directory
<dckc>ah... found my notes... (add-to-load-path (getcwd))
<dthompson>guile's load path is consulted for loading modules, like with (use-modules ...) but is *not* used for 'load' afaik
<dthompson>since 'load' is more primitive
<dckc>right... I was kinda wrapped around the axel
<dckc>i needed to (chdir) to get (load "alice.scm") to work,
<dckc>but then alice.scm did (use-modules (endo)) so I had to (add-to-load-path (getcwd)) to get that to work
<dckc>for context: https://github.com/Agoric/agoric-sdk/pull/8184 and https://github.com/Agoric/agoric-sdk/blob/dc-escrow-formal/packages/zoe/spec/alice.scm
<dckc>today I realized that alice.scm isn't working due to a regression.
<dckc> https://github.com/Agoric/agoric-sdk/blob/dc-escrow-formal/packages/zoe/spec/amount-properties.scm is the currently working bit
<dckc>I should probably start a new project / repository
<dckc>but... hm... the target _is_ a reimplementation of zoe escrow, so maybe not