IRC channel logs

2024-10-04.log

back to list of logs

<randy__>That parser problem really bugged me. Thanks for finally dealing with it!
<jummit>I was looking at the libp2p netlayer, and was wondering if it would be feasible to add support for the Rendezvous routing protocol. I like the idea of not having to share addresses to connect to new peers.
<dthompson>jummit: hi! do you have a link for that?
<jummit> https://docs.libp2p.io/concepts/discovery-routing/rendezvous/
<dthompson>oh, it's part of libp2p. I'm unsure what else needs to be done here since we use their Go library that should do all of the things, presumably
<jummit>yeah, the daemon would need to expose the functionality probably
<jummit>just something I'd be interested in if I ever build something with goblins
<dthompson>iirc we ask libp2p to use whatever protocols it can
<jummit>is there any mechanism for registering and looking up peers by a namespace in goblins? I think I only saw addresses being used.
<dthompson>we use whatever addresses libp2p gives back to us
<dthompson>we ask libp2p to get us on the network and pass along all the info it generates
<jummit>right
<dthompson>I haven't done this work so idk why it wouldn't try using the rendezvous thing
<jummit>well, I should probably do some tests to see if it maybe works already
<jummit>:D
<dthompson>I know we've been puzzled at times about why libp2p is doing what it's doing. maybe there's a config problem. idk
<jummit>I guess what I want is a way to register sturdyrefs on the network under a namespace to allow other peers to find them, which is kind of what Rendezvous tries to solve.
<dthompson>are you talking specifically about libp2p or goblins in general? if the latter then you'll want to use the relay netlayer (currently called the "pre"lay netlayer as it's a WIP with important things missing)
<jummit>oh, that's what the prelay netlayer is for? then maybe I'll take a look when it's more fleshed out
<cwebber>Hello jummit! Cool to see you exploring this space
<jummit>o/
<cwebber>I do think the Rendezvous stuff, maybe maybe, is their relay mechanism
<cwebber>And yeah Prelay is the pre-e2ee design of that
<cwebber>The core ideas are there but it still needs end to end encryption
<jummit>a sketch of what I'd like to do would be: (register object 'my-app) on peer A and (define refs (lookup 'my-app)) on peer B.
<cwebber>jummit: I see, you're looking for human readable names?
<jummit>yeah, and a registry which collects a list of objects
<jummit>for example, in the case of file sharing all peers would publish their file objects under a common namespace
<jummit>(probably a bad idea, but it's an example)
<cwebber>jummit: I'd love it if you would read these https://spritely.institute/news/two-petnames-papers-are-released.html
<cwebber>In particular the naming hubs / edge names parts might be relevant to that you're saying, but petname systems in general will probably be interesting to you
<jummit>Thanks, I'll take a look!
<cwebber>:)