IRC channel logs

2024-08-07.log

back to list of logs

<dckc>ACTION resumes work on property testing for ERTP, Zoe
<dckc>anybody else aboot?
<dckc>writing this much code without static typing is quite unsettling
<dckc>does guile have anything like racket contracts?
<dckc>ACTION goes to #guile to ask
<dckc>I'm pretty used to the endo pattern stuff; I might port some of that.
<dckc>ACL2 stuff: https://www.cs.utexas.edu/~moore/acl2/v8-5/combined-manual/index.html?topic=ACL2____TYPE-PRESCRIPTION , b* https://www.cs.utexas.edu/~moore/acl2/v8-5/combined-manual/?topic=ACL2____B_A2
<dckc>ACL2 "tau" system has a nifty idiom:
<dckc>(implies (and (p1 x1) (p2 x2) ...)
<dckc> (q (fn x1 x2 ...)))
<dckc>pretty analogous to endo's M.call(p1, p2).returns(q)
<dckc>hm. that won't cause guile to throw handy exceptions when (p1 x1) is false
<dckc>to port endo's passStyleOf, I need a promise recognizer. I don't see a promise? thingy. is it feasible to make one?
<dckc>ah. promise-ref?
<weary-traveler>i'm trying to understand how to use it to set up two processes on the same machine that communicate over stdin and stdout. the tutorials here seem to only cover the case where the vats are running in the same process: https://spritely.institute/files/docs/guile-goblins/0.13.0/Tutorial.html
<weary-traveler>is there an example where the vats are in separate nodes, i.e., distinct processes?