IRC channel logs

2024-07-21.log

back to list of logs

<dckc>ok... so... where was that promise combinator library stuff? let's see...
<dpk>hi dckc!
<dckc>(display 1) in the REPL doesn't seem to add a newline. boring. what's the right widget to get a newline?
<dpk>(newline)
<dckc>hi dpk... have we met? I'm struggling to recall
<dpk>Swhack :-)
<dckc>`(newline 1)` went kerflewey. I want an x such that (x "a" 2) prints a and 2 and makes a newline. I want JS console.log
<dpk>(display 1) (newline)
<dckc>IOW: build your own. boring. oh well.
<dpk>uhh, that isn’t a standard thing but if you’re in Guile i think there is a thing for it
<dckc>I'm in guile
<dpk>ACTION reads the docs
<dckc>console.log also isn't part of the JS std lib, but it's ubiquitous.
<dckc>did you go by dpk in swhack venues?
<dckc>also, (define-values decisionP decide (spawn-promise-values)) is evidently not right. How do I find the right incantation? web searches are not helping
<dpk>right, i think i was thinking of https://www.gnu.org/software/guile/manual/html_node/Formatted-Output.html which maybe it’s great either (it’s like fprintf)
<dckc>where are docs on spawn-promise-values? I saw them a while ago
<dpk>assuming decisionP and decide are the names you want to bind, they need to be in parentheses: (define-values (decisionP decide) (spawn-promise-values))
<dckc>ok, thanks for the fish. now... how do I fish?
<dpk>(reason for this: you can use e.g. (define-values x (values 1 2 3)) to convert multiple values into a list, or even (define (x . y) (values 1 2 3)) to convert rest values)
<dckc>when the REPL spits out umpteen lines that amount to "BZZT", is there a geiser thing to navigate to where-did-I-screw-up?
<dckc>it's ctrl-click on escrow2013.scm:45:22 in vs-code
<dckc>oooh!!! I have made fire!
<dckc>;;; compiled /home/connolly/.cache/guile/ccache/3.0-LE-8-4.6/home/connolly/projects/agoric-sdk/packages/zoe/spec/escrow2013.scm.go
<dckc>so I want to save my work, but this emacs doesn't have magit. How do I add magit to a running emacs in the guix way?
<dckc>ACTION asks in #guix
<dpk>dckc: according to log grep, we met briefly in Swhack in 2013 and not since, heh