IRC channel logs

2024-06-01.log

back to list of logs

<cwebber>dckc: juli- has been continuing research on figuring out how all the pieces work and fit together. Still early stages but actively worked on :)
<MiPMrnP>Hello all! I was wondering how people do development workflow with https://gitlab.com/spritely/guile-hoot-game-jam-template ?
<MiPMrnP>Sorry to be asking again, I am not sure if people see it if they join after the message was posted.
<MiPMrnP>Hello all! I was wondering how people do development workflow with https://gitlab.com/spritely/guile-hoot-game-jam-template
<cwebber>Hi MiPMrnP
<MiPMrnP>Heyho cwebber
<cwebber>The right person to talk to is dthompson when he's around and available but in general there are two things
<cwebber>In the broadest sense, much of browser-oriented Hoot dev tends to be a classic edit-compile-run cycle; see "make serve". not the most ideal for a lisp but if you want to print graphics etc you probably need to do that
<cwebber>But let's say you wanted to write a general algorithm like A* pathfinding
<cwebber>Writing it at the general REPL, since it doesn't interface with browser APIs, should work. Thus many of us use emacs + geiser though strictly speaking that's not a requirement
<cwebber>Then you can simply include that in your program.
<cwebber>For debugging, "pk" is your friend
<cwebber>You might consider watching some of daviwil's live streaming of the lisp game jam with Hoot
<cwebber>It's under the "system crafters" channel
<cwebber>If you want more detailed answers, maybe ask on community.spritely.institute
<MiPMrnP>Yes so usually I use emacs + geiser (I have never programmed much in scheme but sometimes do some SICP exercises, or e.g. follow your primer). Great idea watching the live stream. I just got the demo running and was like oh hm I don't want to restart the server everytime I make a change so I am sure there is a better way.
<cwebber>MiPMrnP: in the glorious future there will be Chickadee on Hoot
<cwebber>And then the same games will work on the desktop and browser
<cwebber>It's a ways away tho!
<dthompson>MiPMrnP: I keep `make serve` running the whole time. and then I run `make` somewhere else to rebuild when I make changes.
<dthompson>I've been using `M-x shell` in emacs to open a shell to run the server, and then `M-x compile` to do builds
<dthompson>and cwebber is right that if there's no code that is just "plain scheme" you can develop it live at the guile repl and then port it over to your hoot program once it works.
<dthompson>if there's some code* rather, oops
<MiPMrnP>cwebber Ah at least the future is not totally dark. A glimmer of hope.
<dthompson>we hope to provide some form of live hacking in the browser eventually.
<dthompson>it's tricky, though!
<MiPMrnP>dthompson Great that the server will keep running while running make. I think that is more than good enough for me now. I was thinking about porting the realm of racket snake game as a way to learn more guile etc.
<dthompson>we hope you have fun :)
<Zarutian_iPad>ACTION knows now why Randy left Spritely and it fits his suspictions.
<Zarutian_iPad>I suspected that Randy is an catalyst that helps start things, such as Spritely
<Zarutian_iPad>and then when he deems it is started he moves on to the next thing
<MiPMrnP>Another small thing, how can we have a guix enviroment in geiser? Do you start emacs from the command line after doing guix shell?
<jfred>hrmmm... I skipped tests on the goblins build to get past that issue I was running into before, but now: https://paste.sr.ht/~jfred/513f23af82d1a1a70cbf748c91c11679ede25ab7
<jfred>MiPMrnP: I usually use direnv with the emacs direnv package; if I then have an .envrc that drops me into a guix shell, that'll take effect within emacs too
<jfred>got that from one of dthompson's blog posts a while back: https://dthompson.us/posts/guix-for-development.html
<cwebber>MiPMrnP: well there are a few paths. The easiest one to explain is "guile --listen" from within the guix environment (maybe "./pre-inst-env guile --listen") and then M-x connect-to-guile
<jfred>aha, something on my debian system was preventing the configure script from locating guile/guild from the `guix shell` profile. `guix shell --pure` seems to have done the trick
<jfred>hmm, at least to get past `make` anyway. tracking this one down: https://paste.sr.ht/~jfred/944b261a9af7471f9102d8c8941bcf44a626ffce
<dckc>good to hear it, cwebber . go juli- go!