IRC channel logs

2023-01-20.log

back to list of logs

<jfred>Wow, the community-garden source is even more interesting than I realized (in that it makes heavy use of GOOPS as well as Goblins objects)
<jfred>I think this is actually going to be very helpful, since the thing I'm trying to integrate with (OpenCV via AIscm) is also built around GOOPS
<dthompson>jfred: hey, glad you find it interesting! I'm hoping to clean it up a lot after goblins 0.10 is out.
<dthompson>goblins 0.10 will allow for cleaner integration with foreign event loops (such as this game engine)
<jfred>Oh very cool! Yeah, I think AIscm also has an event loop that I'll need to integrate with... at least I assume that's what's going on, there's a (show) method that just takes a procedure so under the hood I assume it's starting an event loop for that
<jfred>Will that integration require changes to the foreign event loop at all or is it agnostic to that?
<Zarutian_iPad>depends. Is it possible to do dali clock in it?
<Zarutian_iPad>what is a dali clock you ask?
<dthompson>jfred: our hope is that it will be agnostic to that.
<dthompson>goblins comes with a fibers-based vat. I have written a "chickadee vat" that hooks into the game library that the community garden demo uses. tsyesika is poking at a GTK vat and I'm excited to see where that goes.
<Zarutian_iPad>basically js`const daliclocktick = () => Promise.resolve(42).then((_) => { doOneActorEvent(); daliclocktick(); }`
<dthompson>I've tried to implement vats in a generic way, leaving a few holes to fill in for integration into the desired async event system.
<dthompson>hoping to have this merged next week and in the 0.10 release
<jfred>\o/