IRC channel logs

2023-09-18.log

back to list of logs

<kriskowal>hey, based on improved understanding of javascript symbols, syrup records, i’m looking at taking my js impl farther
<kriskowal>syrup docs say that dict keys can be anything https://github.com/ocapn/syrup
<kriskowal>to make that work, js would have to model them as a Map and uniqueness of keys doesn’t correspond to uniqueness of bytes.
<kriskowal>i’m inclined to continue using objects and limit keys to strings. that’s consistent with the syrup subset we might use for ocapn, i think.
<kriskowal>allowing symbols as dict keys would preclude round-tripping user records since we distinguish js objects from tagged stuff by a registered symbol key.
<kriskowal>the docs also do not seem to reflect the change from representing bigints 1 as 1+ instead of i1e
<kriskowal>and i’ll note that our syrup impl hasn’t had null or undefined bottom types since the initial experiment. records will do.