IRC channel logs

2023-06-15.log

back to list of logs

<KrisKowal[m]>Noise protocol has been recommended now by basically everyone I’m in touch with. Thanks @zenhack.
<KrisKowal[m]>And Brian Warner verified that we can use Noise protocol on top of arbitrary message framing. That’s important to us since we’ll be obliged to run O’Cap’n over a pretty wide variety of message framing protocols. We use netstring for a bunch of stuff at Agoric, which exists on the same spiritual plane as Syrup. We will use little-endian-32-bit-length-prefixed messages for Chrome’s Message Hosts. We’ll be obliged to use
<KrisKowal[m]>MessagePort and WebSocket on the web. All of these routes will need to be expressible in the connection hints for 3PH, like IPFS addresses.
<KrisKowal[m]>But the reason I pop this window open is to post a gedankenexperiment: For cross-language protocols like the 3PH Bootstrap object, can we use dromedaryCase or normalize case on the wire? I do love that you can use hyphens in Scheme, and we technically can make it work in JavaScript, but that’s not going to stretch far.
<KrisKowal[m]>In JavaScript, sending a gift would look like E(remote)['deposit-gift']() today, as opposed to merely E(remote).depositGift() or 🤞 maybe someday just remote~.depositGift().
<Zarutian_iPad>ACTION has never seen dromedaryCase  before but gets it instantly
<KrisKowal[m]>There was a short-lived proposal for dromedaryCase and BactrianCase in the Perl community a very long time ago, by the fellow who wrote most of the perldocs. I enjoy bringing it back to life at every opportunity.
<Zarutian_iPad>dromedary is one of the cat-footed animals, yes?
<Zarutian_iPad>ACTION awaits the groan ;-þ
<isd>dromedaryCase is also consistent with what the capnp conventions are. I also like hyphens in the abstract, but the overwhelming majority of languages don't support them, and I've found that it's hard to understate the value in mapping well to commonly available features...