IRC channel logs

2023-03-28.log

back to list of logs

<ICRainbow>I want to implement OCapN (CapTP?) in a new language (Haskell, btw). Where to start?
<ocdtrekkie>Cap'n Proto has a Haskell implementation, I believe, which may be useful or interesting.
<ocdtrekkie>But OCapN has not settled on a specific protocol to implement at this stage.
<isd>ICRainbow: right, you'd be implementing something that will likely be quickly out of date, and really the only "docs" for what is in use now is the spritely source code.
<ICRainbow>I know. Doesn't matter, I can track a moving goal.
<isd>ICRainbow: https://github.com/zenhack/haskell-preserves will be useful for the current serialization layer. Other than that I think reading the goblins source code is going to be the most authoritative thing. Reading docs on erights.org and capnp's rpc.capnp might be helpful with concepts, and haskell-capnp might be useful for ideas wrt. implementation.
<ICRainbow>So, the wire format is preserves/syrup (i.e. not capnproto-rpc or something) and to find out what messages to send I should consult spritely (goblins?). Right?
<isd>For now, yeah
<Zarutian_iPad> https://github.com/ocapn/ocapn/issues/7
<Zarutian_iPad>that should get you started ICRainbow
<Zarutian_iPad>at least which messages are sent on the wire
<ICRainbow>thanks!