IRC channel logs

2025-05-12.log

back to list of logs

<ZhaoM>damo22: I'm wondering maybe the successful boot from Linux with SATA controller correctly configured indicates that the BIOS has no issue
<ZhaoM>azert: that AHCI detection is done in rumpkernel so maybe I should try with RUMP_VERBOSE https://man.netbsd.org/rumpkernel.7
<ZhaoM>I only know how to set environment variable in SHELL, maybe I can do it in GRUB
<ZhaoM>If someone else having T60 giving it a try to use rumpdisk to boot may be helpful
<azert>ZhaoM: RUMP_VERBOSE is probably already on, my suggestion was to enable AHCI specific verbosity
<azert>see https://mail-index.netbsd.org/current-users/2009/08/16/msg010347.html
<ZhaoM>azert: OK
<p4r4D0xum>i was thinking about smbus, any idea how to implement it?
<gnucode>what's smbus ?
<yelninei>When building bison with disabled weak symbols (gl_cv_have_weak=no) it fails to link with undefined references to pthread_key_create, pthread_getspecific and pthread_setspecific.
<yelninei>i think this is the reason for my segfaults but I dont know who to contact about this
<youpi>it's probably merely missing -lpthread?
<youpi>since now that glibc doesn't require it, people seem to have completely forgotten that it's usually required on unices
<yelninei>thanks, adding LDFLAGS=-lpthread fixes everything. Not sure why this is not needed on linux and why this was not an issue before glibc 2.41
<youpi>because people make various assumptions
<youpi>the symbols were moved from libpthread to libc
<youpi>(on linux)
<youpi>on hurd, we have started the move, but it's not finished
<youpi>so if an application tests for e.g. pthread_once being available without -lpthread, but then use pthread_key_create without checking that it's also available without -lpthread, that'll just fail
<youpi>and about weak symbols, normally the application would actually *check* at runtime whether the symbol is available or not, but some piece of code probably don't do it properly because nobody actually really exercice such code
<yelninei>i guess it is hard to have a configure script that deals with every combination of os and library versions and keep it up to date
<youpi>you don't need to look for combinations of os/library versions
<youpi>you just need to probe what you need
<youpi>if you want threads, you can check for pthread_create, and the rest should be available
<youpi>if you want to be thread-safe, just check for the pthread_* that you actually use
<yelninei>Thank you very much
<mandrillone>Regarding the synthetics, I think you rarely sort strings, most of the time you compare one string against others. In that case it might be cheaper to normalize at the grapheme level on the fly during the comparison
<mandrillone>In any case, most of the time you don’t need to do almost any normalization