IRC channel logs

2025-04-29.log

back to list of logs

<f0lkert> https://git.savannah.gnu.org/cgit/hurd/ is listed as the hurd-repo at wikipedia. but it gives a 502 bad gateway error.
<youpi>it works for me
<f0lkert>it works and then it doesn't. very slow also.
<f0lkert>anyway I saw in the debian based installer that HURD does iSCSI? I'd like to take a look at the code of that. in which repo can I find it?
<azert>f0lkert: I really doubt that there is any iSCSI driver working, never heard of anyone using that on the Hurd
<azert>but it is one of the thing you should totally be able to implement as an user level driver
<azert>there are performances issues to be taken in consideration, it would be an interesting experiment
<f0lkert>yes, what I'm looking for is example code for writing a userlevel block device. I know iSCSI a bit (wrote a target) but anything should do.
<azert>rumpdisk is probably a good example.
<f0lkert>where can I find that code? which repo?
<ZhaoM>f0lkert: https://git.savannah.gnu.org/cgit/hurd/hurd.git/
<f0lkert>ok thanks
<ZhaoM>f0lkert: the search bar on this link is useful for searching https://darnassus.sceen.net/~hurd-web/
<f0lkert>oof, this is more involved than expected :-) so sorry for dumb questions in advance. as a test I'm trying to instantiate nbd: sudo settrans /dev/nb0 /hurd/storeio -Tnbd 192.168.122.1:10809 this complains that /dev/nbd0 doesn't exist?! but this line is to make it?
<ZhaoM>f0lkert: see settrans --help
<ZhaoM>there is an option -c
<ZhaoM>for creating the node when the node doesn't exist
<damo22>im not sure if that is correct
<f0lkert>thank you, works
<f0lkert>no :-)
<damo22>what is nbd?
<f0lkert>network block device
<f0lkert>a simple way of exporting storage over the network
<damo22>ok never tried it
<f0lkert>loooking at the nbd-driver: after it opens a connection, it closes the socket? otoh it keeps some kind of mach port.
<youpi>oh, I didn't rember we had nbd support in libstoreio
<youpi>we could implement iscsi the same way
<youpi>a quick nbd tutorial could be interesting to show that you can set this as non-root in the Hurd
<p4r4D0xum>I've just copied amd64 image to a harddrive via dd
<p4r4D0xum>ls
<p4r4D0xum>sorry
<p4r4D0xum>and I get grub rescue
<p4r4D0xum>can't get the grub config
<p4r4D0xum>checked if the image is raw, it is
<youpi>first check if grub is able to see drives and partitions at all with ls
<p4r4D0xum>it does, but now I tried to mount it under linux, and something went wrong
<p4r4D0xum>so I will recopy it
<p4r4D0xum>think I know what I did wrong, I think I copied it on sdb2
<p4r4D0xum>works! but it hangs... :/
<p4r4D0xum>sneek later tell AlmuHS You mentioned something about grub noide flag? Could you elaborate?
<sneek>Will do.
<youpi>that makes the kernel not drive ide itself, and let rumpkernel do this
<youpi>depending on where exactly things hang it can or cannot help
<youpi>without showing us the actual output you are getting, we cannot say anything
<youpi>(as a reminder, divination is a hard thing to do)
<p4r4D0xum>youpi: I thought it hanged at Initializing Device ... Nested method call : SMI
<p4r4D0xum>ACPI but it runs through it after a while
<p4r4D0xum>and can't find wd0
<youpi>so rump didn't see your disk
<youpi>btw, the amd64 image doesn't have in-kernel drivers, so noide cannot help anyway
<p4r4D0xum>I will give i386 a go.
<youpi>did you set your box in ide mode?
<youpi>ahci support vary
<youpi>and raid mode even more
<p4r4D0xum>no, I used AHCI only
<youpi>that's the more important thing to do rather than randomly picking i386/amd64 (which have the same sets of drivers anyway)
<p4r4D0xum>youpi: but that's interesting, I have medion mt with e6400 and everything works out of the box
<p4r4D0xum>it hangs sometimes during update but it works, but it's IDE
<p4r4D0xum>interesting, I tried it on elitebook in ide and it goes further but has problem with irq
<youpi>p4r4D0xum: "everything works out of the box", what do you mean?
<youpi>with linux?
<youpi>hurd != linux
<youpi>or do you mean "on that other random box, the hurd works fine" ?
<youpi>if you pick up random hardware, you will have success randomly, sury
<youpi>we don't have resources to fix driver probing on all random hardwared
<p4r4D0xum>youpi: medion host works with hurd
<p4r4D0xum>the hurd works more or less fine
<youpi>then you can play with it
<p4r4D0xum>that's my intention, I have a lot of old pcs here, so I hope to learn where I'm at and maybe
<p4r4D0xum>contribute to list of hardware hurds works on
<p4r4D0xum>youpi: and how to do the noide in grub? Where should I put it?
<youpi>on the multiboot line
<youpi>along the root= option
<p4r4D0xum>youpi: "root=part:2:device:hd0 noide"
<p4r4D0xum>?
<youpi>yes
<p4r4D0xum>oh I have to change hd0 to wd0, right?
<youpi>yes
<p4r4D0xum>yes!
<p4r4D0xum>youpi: it boots, but root stays in read-only mode
<p4r4D0xum>wait, no it fsck fails
<p4r4D0xum>Going to fsck it
<p4r4D0xum>I checked wd0s2 under hurd, sda2 under linux - comes up clean but I'm stuck on the check and it doesn't se my swap. :/
<youpi>swap is configured in /etc/fstab
<p4r4D0xum>youpi: but is it necessery to boot hurd?
<p4r4D0xum>i think the issue here, not sure is that grub reads it xd0 and hurd as xd2, need to check it out
<youpi>swap is not needed as long as you have enough memory, sure
<p4r4D0xum>2 GB
<p4r4D0xum>its booting!
<p4r4D0xum>everything works in ide :D
<p4r4D0xum>so happy
<p4r4D0xum>holly cow, it works and is fast on 530M
<p4r4D0xum>s/holly/holy
<p4r4D0xum>s/cow/qcow :)
<p4r4D0xum>f0lkert: A question, are you that folkert from NL?
<p4r4D0xum>youpi: does hurd implement thermal shutdown?
<p4r4D0xum>it works in ahci mode as well, and Xorg works too!
<p4r4D0xum>What a beutiful day
<p4r4D0xum>it worked. :/ no the console hangs on sshd but it boots
<p4r4D0xum>had some problem with shutting down and wd0 time out
<youpi>p4r4D0xum: there is not thermal management
<f0lkert>p4r4D0xum: yes
<f0lkert>p4r4D0xum: why?
<p4r4D0xum>Fellow hackerspacer here
<f0lkert>ah!
<p4r4D0xum>;-)
<f0lkert>which one?
<p4r4D0xum>rev
<p4r4D0xum>good to have you here
<f0lkert>the one with the beautiful lasercutter
<f0lkert>thank you!
<p4r4D0xum>f0lkert: haha, never used it so I have to trust you on it
<f0lkert>yeah I'm planning to fix the nbd driver but I already managed to make my HURD system not boot
<f0lkert>wd0: invalid argument. strange because just before that it says it detected the wd0 qemu harddisk(-image).
<p4r4D0xum>i wish I could help, but Im just a baby here, for way too lon
<p4r4D0xum>g
<p4r4D0xum>just this morning I was able to boot it on my 3 real hardware. :)
<p4r4D0xum>and I suck at C
<f0lkert>is it your daily driver?
<p4r4D0xum>f0lkert: You mean my workstation? No, I use gentoo.
<f0lkert>right
<f0lkert>I use ubuntu, because I'm old
<p4r4D0xum>nobody is perfect /joke
<p4r4D0xum>and I'm using gentoo because I'm an masochist.
<p4r4D0xum>and I have also an ArchLinux for times when I don't want to cry all day. :D
<f0lkert>never used it
<f0lkert>hehe
<f0lkert>azert: I got that iSCSI when I did not have a harddisk detected
<f0lkert>it being the debian hurd installer
<p4r4D0xum>f0lkert: you mean sd0?
<f0lkert>wd0
<p4r4D0xum>if so I think it's because you need to add 'root:part:... noide
<p4r4D0xum>in your grub.cfg
<f0lkert>oh but it was booting before? only after I did a make install in from the HURD repo I got this problem??
<p4r4D0xum>youpi said that ahci is less predictable than ide
<p4r4D0xum>if you're in ahci mode and you do not do noide flag then at least on my hardware, you get sd0
<p4r4D0xum>and that noide flag works only on i386 image, but I assume you're using it.
<youpi>f0lkert: running make install from a hurd build is asking for trouble indeed
<youpi>it's like all these low-level layers, their installation details really vary among distributions
<youpi>so better install by hand the only bits you are actually working on
<youpi>(and making a copy of what you overwrite, to be able to restore it)
<f0lkert>youpi: right! that will be libstore.* then.
<azert>f0lkert: separating a generic libscsi from the libiscsi you are implementing might be an useful thing to do. I’m not saying you should do absolutely keep them separated, but it might be wise in the long term to have an Hurd scsi layer available for reuse!
<f0lkert>azert: no, I'm not implementin iSCSI, I'm trying to fix nbd.
<azert>f0lkert: nice
<f0lkert>ok so I built a libstore with debug-output (to syslog in case stdout goes to /dev/null). is this the proper way to start it so that it uses the adjuusted version?
<f0lkert>PATH=~folkert/hurd/utils:$PATH LD_LIBRARY_PATH=~folkert/hurd/libstore settrans -c /dev/nbd1 /hurd/storeio -Tnbd 192.168.122.1:10809/4096
<f0lkert>(because I see no output in /var/log/messages)
<azert>f0lkert: https://www.gnu.org/software/hurd/hurd/debugging/translator/gdb.html
<azert>you should try the /usr/bin/env method
<youpi>f0lkert: you want to pass -a to settrans
<youpi>so it immediately starts the translator
<youpi>(active translator)
<youpi>otherwise it will just record a passive translator, that will get auto-started
<youpi>and thus that auto-start will not inherit the environment variables