IRC channel logs

2025-04-21.log

back to list of logs

<damo22>ZhaoM: your problem is the RUMPLIBS etc
<damo22>in your makefile
<damo22>you are linking all the low level disk drivers
<damo22>so it will detect and probe your AHCI controller
<damo22>you probably need "rumpvfs rumpvfs_nofifofs rumpfs_ext2fs rumpuser rump"
<damo22>int main()
<damo22>{
<damo22> rump_init();
<damo22> rump_sys_reboot(0, NULL);
<damo22> return 0;
<damo22>}
<damo22>start with that and get it to link
<damo22>we may be missing some symbols
<ZhaoM>ok
<damo22>gcc -static -Wall -g -D_FILE_OFFSET_BITS=64 test-rump.c -o test-rump -Wl,--whole-archive -lrump -lrumpuser -lrumpvfs -lrumpvfs_nofifofs_pic -lrumpfs_msdos -Wl,--no-whole-archive -lpthread -ldl -lpciaccess
<damo22>even that is missing a symbol
<damo22>/usr/bin/ld: /usr/lib/gcc/i686-gnu/14/../../../librumpfs_msdos.a(msdosfs_vfsops.o): in function `rumpns_msdosfs_mountfs':
<damo22>(.text+0x87d): undefined reference to `rumpns_getdisksize'
<damo22>actually it does not need pciaccess either
<ZhaoM>I found that setting $RUMP_VERBOSE as 1 can give more useful information
<ZhaoM>BTW maybe rumpfs is not the best name, it has already has it own meaning https://man.netbsd.org/rumpfs.4
<ZhaoM>though I haven't came out with a better one
<youpi>janneke: I pushed a symlink fix