IRC channel logs

2025-04-19.log

back to list of logs

<ZhaoM>sneek later tell gnucode my T60 is running this command '/usr/bin/console --daemonize -d current_vcs -c /dev/vcs -d vga -d pc_kbd --model pc105 --layout us pc_kbd -d pc_mouse --protocol=ps/2 pc_mouse
<sneek>Got it.
<ZhaoM>sneek later tell gnucode when I try to run the command you sent it shows 'Device or resource busy'
<sneek>Got it.
<ZhaoM>ok I will start with porting puffs to hurd as a server first
<damo22>ZhaoM: as i said, you should start with a simple main() function that links the relevant librump_*.a files and attaches a filesystem from a partition dumped to a file
<damo22>you dont need to make it a hurd server right away
<damo22>start with just the basic rump calls
<damo22>for example, you can create a file containing a small ext2 fs
<damo22>and try to mount that via rump
<damo22>dont start with the boiler plate code for an entire server
<ZhaoM>ok
<damo22>ZhaoM: i found this example from the rumpkernel upstream https://paste.debian.net/plainh/06ed2a43
<damo22>it should be easy to adapt if you can understand what its doing
<damo22>rump_pub_etfs_register("/dev/fakeblk", "/path/to/hurd-partition", RUMP_ETFS_BLK);
<damo22>that assigns the hurd partition to a fake block device within the rump's internal /dev
<damo22>then you can call rump_sys_mount(RUMP_MOUNT_x, "/target", ...)
<damo22>that will mount the fake block device to a target location inside rump
<damo22>then all the rump_sys_{open,read,write,close} etc functions can be called on paths within /target
<ZhaoM>thanks :)
<youpi>gnu_srs, gnu_srs1: apparently ext2fs broke the group descriptor of mahler's root again, could you re-fsck it?