IRC channel logs

2025-04-05.log

back to list of logs

<almuhs>hi. I'm trying to compile this caesar translator https://paste.debian.net/1318833/ , but I have linker errors
<almuhs>I'm compiling with gcc -g caesar_trans.c -o caesar_trans -ltrivfs -lports
<almuhs>this is the error:
<almuhs>/usr/bin/ld: /tmp/ccn1nwJU.o: undefined reference to symbol '__assert_perror_fail_backtrace'
<almuhs>/usr/bin/ld: /lib/i386-gnu/libshouldbeinlibc.so.0.3: error adding symbols: DSO missing from command line
<almuhs>collect2: error: ld returned 1 exit status
<almuhs>ok, solved
<almuhs>gcc -g caesar_trans.c -o caesar_trans -ltrivfs -lports -lshouldbeinlibc
<damo22>almuhs: rot26, twice as strong as rot13
<almuhs>deployed with success: :)
<almuhs>pruebas@debian-hurd:~$ settrans -gac /tmp/c caesar_trans example_file
<almuhs>pruebas@debian-hurd:~$ cat /tmp/c
<almuhs>damo22: what is rot26?
<damo22>caesar cipher with offset 26
<almuhs>oh, ok
<almuhs>i'm trying a translator example written by Sergey some months ago
<almuhs>*testing
<Gooberpatrol66>i think rot26 wouldn't do anything
<almuhs>previously i tested this, but the libtrivfs headers has changed and doesn't compile https://www.gnu.org/software/hurd/hacking-guide/hhg.html#An-Example-using-trivfs
<damo22>thats the point, it was a joke
<Gooberpatrol66>yeah
<almuhs>I replaced this
<almuhs>kern_return_t trivfs_S_io_write (struct trivfs_protid *cred, mach_port_t reply, mach_msg_type_name_t replytype, data_t data, mach_msg_type_number_t datalen, loff_t offs, mach_msg_type_number_t *amout)
<almuhs>with
<almuhs>kern_return_t trivfs_S_io_write (struct trivfs_protid *cred, mach_port_t reply, mach_msg_type_name_t replytype, const char* data, mach_msg_type
<almuhs>But now returns nosense output
<damo22>almuhs: nonsense output is probably correct, its supposed to be a poor form of encryption
<almuhs>this latest example is not the caesar
<almuhs>this must print 111111....
<almuhs>in /dev/one
<damo22>sorry i dont understand
<almuhs>check this link https://www.gnu.org/software/hurd/hacking-guide/hhg.html#An-Example-using-trivfs
<almuhs>this include a translator example using libtrivfs
<almuhs>fixed it too: https://paste.debian.net/1367549/
<almuhs>now it prints 11111... correctly
<Pellescours>hi everyone, I think the condition needs to be updated for x86_64, am I correct ? https://git.savannah.gnu.org/cgit/hurd/gnumach.git/tree/i386/intel/read_fault.c
<Pellescours>according to the comment it is only required for i386, so 64 bit mode should also be excluded
<Pellescours>I think it should be updated to #if __i366__ && !(__i486__ ...)
<azeem>you didn't mention a line number
<Pellescours>ah yes, line 36
<youpi>oh sure, please send a patch
<youpi>and also a bit above the call in trap.c
<Pellescours>I won't be able to do it until tomorrow, so if someone want/have time, feel free. Otherwise I'll do it tomorrow :D
<hakanrw_>hello! is gnu mach currently able to do SMP on x86_64 at all, or is it limited to i386?
<AlmuHS>hakanrv_ : the SMP is limited to i386. Currently we're trying to fix some race conditions
<hakanrw_>AlmuHS: i see, thank you!