IRC channel logs

2025-04-02.log

back to list of logs

<damo22>rumpnet should be a drop in replacement for netdde
<damo22>you still need devnode and pfinet etc
<Pellescours>I did
<Pellescours>/dev/net point to my /dev/rumpnet
<Pellescours>and a translator to my built rumpnet is set on /dev/rumpnet
<Pellescours>I didn’t touched to pfinet
<damo22>so how are you starting pfinet
<damo22>-i /dev/net ?
<damo22>showtrans /servers/socket/2
<damo22>since /dev/eth0 is not exposed by rumpnet, you will need to change the invocation of pfinet to point to rumpnet's devnode driver
<damo22>eg settrans /dev/wm0 /hurd/devnode /dev/rumpnet wm0
<damo22>and settrans /servers/socket/2 /hurd/pfinet -i /dev/wm0
<damo22>brb
<Pellescours>Ah that’s the point, ok going to sleep but I’ll test it tommorrow, I’ll change the pfinet invocation
<ZhaoM>Wierd, I cannot see the source code of getauth in either glibc or hurd
<ZhaoM>I tried to use gdb to track the source but my gdb has some issues may need be to upgraded
<ZhaoM>but it seems the debian repo is updating and I cannot complete 'apt update' in this period :/
<Pellescours>the "makphy0: Failed to access EADR. Are you an emulator?" is normal or not?
<ZhaoM>and cannot find file_check_access() https://git.savannah.gnu.org/cgit/hurd/hurd.git/tree/libtrivfs/file-access.c#n30 in either hurd or glibc , did I miss something?
<azert>Pellescours: that message looks like something that netbsd would normally spew out on certain configurations, yes
<sneek>Welcome back azert, you have 1 message!
<sneek>azert, ZhaoM says: thanks for the documentation
<azert>This is an interface we should consider maybe for the Hurd? http://www.watson.org/~robert/freebsd/2007asiabsdcon/20070309-devsummit-zerocopybpf.pdf
<azert>I know that Mach is conceived to implement zero-copy through page-table manipulation, but the hardware is not made for that, that’s why people use circular buffers more and more
<azert>A part from caching considerations that most directly affect performances, in principle, a device can even dma in a shared circular buffer, it surely cannot alter the page table. In any case, memory needs to be moved in and out so I’m not so sure that avoiding copying is the “right” optimization
<azert>But I can guess that doing what everyone else is doing gets better optimized by the current processors
<p4r4D0xum>hello, I asked before some issue with a physical display and I forgot about to check for an aswer, my apologies.
<sneek>Welcome back p4r4D0xum, you have 1 message!
<sneek>p4r4D0xum, ZhaoM says: try to upgrade 'hurd' and 'gnumach' and report here if there's still out of range error
<p4r4D0xum>:D
<ZhaoM>sneek is a very useful bot
<ZhaoM>sneek: botsnack
<sneek>:)
<p4r4D0xum>ZhaoM: I did full upgrade, but I'm going to double check it.
<p4r4D0xum>A moment please.
<p4r4D0xum>ZhaoM: On the boot just now I got out of range, let me run apt upgrade
<p4r4D0xum>ZhaoM: Nope, gnu mach and gnu hurd are the newest.
<p4r4D0xum>Could this be do to the fact I have a graphics card on I think agp still and not integrated one?
<ZhaoM>you are running on a real machine?
<p4r4D0xum>I tried different displays on vga port
<p4r4D0xum>ZhaoM: Yes I do.
<ZhaoM>eh then it's a bit out of my skill :/
<ZhaoM>p4r4D0xum: paste the error here if it's not too long
<p4r4D0xum>It's not
<p4r4D0xum>"Out of range"
<p4r4D0xum>:D
<youpi>ZhaoM: (gdb) l * getauth
<youpi>0x45080 is in getauth (./hurd/hurdports.c:51).
<youpi>warning: 46 ./hurd/hurdports.c: Aucun fichier ou dossier de ce nom
<ZhaoM>youpi: thanks :)
<youpi>hurd/fs.defs:routine file_check_access (
<youpi>so it's an RPC
<youpi>implemented in S_file_check_access, typically
<youpi>(the server part)
<ZhaoM>youpi: but in this case https://git.savannah.gnu.org/cgit/hurd/hurd.git/tree/libtrivfs/file-access.c#n30, we have already been in a S_file_check_access
<youpi>yes, and it calls the RPC on the realnode behind it
<youpi>of the FS on which the translator was mounted
<ZhaoM>p4r4D0xum: so it's an error from the display instead of from hurd?
<ZhaoM>youpi: got it
<p4r4D0xum>ZhaoM: Yes.
<ZhaoM>no idea then :|
<p4r4D0xum>going to check if I can disable the "new" console and see if that works
<p4r4D0xum>it's a hail marry, but it's better than nothing
<p4r4D0xum>can't find the config file to disable it, anybody can tell me where is this defined?
<crupest>Is there any problem for `getsockname` on Hurd? It seems to return an empty string. And it breaks libuv. I find this mail and the demo code can still reproduce the bug.
<crupest> https://lists.gnu.org/archive/html/bug-hurd/2005-03/msg00217.html
<youpi>on PF_LOCAL sockets we don't have a sockname
<crupest>The code in that mail is old-style. I create a new one https://paste.debian.net/1367082/ . This can be built directly.
<crupest>Ah. I see freebsd does not, either. So I can make it work like freedsb.
<gnucode>this is kind of a fun read.
<gnucode> https://orib.dev/gefs.html
<gnucode>not that I understood much of it.
<gnucode>apparently it's plan9's newest filesystem. https://9front.org/releases/
<jack-sparrow>hello,
<jack-sparrow>hurd work as desktop now ? or no and why ?
<gnucode>jack-sparrow: yes, you can run a simple X window manager on the Hurd.
<gnucode>Xfce works as well.
<gnucode>I personally choose i3, because it's super light weight. and my T43 only has 1.5 GB.
<gnucode>The T60 is probably the best hardware to run the Hurd on at the moment.
<jack-sparrow>be back
<jack-sparrow>thank
<jack-sparrow>gnucode: dwm ?
<gnucode>jack-sparrow: that should work just fine. yeah.
<gnucode>the web browser situation is a bit complicated.
<gnucode>I compile netsurf.
<gnucode>Some other odd web browsers should work too, but you may have to compile them yourself.
<gnucode>Firefox used to work, but the port has not been updated in a long time.
<Pellescours>damo22: I think the rumpnet translator dies when it tries to initialize the interface, the last message I have from it (when starting it as active), is "makphy0: 10baseT, 10basT-FDS, ..." and before I have the "Are you an emulator?" messages
<Pellescours>and I don’t know how to debug this, it’s really hard with translator to have the printf method
<damo22>Pellescours: do you have wm0 in that log
<Pellescours>yes
<damo22>maybe your translators are not set up right
<Pellescours>before the makephy0 I have some logs with wm0
<damo22>rumpnet is probably working itself
<Pellescours>In that specific logs, it’s makephy0 that appear but before the makephy0 logs it’s wm0 logs
<damo22>what node are you using after /dev/rumpnet
<damo22>you have to use devnode on /dev/rumpnet wm0
<Pellescours>I do settrans -ac /dev/rumpnet ~/hurd/build/rumpnet/rumpnet
<damo22>see for example how /dev/eth0 is connected to the card
<Pellescours>and showtrans /dev/wm0 shows "/hurd/devnode /dev/rumpnet wm0"
<Pellescours>I used the settrans command you told me earlier
<Pellescours>to setup wm0
<damo22>i dont recall the exact syntax
<damo22>check /dev/eth0
<Pellescours>it have a -M more and it use /dev/net instead of /dev/rumpnet. I’ll try that
<damo22>/dev/net is probably pointing at netdde
<damo22>you dont want that part
<damo22>can you show me the showtrans /dev/eth0
<Pellescours>I changed the link to point to /dev/rumpnet
<Pellescours>showtrans /dev/eth0: "/hurd/devnode -M /dev/net eth0
<Pellescours>"
<damo22>ahh, yes you need settrans /dev/wm0 /hurd/devnode -M /dev/rumpnet wm0
<damo22>it basically demultiplexes the wm0 device out of rumpnet
<damo22>probably settrans -a
<Pellescours>I did it but the result is the same, after having run the settrans to start rumpnet, logs stop after that makephy0 log, and the "showtrans /dev/rumpnet" only shows "/hurd/chrdev 0 0"
<damo22>try rumpnet.static
<damo22>thats what ive been testing on
<Pellescours>same
<Pellescours>ah but my translator on /dev/wm0 died
<damo22>lspci -nn |grep net
<Pellescours>and when I resetup the translator on wm0 and I restart the translator on rumpnet, I get
<Pellescours>settrans /dev/rumpnet: Device or resource busy
<damo22>00:02.0 Ethernet controller [0200]: Intel Corporation 82574L Gigabit Network Connection [8086:10d3]
<damo22>do you have that
<Pellescours>yes
<damo22>ok
<Pellescours>ah no it’s not the same
<damo22>what is it
<Pellescours>it’s 00:03:0 Ethernet controller [0200]: Intel Corporation 82540EM Gigabit Ethernet Controller [8086:100e] (rev 03)
<Pellescours>It’s the default nic for qemu I think
<damo22>that should b efine
<damo22>is netdde stopped?
<Pellescours>yes
<damo22>you need to stop eth0 from autostarting
<Pellescours>did it
<damo22>ps -ef |grep -E 'pfinet|netdde|devnode|rumpnet'
<Pellescours>still the Device or resourc busy message
<Pellescours>oh but the process still live for rumpnet.static and wm0
<damo22>yeah might need to use -fga
<damo22>in settrans to kill the old ones
<damo22>and start active new ones
<Pellescours>starting rumpnet still dies and it kills translator on /dev/wm0
<damo22>hmm
<Pellescours>no that’s weird
<Pellescours>ps still report them
<Pellescours>but showtrans on node don’t
<damo22># settrans -fga /dev/rumpnet /bin/sh -c "exec >> /root/rumpnet.log 2>&1 && /path/to/rumpnet.static"
<damo22>that will give you translator with log
<damo22>what does the log say?
<Pellescours>log file was empty (I saw all the rump starting logs in the console)
<Pellescours>but doing a ifconfig put a ton of logs on the console
<damo22>oh thats probably because it uses mach_print
<Pellescours>about irq
<Pellescours>still 1 unacked irqs in entry xxxx
<Pellescours>release a dead delivery port xxx entry yyyy
<damo22>you must have a stray process
<damo22>you really need to use kill -9
<Pellescours>the showtrans on wm0 and rumpnet still shows no translators but the process are still running
<damo22>you can use -fgap
<damo22>that p will add a passive translator entry
<damo22>but if its dying, it might restart in a loop?
<Pellescours>I have 2 rumpnet running
<damo22>:|
<Pellescours>the one in the sh -c and another one (a child of the sh)
<damo22>you need to kill everything related to network stack
<damo22>then use -fgp
<damo22>so it wont start automatically
<Pellescours>done
<damo22>then do something like ifup /dev/wm0
<Pellescours>ifup: unknown interface