IRC channel logs

2025-03-24.log

back to list of logs

<damo22> what about #ifdef APIC to read hpet for fine tuning?
<damo22>i think we can decide if we expect a HPET at compile time
<damo22>thats what i was getting at in my mail
<damo22>if APIC is defined and there is no HPET, none of the clock interrupts will even work for APs
<damo22>and it will break on an assert anyway
<damo22>hmm we use PIT to calibrate LAPIC timer, and then the LAPIC timers are enabled on all APs, but i think we are still using PIT to make clock interrupts on BSP
<damo22>and the HPET is enabled just for high resolution timer scheduling
<damo22>?
<damo22>or for delays in kernel
<damo22>set_timeout does not use HPET
<damo22>so HPET is only being used in kernel for hpet_udelay etc
<damo22>hpet is still critical to smp timing
<damo22>so yes, we assume its present on smp systems
<ZhaoM>morning
<sneek>Welcome back ZhaoM, you have 2 messages!
<sneek>ZhaoM, youpi says: it's not really useful to look at tsc. Nowadays most machines to have an hpet, so we will be fine with just that
<sneek>ZhaoM, azert says: reading the hpet takes ~100x more cycles then reading the tsc (source: https://docs.redhat.com/en/documentation/red_hat_enterprise_linux_for_real_time/7/html/reference_guide/chap-timestamping#Reading_hardware_clock_sources ). That’s why I mentioned the tsc. That said youpi is always right and possibly it’s a premature
<ZhaoM>sneek later tell azert thanks for the documentation
<sneek>Okay.
<ZhaoM>ok a small conclusion
<ZhaoM>tsc is indeed more efficient than hpet but I think hpet is still needed as an option since it seems some CPU may not have a TSC https://wiki.osdev.org/TSC#:~:text=Portability
<ZhaoM>I may give TSC a try if I'm motivated in the future
<ZhaoM>damo22: if the detection of HPET can be done automatically without any overhead with the help of the branch predictor, that will be very nice
<ZhaoM>I will do a simple benchmark just like the url shared by azert to see if that `if` affects the performance
<damo22>ZhaoM: my point was we may not need to do a runtime check at all, if we assume every APIC machine has HPET
<damo22>and just short circuit the code in the non-APIC case
<damo22>at compile time
<ZhaoM>about `APIC machine has HPET`, is it always the case? I just found this https://wiki.osdev.org/HPET#Detecting_HPET_using_ACPI
<ZhaoM>and yes we indeed init_hpet when APIC is available
<ZhaoM>but I think if runtime check is more flexible and does not cause significant overhead we can give it a go :)
<ZhaoM>conclusion ned
<ZhaoM>s/ned/end/
<damo22>ZhaoM: osdev has some useful info, but in practice every machine with acpi tables since 2005 has a HPET
<damo22>and i wrote init_hpet with that in mind
<damo22>why add unnecessary run time check every time you fine tune the clock?
<damo22>btw, i looked into using TSC but its a pain to calibrate that because it depends on cpu frequency
<damo22>there is a method to the madness
<ZhaoM>well I think you convinced me
<ZhaoM>ok I will use #ifdef APIC