IRC channel logs

2025-03-23.log

back to list of logs

<azert>ZhaoM: do you really need nanosecond precision in the timer interrupt?
<ZhaoM>that's needed for curl testsuite 1541 to pass
<ZhaoM> https://mail.gnu.org/archive/html/bug-hurd/2025-03/msg00000.html
<ZhaoM>More precisely say HPET can give us 10ns precision
<azert>That’s great
<ZhaoM>And my next goal is supporting higher-precision time stamp for ext2fs, then a lot of vim testsuites can pass :)
<ZhaoM>damo22: ping
<ZhaoM>what do you think of using #ifdef APIC to do the work
<ZhaoM>though it seems a bit unusual
<ZhaoM>#ifdef APIC in apic.c
<azert>I think that the branch you are introducing will not cause any overhead
<azert>Because of the branch predictor doing a good job
<azert>I would be more concerned that Linux uses the tsc instead of hpet for performance reasons. In theory, you could steal the tsc netbsd implementation and use the tsc if it is of the invariant type
<ZhaoM>haven't read the documentation about tsc. I will give it a try after integrating HPET
<Pellescours>youpi: for rumpkernel I saw that you have to search into the original sources to find the built pic files https://salsa.debian.org/hurd-team/rumpkernel/-/blob/master/debian/rules?ref_type=heads#L93
<Pellescours>I discovered that we actually need to define a variable MKPICINSTALL when running the build.sh script to have all pic files being installed in the obj folder https://github.com/NetBSD/src/blob/trunk/share/mk/bsd.own.mk#L1465
<Pellescours>so all lib files we want to install are in obj/destdir/usr/lib/ folder and not sparsed in the source
<Pellescours>this removes the need to do a find :)
<Pellescours>Ah but the rumpuser and pci won’t appear because we only do a make dependall
<youpi>sneek: later tell ZhaoM it's not really useful to look at tsc. Nowadays most machines to have an hpet, so we will be fine with just that
<sneek>Okay.
<azert>sneek: later tell ZhaoM reading the hpet takes ~100x more cycles then reading the tsc (source: https://docs.redhat.com/en/documentation/red_hat_enterprise_linux_for_real_time/7/html/reference_guide/chap-timestamping#Reading_hardware_clock_sources ). That’s why I mentioned the tsc. That said youpi is always right and possibly it’s a premature
<sneek>Will do.
<azert>optimization
<youpi>no, I'm not always right :) reading hpet is expensive indeed, but in this case we have already paid the cost of an interrupt or a system call, so that won't be much more, so we will probably be fine with that