IRC channel logs

2024-11-30.log

back to list of logs

<damo22>youpi: im reading the libbpf code but i cant seem to find a function that sends a network packet
<damo22>i think i need a SOCK_DGRAM not a SOCK_RAW too because libpcap uses that
<damo22>i understand that opening the socket allows me to call rump_sys_ioctl(socket, ...) with different functions to configure the net device, but i cant seem to find how to actually send/rx a packet
<youpi>sneek later tell gfleury sure, it's in my queue. I was looking at failed logs, next target could be pthread_sigmask and pthread_set/getspecific
<sneek>youpi, you have 1 message!
<sneek>youpi, gfleury says: few days ago i have sent a pachset for pthread_contrattr_*. If you have a time this weekend take a look at it
<sneek>Okay.
<youpi>damo22: the tcpdump code will show you how to receive packets
<youpi>the ping code can tell you how to send a packet
<damo22>well, i think it says device_read and device_write, but i dont know how to implement these to the NIC via rump, i seem to be missing some docs for rump
<damo22>i imagine it should be easy like rump_sys_read(some_fd, ...
<damo22>do i just use the socket?
<youpi>yes
<youpi>just like tcpdump and ping use it
<damo22>a hok
<damo22>ah ok*
<damo22>opened net dev
<damo22>/hurd/pfinet: ../../pfinet/ethernet.c:386: setup_ethernet_device: Assertion 'netstat.header_format == 1' failed.
<damo22>i guess i need to implement device_get_status and device_set_status properly
<damo22>opened net dev
<damo22>fsysopts: /servers/socket/2: -i /dev/wm0 -a 0.0.0.0 -m 255.0.0.0: Error in unknown error system: FFFFF63C
<damo22>Listening on Socket//dev/wm0
<damo22>youpi: how does pfinet configure the network device? eg address and netmask, it doesnt seem to make sense how it implements the ioctl itself
<damo22>surely netdde configures the eth0
<damo22>is it a bad idea to try to use rumpnet + pfinet?
<gnu_srs1>damo22: What about rumpnet + lwip?
<gnu_srs1>Is this a bug in dash? [ -x `command -v restorecon` ] && echo "\$?="$? returns $?=0 not 1??
<youpi>damo22: pfinet does not need to tell the device about ip, it's all software, the ethernet card doesn't care
<youpi>rumpnet+pfinet fully makes sense (rumpnet+lwip too)
<youpi>pfinet or lwip just create ethernet frames and give it to rumpnet, and gets ethernet frames from it
<youpi>btw, now I realize: it's not ping that you'd want to look at for sending frames, since it creates only icmp/ip packets, it's rather dhcp or arping (which create ethernet frames)
<youpi>gnu_srs1: $? only provides the return value of the last whole shell command , not of the last piece of command
<gnu_srs1>So how should the test be written?
<youpi>ah, no, not even, sorry
<youpi>false ; true && echo $?
<youpi>would print 0
<youpi>as well as true ; true && echo $?
<youpi>[ -x ] && echo ok
<youpi>[ -x "" ] && echo ok
<gnu_srs1> `command -v restorecon` returns an empty string
<youpi>you're just missing "" to get what you want
<youpi>so it's indeed seen by -x as empty string
<gnu_srs1>[ -x `command -v restorecon` eq ""] ??
<youpi>no
<youpi>see what I wrote
<youpi>[ -x ] vs [ -x "" ]
<youpi>so [ -x "`command -v restorecon`" ] && echo "\$?="$?
<youpi>you really need to think by logic, not by intuition
<gnu_srs1>OK, so I have to embed into parenthesis?
<youpi>no, I didn't write any parentheses
<youpi>see what I wrote above
<youpi>I just added "", that's all
<youpi>so -x does work properly
<gnu_srs1>Sorry, I meant qoutes, or whatever "" is called
<gnu_srs1>Found it: ' = apostrophe, " = quotation mark, ` = backtick/grave accent
<azeem>(or single vs doube quotes)
<azeem>double*
<gnu_srs1>azeem: agreed :)
<gnucode>heyo, I'm updating my T43 and the "change-logs" / "messages" just said, that next week apt will no longer use "apt-key" to verify signatures.
<sneek>gnucode, you have 1 message!
<sneek>gnucode, ZhaoM says: I successfully install luakit in the Hurd on my T60, thanks for reminding me some work is needed
<gnucode>Apparently it won't be there next week. Are we ready for that change?
<gnucode>sneek later tell ZhaoM Nicely done! How well does luakit work on the Hurd?
<sneek>Got it.
<gnucode>sneek later tell ZhaoM nice job on the rtc by the way! That was a very quick 1st contribution!
<sneek>Will do.
<gfleury>Hi
<sneek>gfleury, you have 1 message!
<sneek>gfleury, youpi says: sure, it's in my queue. I was looking at failed logs, next target could be pthread_sigmask and pthread_set/getspecific