IRC channel logs

2024-10-25.log

back to list of logs

<damo22>so i need to unpack the font into some memory and then blit it to the screen at the right place with the right stride
<youpi>yes
<damo22>so we dont need all the vga commands?
<youpi>provided the framebuffer is already set-up, you don't need to tinker with the card at all
<youpi>just need to know the format
<damo22>ive done that part
<damo22>it fetches the params from mbinfo
<youpi>one might want to synchronize with vsync to avoid tearing, but honestly let's just not care :)
<youpi>damo22: note that the "unpack the font into some memory" is already implemented
<youpi>in the dynafont support
<youpi>there's the initial loading
<youpi>it's just the copying into vga font mem that you can just drop
<damo22>if i implement a new display "driver" in the console-client, that means we need to specify "-d fb" something like that, but if the fb is not available we need to drop back to "-d vga"
<damo22>it is reasonable to load both drivers and tell vga driver to skip if fb is working?
<youpi>that should be fine yes
<damo22>otherwise i would need to merge the two drivers with a lot of conditional code
<youpi>really that many conditions ?
<damo22>well the driver is implemented as a struct of function pointers
<damo22>it makes sense to implement a new struct as a separate driver
<youpi>yes but auto-switching will be easier if integrated
<damo22>true
<youpi>and can be achieved by choosing which pointer you put in the struct for putting characters etc.
<damo22>ok
<damo22>i can try that way
<youpi>(the display_ops)
<damo22>ah yes i can swap them here err = driver_add_display (&vga_display_ops, disp);
<damo22>easy
<gnucode>also, I just had a rather silly idea for a Hurd game we could all play. We could all join the OFTC network, on a randomly determined channel with odd sounding usernames...and we have to guess which made of nickname is who.
<gnucode>That sounds strangely really fun to me. 🎃
<damo22>ive got glyphs rendering, but the console has trouble filling up and not scrollign
<azert>damo22: this is great! Sounds like you solved 80% of the problems already
<youpi>no
<youpi>rather 80% of the result
<youpi>and the remaining 20% are 80% of the problems :)
<youpi>blitting glyphs is not that hard. scrolling, cursor, etc. is more trouble
<azert>A bit unrelated to damo22 current work that is very important. Do you think that this: https://lore.kernel.org/dri-devel/20210430105840.30515-1-tzimmermann@suse.de/ could be implemented as a piece of the Hurd console? That would allow Wayland to run on the Hurd
<azert>it would probably require a good chunk of the drm framework to be included too
<RandomUser>Hello folks, I wish to start with Hurd, but I am not really sure what the skill requirements are. I know nothing about kernel development, not even created a toy kernel before, so would this be right for me to work?
<damo22>lol yes, the cursor is a pain and so is scrolling
<damo22>somehow it is still restricted to 80x25
<damo22>when i scroll to the end of the first terminal, it stops printing any chars
<damo22>i have a semi working gfx console :D
<damo22>scrolling is fixed, now cursor still broken
<damo22>cursor fixed, clearing screen broken
<damo22> https://i.imgur.com/KH7Fn3W.png
<damo22>\o/
<youpi>\o/
<damo22>reset/clear doesnt clear it though
<damo22>not sure why
<damo22>it clears ~2 lines
<damo22>there must be some memory corruption as well because sometimes my "t" key stops working
<youpi>no really convenien for yping suff
<damo22>exacly