IRC channel logs

2024-10-14.log

back to list of logs

<jab>bummer!
<gnucode>2048 works!
<almuhs>what is 2048?
<Gooberpatrol66>a game
<Gooberpatrol66>puzzle game thing
<almuhs>oh, ok
<gnucode>2048 works.
<gnucode>2048-qt doesn't start.
<almuhs>wesnoth shows error GlxBadContext
<gnucode>apt install allure;
<gnucode>allure -> binary not found.
<almuhs>hedgewars neither are in repositories
<almuhs>assaultcube neither, but maybe i could compile it. But it needs libsdl
<almuhs>frozenbubble crash too
<almuhs>same glx failure
<gnucode>amoebax also fails.
<gnucode>GLXBadContext
<almuhs>we have to found the library related with glx
<gnucode>hmmm.
<gnucode>angband -> angband only works with utf-8 support.
<gnucode>doesn't the Hurd have utf-8 support obviously?
<almuhs>hurd has utf-8
<almuhs>the problem seems related with opengl
<almuhs>glxinfo shows the same error
<almuhs> https://pasteboard.co/loX8C9Edft00.png
<almuhs>same error without sud
<almuhs>without sudo
<gnucode>hmm.
<almuhs>i go to try to compile assaultcube. I haven't many hope about this works
<gnucode>atom4 works!
<almuhs>what is atom4?
<almuhs>try 0ad
<gnucode>looks a little like frozen bubble.
<gnucode>I'm using the unstable distribution. 0ad is not installable.
<almuhs>check with apt policy
<almuhs>maybe you can install an old version
<almuhs>i'm compiling assaultcube
<gnucode>ballz works!
<almuhs>document all this games, with screenshots
<almuhs>to know which games works
<gnucode>I can do that! ballz is actually kind of fun by the way!
<gnucode>I'm not sure how to do a screenshot...just a second.
<almuhs>pingus fails. Same Glx erro
<almuhs>r
<almuhs>assaultcube has a compilation error
<gnucode>grrr.
<gnucode>lets of errors.
<gnucode>I guess just because it compiles...doesn't mean it runs.
<damo22>theres no opengl on hurd yet because theres no video acceleration
<youpi>there is the mesa software emulation
<damo22>what happens if you run glxgears
<damo22>gnucode: ^
<damo22>gnucode: you probably need to install mesa-*
<youpi>damo22: it fails on the X_GLXIsDirect minor opcode too
<youpi>it used to just work in the past (although not very fast)
<youpi>we have various kde packages whose testsuite fail similarly
<youpi>probably worth fixing
<damo22>i think you need to install libgl-dev
<damo22>to be able to compile opengl games
<almuhs>mesa is installed already
<damo22>almuhs: what about libgl-dev
<almuhs>frozenbubble, wesnoth and pingus worked some years ago, so it must be a regression
<almuhs>but libgl-dev is for compile
<damo22>yeah
<youpi>note: the GLXIsDirect error really looks like a genuine bug, not a missing package
<almuhs>the game that i'm compiling doesn't requires libgl-dev
<youpi>like somebody forgot to make the software emulation layer answer "no it's not direct"
<almuhs>if i get to compile assaultcube, i can check if libsdl works
<almuhs>but AC is a bad game for a jam, because it's a shooter. Without audio, and with probably lag, it can be very difficult to play
<jab>and my hurd box froze again...grrrr.
<damo22>jab: what did you do
<almuhs>in AC compilation, i have a enet compile error
<almuhs> https://paste.debian.net/1332203/
<damo22>i havent booted hurd for a long time, i am upgrading my packages
<jab>I was trying to set up an i3 keycommand to get a screen shot.
<jab>I had an error in the config apparently.
<almuhs>then make a simple photo
<jab>scrot works.
<jab>I just need to get it to work.
<almuhs>ok
<almuhs>i continue with assaultcube compilation. In Linux compile well, but in Hurd it shows this error
<damo22>almuhs: it looks like gethostbyname is being called with the wrong last parameter
<almuhs>yeah. But must be a library problem, because the same code compile correctly in Linux
<almuhs>or maybe a preprocessor flags problem
<almuhs>here it is the code https://github.com/assaultcube/AC/archive/refs/tags/v1.3.0.2.zip
<youpi>#if defined(linux) || defined(__linux) || defined(__linux__) || defined(__FreeBSD__) || defined(__FreeBSD_kernel__)
<youpi> gethostbyname_r (name, & hostData, buffer, sizeof (buffer), & hostEntry, & errnum);
<youpi>#else
<youpi> hostEntry = gethostbyname_r (name, & hostData, buffer, sizeof (buffer), & errnum);
<youpi>looks like a missing || defined
<damo22>|| defined(__GNU__)
<almuhs>where exactly? in which file?
<youpi>what the eror message said
<almuhs>i go to check
<almuhs>ok, solved this compiling error
<almuhs>adding the || defined(__GNU__)
<almuhs>compiled, but failed too in booting
<almuhs> https://pasteboard.co/vUYzjpH2nXM6.png
<damo22>recompile with -g
<damo22>and find the illegal instruction using gdb
<damo22>my hurd also froze on cloning from git 340MB
<damo22>i have seen this before that if i sync more often it doesnt hang
<almuhs>i'm trying to find where is private/entropy.dat
<jab>damo22: if I don't update the Hurd in a while, then I always update in the Hurd console. I've gotten issues when trying to update after X starts.
<damo22>i dont have X installed on hurd
<gnucode>It's kind of fun to use X. :) It's what us Hurd newbies do!
<gnucode>now I con't get ballz to work.
<damo22>error: RPC failed; curl 92 HTTP/2 stream 0 was not closed cleanly: CANCEL (err 8)
<damo22>error: 2126 bytes of body are still expected
<damo22>fetch-pack: unexpected disconnect while reading sideband packet
<almuhs>blobby volley fails too, with same glx error
<damo22>can you paste the error somewhere
<damo22>im having trouble cloning a big repo
<gnucode>biloba fails too
<almuhs> https://pasteboard.co/HKyUQnR3kWO4.png
<gnucode>GLXBadContext
<damo22>X_GLXIsDirect
<damo22>need to find that in the source
<gnucode>biniax2 fails as well. GLXBadContext
<gnucode>blobby failed too. couldn't open audio device. GLXBadContext
<gnucode>bloboats failed as well. Same error.
<almuhs>alex4 works. But it's really retro
<gnucode>blobwars fails as well.
<almuhs>there is a bug in opengl, definitelly
<almuhs>about assaultcube, i think that the problem could be in the script
<almuhs> https://github.com/assaultcube/AC/blob/master/assaultcube.sh
<gnucode>I can't install alex4
<almuhs>from the snapshot too
<gnucode>blupimania is also not working.
<almuhs>same glx error?
<damo22>do these games all use libSDL?
<damo22>the xorg-server parses the request to open a GLX context
<gnucode>bombardier works.
<damo22>part of the request is whether the GLX context is a direct one or not
<gnucode>text based game.
<damo22>almuhs: can you try LIBGL_ALWAYS_INDIRECT=1 ./game
<gnucode>doomsday almost worked...
<almuhs>in which game?
<damo22>for a start, try: LIBGL_ALWAYS_INDIRECT=1 glxgears
<damo22>do you get the spinning gears?
<almuhs>glxgears?
<gnucode>I got a pop up window.
<gnucode>then when the game actually loaded...
<damo22>glxgears is a built in test program to try opengl
<damo22>with the flag i am trying to force it to use software rendering
<almuhs>LIBGL_ALWAYS_INDIRECT=1 glxgears shows same glx error
<damo22>ok
<damo22>what about glxinfo
<gnucode>QOpenGLWindow::beginPaint: Failed to create context
<almuhs>same
<damo22>ok that sucks
<almuhs>it seems an opengl bug
<damo22>no its not using the software renderer
<almuhs>but i can't downgrade easily
<damo22>there is a environment variable that can override it
<damo22>its not a bug its a bad default
<damo22>LIBGL_ALWAYS_SOFTWARE=1 glxinfo
<almuhs>same error
<damo22>sudo apt install libgl1-mesa-swx11
<almuhs>this package is not available in repos
<damo22>maybe no 1 in the name
<damo22>libgl-mesa-swx11 ?
<almuhs>neither
<damo22>hmm
<almuhs>there are not any package with swx11 in its name
<almuhs>the most similar is libgl1-mesa-glx
<damo22>ok is that installed libgl1-mesa-glx
<almuhs>i have to go sleep
<almuhs>you can install xorg with a little desktop in a VM and make the experiments
<damo22>ok
<gnucode>crawl works. :)
<gnucode>sudo apt install libgl1-mesa-swx11 -> no installation candidate
<damo22>what about -glx
<damo22>libgl1-mesa-glx
<damo22>is that installed already?
<gnucode>it installed just now.
<gnucode>should I go ahead and re-test all those games?
<damo22>ok, try glxinfo
<gnucode>glxinfo --> binary not found
<gnucode>sudo apt install glxinfo --> failed
<damo22>you are missing some stuff
<gnucode>probably.
<damo22>i dont know the names of all the libs but you can check the "mesa" debian source to find them
<gnucode>maybe I should try to install mesa.
<damo22>eg in here https://salsa.debian.org/xorg-team/lib/mesa/-/tree/debian-unstable/debian
<damo22>there is no meta package called mesa to install all of mesa
<damo22>you just have to install them one by one
<gnucode>kk
<damo22>you probably need libglx-mesa0
<gnucode>I got that one.
<gnucode>probably after I installed mesa-common-dev
<damo22>mesa-utils
<damo22>install that ^ then do this: LIBGL_ALWAYS_SOFTWARE=1 glxinfo
<gnucode>sudo apt install mesa-utils
<gnucode>LIBGL_ALWAYS_SOFTWARE=1 glxinfo
<gnucode>X Error of failed request: GLXBadContext
<gnucode>Xlib: sequence lost (0x10014 > 0x16) in reply type 0x0!
<gnucode>I can put the whole error message on a pastebin if you like
<gnucode>snake in emacs works, but it's really laggy
<damo22>youpi: i have a feeling that rumpdisk does not flush its cache often enough, and so if you write a lot, it buffers the writes until it fills up a cache and then somehow gets stuck
<damo22>but if i regularly type 'sync' manually, it does not get stuck
<damo22>is it true that we are caching twice, once in rump vfs and once in pager?
<damo22>youpi: i have been in contact with a netbsd kernel developer, apparently if we are using pread/pwrite on a rwd0 device, there is no caching, but we are wasting ram for no reason, we can set -DBUFPAGES=16
<damo22>when building rump
<damo22>(03:48:59 PM) mlelstv: I'm not 100% sure if 16 pages are enough, but they should be.
<damo22>(03:49:30 PM) mlelstv: sufficient to do one maximum sized I/O request, if not enough, increase slightly
<damo22>youpi: rumpkernel debian package wont compile for me on hurd unless i add -D_GNU_SOURCE
<damo22>wcwidth cannot be located
<damo22>gnumachUser.c: In function 'thread_get_name':
<damo22>gnumachUser.c:1791:37: error: comparison of integer expressions of different signedness: 'unsigned int' and 'int' [-Werror=sign-compare]
<damo22> 1791 | if (mig_unlikely (msgh_size != 36 + ((OutP->nameType.msgt_number + 3) & ~3)))
<damo22> | ^~
<youpi>damo22: is it true that we are caching twice, once in rump vfs and once in pager?
<youpi>That's possible, yes, AFAIR the people doing the rump port didn't manage to understand how to control the caching done in rump
<youpi>> we are wasting ram for no reason, we can set -DBUFPAGES=16
<youpi>That's very possible
<youpi>> wcwidth cannot be located
<youpi>Missing #include, very common issue nowadays with the requirement of having all declarations
<youpi>> comparison of integer expressions of different signedness: 'unsigned int' and 'int' [-Werror=sign-compare]
<youpi>We probably want to disable sign-compare being an error
<youpi>(and fix mig)
<youpi>(note: I can provide some quick advise about these ; I can't magically find time to work on them)
<damo22>ok
<youpi>damo22: to sync more regularly, use the --sync option of /hurd/ext2fs
<youpi>(but we want to fix the caching controlling issue of course)
<damo22>damn, i cant figure this ram usage out
<damo22>is there a command on hurd that dumps the memory map of a process?
<damo22>theres like 200mb rss
<damo22>also, running rump_init() in userspace kills the running rumpdisk
<damo22>well not kills it, but acpi reroutes the irq and causes havoc on the running disk driver
<youpi>damo22: vminfo
<bool`>is there any place for a newer programmer to contribute to gnu/hurd, or atleast learn from it? i'm very curious about it
<gnucode>hey hure people!
<gnucode>hurd*
<gnucode>bool`: yes! Feel free to jump in!
<gnucode>grrr, my T43 locked up on me again.
<gnucode>I wonder if it's 'cause this box has 1.5GB of RAM. That's not a lot of memory...
<gnucode>I don't think that's it though. I use i3, emacs, netsurf (with max 3-5 tabs open), and a couple of terminals (rxvt). When I run top (and I run it a lot to make sure I am not exhasting memory...)I normaly have .5GB of RAM free.
<gnucode>lots of ram gets used as a buffer/cache.
<gnucode>bool`: The hurd.gnu.org contributing page has a small hack entries stop.
<gnucode>geez, X just locked up on my again when I started playing ballz.
<gnucode>weirdly enough I have to start ballz like 3 times before it'll start properly.
<gnucode>weird.