IRC channel logs

2024-07-07.log

back to list of logs

<almuhs>hi. I've created a Hurd sticker design in stickermule https://www.stickermule.com/u/18a48b5d62ea708/item/15634352
<almuhs>now you can buy good quality stickers with the Hurd logo, to paste in your machines :-)
<Gooberpatrol_66>nice
<damo22>i am trying to implement a call-wheel structure as per Costello and Varghese 1995 for timers. i am running into issue that i cannot dynamically allocate timers because i am inside a clock interrupt?
<damo22>we are currently using a flat list for timers which is fairly inefficient
<damo22>the callwheel works by a ringbuffer that wraps exactly over (elapsed_ticks % WHEEL_SIZE)
<damo22>so its an O(1) lookup to find the array of timers expiring at any tick
<damo22>s/array/list
<damo22>problem is, i cant dynamically grow or shrink the list during a clock interrupt
<damo22>each element of the call wheel is the head of a list