IRC channel logs

2024-05-31.log

back to list of logs

<gnucode>does anyone know if this is still a problem?
<gnucode> https://darnassus.sceen.net/~hurd-web/open_issues/ext2fs_page_cache_swapping_leak/
<gnucode>ok I'm actually surprised that tmpfs used diskfs. tmpfs is running entirely in RAM yes ?
<nikolar>it's supposed to
<nikolar>ignoring swap i guess
<gnucode>for some reason I always assumed the libdiskfs could only use hard drives, SATA/SSDs. I didn't realize you could have libdiskfs run on top of RAM.
<youpi>libdiskfs could actually be called libstorefs
<youpi>it's meant to use some storage area to store a filesystem
<youpi>which is very different from a filesystem built out of the blue such as /proc (thus libnetfs)
<gnucode>so when I say libdiskfs...it might be a good idea to think libstorefs
<youpi>you can think of that, yes
<youpi>"disk" in a very broad sense
<youpi>(note that it can be e.g. a file stored in another filesystem)
<gnucode>youpi...I wondered about that. That wiki edit that I sent you today...where I created my own personal ext2fs filesystem...
<gnucode>somehow I have ext2fs ontop of ext2fs...I feel like there is some magic going on to make that work fast.
<youpi>well, the overlaying is not really what costs most
<youpi>the missing readahead does cost
<gnucode>I'm just thinking is there a limit? suppose I create /home/joshua/dummy/dummy/dummy/dummy....
<gnucode>where each dummy is another ext2fs ...Is there a limit to how many of those that we could have ?
<youpi>SYMLOOP_MAX
<youpi>which is at least 40
<youpi>(as per posix)
<gnucode>readahead...as in the google summer of code project idea that we have had for a while.
<gnucode>That's a fair amount of nested ext2fs.
<youpi>it's actually mostly meant for symlinks
<youpi>ah, I read the wrong file
<youpi>it's actually 32
<youpi>40 is not as per posix, which only says 8
<gnucode>So 32 is the limit if we want to maintain POSIX ?
<youpi>no, 8
<youpi>and hurd provides 32
<nikolar>posix usually doesn't require hard limits, only minima and maxima
<nikolar>yup,
<nikolar> {SYMLOOP_MAX}
<nikolar> Minimum Acceptable Value: {_POSIX_SYMLOOP_MAX}
<nikolar> {_POSIX_SYMLOOP_MAX}
<nikolar> Value: 8
<gnucode>So we could have /home/joshua/dummy/dummy/dummy... 32 times! That's less than I thought, but still a lot.
<nikolar>posix requires at least 8, everything else is up to hurd or libc or whatever
<gnucode>pretty cool
<gnucode>I was just thinking...it would be pretty cool to send a Hurd laptop to Pwn2Own
<gnucode> https://en.wikipedia.org/wiki/Pwn2Own
<nikolar>eh i'd expect hurd to be as full of holes as swiss cheese, since it's got a pretty small userbase
<gnucode>nikolar: hahaha!
<gnucode>I guess Sergey still has a 0 day vulnerability that he found that is not fixed yet.
<jab>So Sergey just offered to live code a simple trivfs translator on our upcoming live coding jam this Saturday June 1st.
<jab>I'm thinking that maybe we could extend ext2fs. If a user asks ext2fs to find say an image file (monkey.png), then ext2fs will return 404.png (a file not found image).
<jab>He also offered to make a simple trivfs translator. Any ideas for what Sergey could code up on the fly?
<pavlx>hello
<jab>hello pavlx
<etno>sneek: later tell gnucode: the c compiler trivfs sounds to me like a fun idea. AIUI, each time someone would open the binary (or execute it), the translator would compile it. TCC could be a handy backend for that.
<sneek>Got it.
<jab>etno: I like that idea too.
<etno>jab: 👍 It could be mounted on a CGI directory 😬
<gnucode>wel that doesn't happen everyday...sway locked up on me. guix was building some really big library, and all of a sudden my linux machine moved at a snail's pace. I was able to recover, which is probably why sway is sooo freaking awesome!
<sneek>gnucode, you have 1 message!
<sneek>gnucode, etno says: the c compiler trivfs sounds to me like a fun idea. AIUI, each time someone would open the binary (or execute it), the translator would compile it. TCC could be a handy backend for that.
<etno>sneek: botsnack
<sneek>:)
<gnucode>etno: so you're saying ...Cfs could be as easy way to get a CGI for C running on the Hurd ?
<etno>sneek: later tell gnucode: well, yes, but you don't want to code CGI handlers in C, right ? 😅
<sneek>Okay.
<jab>etno: I'm also gnucode btw. I go by jab and gnucode. (gnucode is usually from the Hurd).
<etno>Oops, got it (I use an XMPP gateway with biboumi, very handy, with that you get multi-client+offline on IRC with the same nick)
<jab>etno: have you heard about -> https://learnbchs.org/
<jab>that actually does sound like someone I should take a look at...
<etno>I did not know bchs, interesting 🤔.
<jab>right!? I hadn't heard of it either. :)
<jab>I actually wonder how hard it would be to port pledge and unveil to the Hurd.
<jab>anyone know a ballpark estimate how many lines of code GNU Mach is ?
<jab>without the pfinet and netdde ?