IRC channel logs

2024-04-09.log

back to list of logs

<azert>solid_black: maybe el0 needs some initialization?
<solid_black>hi!
<solid_black>azert: try this https://github.com/bugaevc/gnumach/commit/ee177f52680116538192b2c0c5d9a08e174c007f
<solid_black>also please do show full logs -- as youpi says, every detail matters
<solid_black>see how I was able to diagnose what went wrong with entering EL1 by looking at U-Boot's register dump? I might be able to do that again
<solid_black>if you didn't post the register dump, we would still be stuck there
<solid_black>if you enabled sync exc tracing and it still hangs, *what does it output*? same thing (no sync excs)? something new?
<solid_black>as for students: Mach itself was largely written by a then-student, Avie Tevanian :)
<solid_black>GCC patches are in \o/
<Gooberpatrol_66>nice
<anatoly>solid_black: oh yeah!
<almuhs>yesterday I was testing rumpdisk in 3 variants of Thinkpad T60 and in the T410. In all I have the same issue, failing in pci mapping step. But in all of them NetBSD 10 runs well
<almuhs>The T410 neither detect the NetBSD 9.1 DVD
<almuhs>I've just checking the NetBSD sources, and I've just found that ahcisata_pci.c was modified many times since 2021, and the latest was in October 2023
<almuhs> http://cvsweb.netbsd.org/bsdweb.cgi/src/sys/dev/pci/ahcisata_pci.c
<almuhs>pci_map.c was modified by latest time in January 2021 http://cvsweb.netbsd.org/bsdweb.cgi/src/sys/dev/pci/pci_map.c
<almuhs>maybe i can update that files, but i need to check that this doesn't need to update other files
<almuhs>**these files
<almuhs>the commit messages in ahcisata_pci.c shows fixes in detection of many models of disks
<almuhs> http://cvsweb.netbsd.org/bsdweb.cgi/src/sys/dev/pci/#dirlist There are many files with recent updates than 2021
<azert>almuhs: is it hard to just update the whole netbsd source used by rumpdisk? I think it shouldn’t be that hard!
<azert>Did you try?
<almuhs>i can try, but probably i need some help to know what are the modifications done to adapt it to gnumach
<almuhs>to avoid replace any file which have been modified to be compatible with gnumach or hurd
<almuhs>at moment, i can replace all pci directory
<azert>If there aren’t any patches applied then it means it’s virgin
<almuhs>how can i check this?
<solid_black>azert: have you seen my patch above that adds lots of tracing?
<almuhs>no
<azert>I think there is a git in debian
<azert>solid_black: thanks! I’ll try tonight
<solid_black>ok, thanks a lot!
<almuhs> https://salsa.debian.org/public?name=hurd&sort=latest_activity_desc ?
<azert> https://git.zammit.org/rumpkernel-debian.git/tree/buildrump.sh/src
<azert>From git logs it should be obvious if any patches had been added
<almuhs>oh, this is damo22 personal repository
<almuhs>there are only 4 commits
<solid_black>azert: just so that we have less back-and-forth: the patch dumps addresses (of continuations in the kernel, and to where in EL0 it attempts to return); those of course are going to be addresses in your build, so you should symbolicate them
<azert>Yes, the patch looks good
<azert>Also your full log will be helpful to compare
<solid_black>e.g. that ffff0000402096c0 from my trace is idle_thread_continue in my build
<solid_black>you have to subtract the slide (0xffff000040200000 here) of course
<azert>Is there a fast way to get the symbol from an address
<solid_black>addr2line, or gdb
<azert>Something that doesn’t involve qemu and gdb?
<solid_black>i.e. p (void *) 0x96c0 in gdb
<almuhs>ok, i will check which files are modified in these commits
<solid_black>no need for qemu, just gdb
<azert>Thanks
<solid_black>otherwise: aarch64-gnu-addr2line 0x948c --exe=build/gnumach.elf --functions
<solid_black>idle_thread_continue
<solid_black>../kern/sched_prim.c:1631
<solid_black>but really, mind the slide, or you're not going to get anything meaningful
<almuhs>how can i download these sources? http://cvsweb.netbsd.org/bsdweb.cgi/#dirlist
<almuhs>ok, found https://www.netbsd.org/docs/guide/en/chap-fetch.html#chap-fetch-cvs-netbsd-release
<gnucode>sneek: later tell solid_black I should probably update the latest news with your alpine aports
<sneek>Got it.
<almuhs>LOL https://bsd-pl.org/assets/talks/2019-10-10_1_Mateusz-Kocielski_anykernels_meet_fuzzing.pdf
<OwlWizard>is there work being done to have hurd run on risc-v?
<OwlWizard>im not all that well informed about the state of the project
<Pellescours>almuhs: for rumpkernel, you probably can replace the whole src folder and check. I think all patch will apply without issue
<almuhs>yes, but the src from main netbsd repository has a lot of sources which we don't need
<Pellescours>that’s something I want to do (to test) but i’m currently too busy
<Pellescours>there is a script in debian repo that does the cleaning
<almuhs>i've just found that script, that seems which damo22 used to clone the sources. But by default download sources from 2016
<almuhs> https://github.com/rumpkernel/buildrump.sh
<Pellescours>this script https://salsa.debian.org/hurd-team/rumpkernel/-/blob/master/debian/prune.sh?ref_type=heads
<almuhs>i've noticed that this script allows clone via cvs, and the cvs option use the main repository, which it's current. But I don't get how to make this script download from cvs
<almuhs>the buildrump.sh script, by default, download sources from a github repository which are obsolete
<almuhs>if i discover the arguments to force clone via cvs, i can get updated sources
<Pellescours>there is also a github repository (mirror) of netbsd, which can be easier if your more familiar with git
<almuhs>but the github repository is outdated
<Pellescours>not a repo of buildrump, a repo of netbsd sources
<almuhs>but i need to remove all unnecesary sources
<Pellescours>take the debian repo https://salsa.debian.org/hurd-team/rumpkernel, replace the src folder by version 10 of source of netbsd https://github.com/NetBSD/src/tree/netbsd-10 and do a classic debian build
<Pellescours>optional, you can run the prune script to remove unneeded files
<almuhs>ok
<almuhs>the netbsd github seems updated
<almuhs>cloning
<almuhs>the prune.sh script is incomplete: lacks removing games and x11 directories
<Pellescours>patches welcome
<almuhs>:)
<almuhs>oh, games are included to remove in the script. I didn't notice it
<almuhs>if I copy the src directory inside rumpdisk-xxx/buildrump.sh/ , and I execute "dpkg-buildpackage -B -uc -d " I have an error
<almuhs>ERROR: HOST_SH=" sh" is not an absolute path
<Pellescours>are the patches applied after you updated the src?
<almuhs>i think yes
<almuhs>making "quilt pop -a -f" the compilation seems to continue
<almuhs>but this disable all patches
<azert>solid_black: this is what I got with the lots of tracing https://paste.debian.net/1313614/
<azert>looks very similar to yours until it get stuck
<almuhs>hi. After disabling all patches (quilt pop -a -f), when i run dpkg-buildpackage -B -uc -d, i get this error https://paste.debian.net/1313616/
<almuhs>i copied the sources cloned from this: https://github.com/NetBSD/src/tree/netbsd-10
<azert>looks like a bug
<almuhs>yes. Now I'm downloading the sources from cvs, to check that this are the same https://www.netbsd.org/docs/guide/en/chap-fetch.html#chap-fetch-cvs-netbsd-release
<almuhs>added to this, maybe we need to indicated the architecture. i386 in this case