IRC channel logs

2024-04-03.log

back to list of logs

<jab>hello pals!
<Gooberpatrol66>hi
<solid_black>hi!
<Pellescours>hi
<solid_black>the whole HACK HACK HACK in vm_map.c is more broken than it looked last time
<solid_black>even without entry coalescing
<solid_black>part of the reason my patch worked must be that it (accidentally, because I only implemented support for a single entry) dropped support on 'end' staying valid
<solid_black>s/support/reliance/
<solid_black>there's absolutely no reason to think 'end' will stay valid once we unlock the map, because 1) it's an entry in a different memory region, so it could get deallocated or whatever 2) another entry might get inserted in between our region and 'end'
<solid_black>this became broken with rbraun's "VM: rework map entry wiring"
<solid_black>it's using addresses in vanilla Mach 3
<solid_black>let's run my whole system on SMP and see what breaks
<solid_black>what could possibly go wrong :D
<solid_black>things seem to generally work, but I get "Tty c10b1e40 was stuck" all the time
<solid_black>(from i386/i386at/com.c:comtimer)
<solid_black>this happens when a process tries to output more than a few characters
<solid_black>things are definetely multi-core-y, I can see ipc_mqueue_send -> thread_setrun -> apic_send_ipi when I interrupted the machine at a random point
<solid_black>it sounds like vm_map_pageable_scan could lead to deadlocks in the user case too
<solid_black>wiring down the object require faulting in its pages while the map is read-locked, but fauliting in the pages blocks until the pager replies
<solid_black>what if the pager is the same task
<gnucode>howdy people!
<anatoly>solid_black: hi, have you pushed the latest and greatest to the hurd-alpine repo?
<Pellescours>where is that alpine repo?
<anatoly>Pellescours: https://github.com/bugaevc/aports
<Pellescours>thanks
<gnucode>hmmm
<gnucode>setxkbmap -layout 'dvorak' -option 'ctrl:swapcaps'
<gnucode>this used to work for me.
<gnucode>can we now change the layout via some debian command? I'm guessing yes. Don't tell me, let me look for the answer first.
<Pellescours>which env, raw console or x11?
<gnucode>Pellescours: it would be nice to change both to dvorak
<gnucode>I think the debian hurd wiki page mentions a specific command to change the layout
<Pellescours>for the console it will be possible soon (I made recent patch to hurd to make console using the xkbcommon lib, unlocking the possibility to use dvorak)
<Pellescours>It’s not upstreamed yet to debian
<gnucode>Pellescours: bummer. I was actually using the dvorak layout in i3. Now it seems to stop working. Which I guess you patch (which is the 'best' thing) caused.
<gnucode>At least I think so
<Pellescours>I only patched the hurd-console, if you are using i3 it should not be impacted
<gnucode>Pellescours: all I know is that in i3
<gnucode>setxkbmap -layout 'dvorak' -option 'ctrl:swapcaps'
<gnucode>errors out with this message (I just updated)
<gnucode>Error loading new keyboard description
<Pellescours>if you try another layout does it work?
<gnucode>what layout would you like me to try{
<gnucode>try?*
<Pellescours>try a basic one : qwerty or azerty
<gnucode>layout de worked
<gnucode>but now qwerty does not work
<Pellescours>layout us?
<gnucode>that worked
<gnucode>just for fun
<Pellescours>qwerty is not a valid layout name I think
<Pellescours>try bepo_afnor?
<gnucode>ü 'ß § Ä Ü
<gnucode>that is german
<Pellescours>haha
<gnucode>maybe the command is -layout us -varient dvorak ?
<Pellescours>I think yes
<gnucode>woo hoo! I got dvorak working again!
<gnucode>setxkbmap -layout us -variant dvorak -option 'ctrl:swapcaps'
<anatoly>gnucode: https://wiki.archlinux.org/title/Xorg/Keyboard_configuration has lots of examples, man page for it is pretty dry
<gnucode>thanks!
<gnucode>Pellescours: how does one go about changing the console layout?
<gnucode>and I thought that I had a q1 of 2024 almost finished, but apparently not. grr.
<Pellescours>you need to recompile hurd latest to have the latest console installed, and then you need to update the /etc/default/hurd-console file to specify the new variables
<gnucode>hmmm
<Pellescours>AHHHH, I’m playing with cross-hurd, and I modified it enough to suport other keyboards layout. Now I’m trying to start the hurd console in order to be able to have another layout than qwerty
<Pellescours>And every time I start /bin/console with the options (vcs, vga, keyboard...) I have my console screen fill with random characters
<Pellescours>I don’t understand how it should be started
<gnucode>when you try to type on your keyboard, is it putting out the correct lettors, or random gibberish?
<Pellescours>I don’t know the screen is still full of random characters, when I type I see my cursor moving but I don’t know what is typed
<Pellescours>I may have missed something but I put a lot of stuff in place to reproduce what we have in debian (same command line, font file, …)