IRC channel logs

2024-03-31.log

back to list of logs

<almuhs>hi. I've edited the rumpkernel which downloaded from here https://people.debian.org/~sthibault/tmp/unreleased/rumpkernel_0~20211031+repack.orig.tar.gz . How can i compile it?
<youpi> https://www.debian.org/ports/hurd/hurd-devel-debian
<almuhs>is it possible to create a tmpfs in Debian GNU/Hurd? To reduce rumpkernel compilation time
<youpi>there shouldn't be a need for it since ext2fs already caches writes
<youpi>it happens that there already is a tmpfs
<youpi>but there is an issue with it so we can't really use it yet
<youpi>see open_issues etc.
<almuhs>ok, I understand
<almuhs>/home/pruebas/rumpkernel-0~20211031+repack/pci-userspace/src-gnu/pci_user-gnu.c:551:15: error: implicit declaration of function 'vm_pages_phys' [-Werror=implicit-function-declaration]
<almuhs> 551 | ret = vm_pages_phys (master_host, tp, vaddr, PAGE_SIZE, &paddrp, &count);
<almuhs>can't i download only the sources of rumpdisk? or the pci block of rumpkernel?
<youpi>ah, damn, I indeed hadn't uploaded the newer gnumach yet
<youpi>because I'm still waiting for the smp fix
<youpi>you can quilt pop the vm_pages_phys.diff patch
<youpi>and comment it from debian/patches/series
<youpi>rumpkernel is not meant to be built separately
<youpi>I mean, build components separately
<youpi>of course it's theoretically possible but nobody took the time to make it work
<almuhs>ok, i will remove this patch
<almuhs>my knowledge is too limited as to make split the rumpkernel sources
<Pellescours>By split the rumpkernel source you mean, only keep the rump part from netbsd?
<youpi>no, she means spliting the building process
<youpi>so you can build only the part you're interested in
<Pellescours>Ah I see
<almuhs>i only need to compile pci block, and there are a package called librumpdev-pci . I wanted to download the sources only for this package and only compile that
<almuhs>*librumpdev-pci0 and librumpdev-pci-dev
<almuhs>but this is not possible by now
<almuhs>there are a lot of problems. If I put a older version of pci_user-gnu.c which not use vm_pages_phys, now lacks experimental_U.h
<almuhs>could be possible to compile rumpkernel using upstream sources?
<almuhs>**gnumach's upstream sources
<youpi>I don't know, but don't you have experimental.defs coming from the installed gnumach headers?
<youpi>also, I don't understand: the machirqdev.dif fpatch is precisely removing that #include
<youpi>are you sure you are starting from a clean checkout?
<almuhs>really, i have a mix. I downloaded manually that https://people.debian.org/~sthibault/tmp/unreleased/rumpkernel_0~20211031+repack.orig.tar.gz and edited in my host machine. But now I'm noticing that dpkg-buildpackage -B has generated other different sources
<youpi>why just the orig?
<youpi>you want the dsc and debian parts
<youpi>so you can just dpkg-buildpackage it
<youpi>orig is only the upstream part, you won't have all the debian packaging
<youpi>you can e.g. use dget on the dsc url to get everything
<youpi>again, it'd be really help ful that people work on making such information easily available on the wiki
<youpi>so people don't lose time on trying to understand how to build debian packages while it's just normal well-known debian process
<almuhs>if the wiki could allow edit without needing send html patches, could be easier to add info
<youpi>(well-know to people who know it, just needs to be recorded on the wiki so that people won't don't know it can use it)
<youpi>you can git clone the repo from darnassus
<youpi>again, is that not documented?
<youpi>io
<almuhs>what is not documented?
<youpi>git cloning the wiki repo from darnassus
<youpi>the *very normal* way of contributing ot the wiki
<youpi>is that not documented?
<almuhs>i'm not sure
<youpi>it means it's not
<youpi>GRAH
<youpi>do you at least have an account on daranssus
<youpi>?
<almuhs>no
<youpi>pfff
<youpi>this is depressing
<almuhs>i only have account in savannah
<youpi>I have to do everything
<youpi>I just *DONT* have time to do all this
<almuhs>yes, i know. Btw, it could be interesting to create a more intuitive URL for the wiki. Although the URL redirect to darnassus
<almuhs>it's not easy to find the updated wiki by a novice
<youpi>again, contribution welcome
<youpi>but again, first thing first
<youpi>please see my PM
<almuhs>but, who pays the URL?
<youpi>braunr
<almuhs>added to this, it could be interesting add a way to edit the wiki without sending "code" patches. Like wikipedia or similar
<almuhs>directly from the webpage
<youpi> https://darnassus.sceen.net/~hurd-web/contributing/web_pages/
<youpi>it's all in there
<youpi>the edit button is there
<youpi>it's already just in there
<youpi>if it's bug then please report
<youpi>afaict it's just working
<almuhs>ok, i will test it
<youpi>but really simpler is the git clone, as documented
<almuhs>so long
<youpi>not a good excuse
<Pellescours>I’m playing with cross-hurd and when trying to compile python, it sometimes hang at step where it’s linking stuff. I tried to compile python also in my debian VM and I got the same hang
<Pellescours>I don’t know if someone is aware of this kind of hang. I don’t know how to debug this as, even the console does not respond to input
<Pellescours>Note: it’s python 3.12
<Pellescours>I’m running it without smp, and sometimes all is fine
<almuhs>hi. Where gnumach-dev store its files? I want to replace some of this with upstream's version to get compile rumpkernel
<Pellescours>it’s somewhere under /usr/include/i386
<almuhs>/usr/include/i386-gnu/mach ?
<Pellescours>I don’t know they may be split under multiple folders. I don’t know which headers are provided by gnumach and those provided by glibc
<Pellescours> https://packages.debian.org/sid/i386/gnumach-dev/filelist
<zamfofex>Better URL: https://packages.debian.org/sid/hurd-i386/gnumach-dev/filelist
<almuhs>thanks
<youpi>almuhs: find can tell you
<youpi>find /usr/include -name mach.h
<almuhs>fuck. vm_pages_phys() is only in a source file, doesn't appears in any header
<almuhs>this function is in vm_user.c , but not in vm_user.h
<youpi>it's generated from include/mach/gnumach.defs
<youpi>the rumpkernel makefile knows to regenerate from taht
<youpi>you just need to install the newer gnumach.defs
<youpi>it's an rpc for userland, not for the kernel
<almuhs>thanks, i go to try it
<almuhs>found: /usr/include/i386-gnu/mach/gnumach.defs
<almuhs>replaced by upstream version