IRC channel logs

2024-03-24.log

back to list of logs

<damo22>solid_black: the vm_map deadlock is still outstanding? https://lists.gnu.org/archive/html/bug-hurd/2024-03/msg00081.html
<damo22>i think its blocking a smp variant from being released
<damo22>youpi:
<damo22>102 free (priv_arg->arg);
<damo22>103 _thread_cleanup ();
<damo22>104 return NULL;
<damo22>105 }
<damo22>it used to crash in free(), i fixed that, but now when this return NULL happens, it returns to entry_point()
<damo22>(gdb) bt
<damo22>#0 0x081a0fdb in entry_point ()
<damo22>#1 0x00000000 in ?? ()
<damo22>and continues without exiting
<damo22>then crashes next time i do ifup /dev/eth0
<damo22>after line 104, isnt it supposed to exit netdde?
<damo22>why does continuing after breaking on pthread_exit hang?
<damo22>damn, the ddekit thread cleanup is hard
<damo22>it seems to get into a bad state and i need to reboot
<damo22>it crashes on ifup/down
<damo22>i cant kill -9 netdde.static
<damo22>70 irqhelp_server_loop(ddekit_irq_ctrl[irq].irqhelp);
<damo22>(gdb) n
<damo22>warning: Signal ? does not exist on this system.
<damo22>warning: Pid 533 died with unknown exit status, using SIGKILL.
<damo22>Program terminated with signal SIGKILL, Killed.
<damo22>Thread 9 received signal ?, Unknown signal.
<damo22>0x08186b97 in wrapped_server_loop (arg=0x2000d9f0)
<damo22> at ../../libddekit/interrupt.c:71
<damo22>71 ddekit_irq_ctrl[irq].irq_thread = NULL;
<damo22>(gdb) x/i $pc
<damo22>=> 0x8186b97 <wrapped_server_loop+71>: movl $0x0,0x26fd4(%ebx,%eax,4)
<damo22>what is that??
<damo22>stack corruption?
<damo22>out of stack space => 0x8186b83 <wrapped_server_loop+51>: push 0x26fdc(%ebx,%eax,4)
<youpi>damo22: stack corruption is possible is some thread does bogus stack array access, sure
<youpi>normally, entry_point's call to __pthread_exit cannot return
<youpi>because it calls __pthread_thread_terminate on itself
<damo22>ok i think i figured it out
<youpi>or else it calls abort, which at worse calls the abortion instruction
<youpi>(htl)
<youpi>(hlt*)
<damo22>\o/ works
<youpi>\o/
<damo22>without forcing pthread_exit