IRC channel logs

2024-03-18.log

back to list of logs

<belgin>hello!
<user_oreloznog>o/
<belgin>someone was asking how to write an sdcard driver. usually, on embedded systems, they use an emmc controller. there is a spec for that, but it costs about 300 bucks https://www.jedec.org/document_search?search_api_views_fulltext=jesd84-b51 you can also check out implementations in u-boot, which basically implement part of the spec, with some vendor quirks https://source.denx.de/u-boot/u-boot/-/tree/master/drivers/mmc
<belgin>i gave u-boot as an example because it's relatively easy to read the code
<Pellescours>I’m wondering if it’s not already implemented in rumpkernel
<Pellescours> https://salsa.debian.org/hurd-team/rumpkernel/-/tree/master/buildrump.sh/src/sys/dev/sdmmc?ref_type=heads
<Pellescours>yup, rumpkernel have a SD card driver. We just need to wire them and use them
<azert>I think on netbsd it works like the following: obio0 at mainbus0; sdhc0 at obio0; sdmmc0 at  sdhc0
<azert>There will be the issue that since it’s not on pci then either one will have to write an arbiter for whatever, or all the driver will need to be in the same userspace process
<azert>Since the Hurd so far has only a pci arbiter
<azert>Also, intuitively, netbsd is overenginnering over here
<azert>And possibly the Hurd doesn’t want all the baggage
<azert>mainbus is a placeholder. obio stands for on board io.
<kilobug> /away bbl
<kilobug>(sorry)
<azert>If one can create shims for whatever is obio maybe through the hypothetical device tree translator that people discussed days ago maybe one can use rumpdisk for the sd card
<azert>Hi solid_black
<azert>I was thinking in regards to your post on mastodon, that maybe if you have serial ports support, Hurd on aarch64 can have networking way before any work on device drivers gets done
<azert>Typically by using the available ppp support https://mail.gnu.org/archive/html/bug-hurd/2017-08/msg00003.html over serial
<azert>Then you will be able to connect remotely through ssh
<azert>And even connect from the internet through the serial port
<azert>Effectively using it as a network card
<azert>Although limited to a few hundreds kilobits per second :(