IRC channel logs

2024-03-17.log

back to list of logs

<damo22>\o/ it works
<youpi>> it crashes if you do return NULL
<youpi>That's really odd and worth investigating, by at least checking what asm instruction exactly produces the crash
<solid_black>hi
<damo22>how do i step by asm?
<solid_black>si
<solid_black>and ni
<solid_black>I've got exciting news :)
<damo22>what is it
<solid_black>ext2fs.static starts and works, and ld.so loads the exec server and all the shared libraries and does all the relocations and whatnot, and the exec server handshakes with ext2fs
<damo22>cool, but no disk?
<solid_black>it currently fails on ext2fs failing to find /servers/exec to put the exec server on, simply because haven't put that node onto the ramdisk
<solid_black>it's ramdisk for now
<damo22>ok
<damo22>im not sure how to write SD card driver
<solid_black>also check this out https://imgur.com/a/W2f329S
<solid_black>I played with DWARF to make exceptions / interrupts look like signals to GDB
<solid_black>and GDB is now totally able to backtrace through interrupt handlers
<solid_black>with full registers, locals, etc
<solid_black>DWARF is really flexible, it lets you encode, in bytecode, where to find saved register values
<solid_black>so I made GDB read our (Mach's) aarch64_thread_state / aarch64_kernel_exception_state that we store
<solid_black>in the same way that the kernel itself does
<solid_black>and reconstruct backtraces / saved variables based on that
<solid_black>there are three different stacks there actually, the userland stack, the PCB stack, and the kernel stack
<solid_black>but GDB is now able to see through them all
<solid_black>how cool is that?
<biblio>solid_black: nice :)
<solid_black>hi biblio
<biblio>solid_black: hi
<solid_black>what's up the risc-v port? :)
<biblio>solid_black: still working with it. No update yet.
<damo22>solid_black: that is cool, but you should write docs on how
<damo22>0x081a8b4b in mach_msg ()
<damo22>(gdb)
<damo22>crash
<damo22> 81a8b4b: e8 b0 1c 05 00 call 81fa800 <__mach_msg_trap>
<solid_black>damo22: so you mean the call instruction is crashing? what kind of crash is that?
<damo22>solid_black: not sure
<youpi>the backtrace would give a better idea