IRC channel logs

2024-03-15.log

back to list of logs

<damo22_>usually when you process data you need it in unencrypted form, you cant process encrypted data -> encrypted output without decrypting it in the middle
<youpi>with homomorphic encryption, you can
<damo22_>ok
<damo22_>thats news to me
<youpi>it's the point of homomorphic encryption :)
<damo22_>is it like a reversible transformation of the data that preserves linear mappings?
<youpi>I don't know the details, but basically after homomorphic encryption, you can perform transformations to the encrypted version, which have useful effect on the data after decryption, without affecting the security of encryption
<damo22_>so if you add one to all the encrypted data it decrypts to adding one to the original data
<damo22_>or something like that
<youpi>something like that, yes
<damo22_>what is that property called?
<damo22_>commutability?''
<damo22_>F(f(g(x)) = F(g(f(x))
<youpi>rather D(op(C(x))) = op(D(C(x))) = op(x)
<damo22>yes
<damo22>same thing though
<damo22>D(op(C(x))) = D(C(op(x))) = op(x)
<youpi>yes but the point is to get the result of the operation from the modified encrypted version, i.e. really decrypting after the m odification
<damo22>ok