IRC channel logs

2024-02-10.log

back to list of logs

<gnucode>my fault.
<nikolar>Oh lol
<gnucode>yup.
<nikolar>Well that's annoying
<damo22> Activating swap...failed.
<damo22> [ 24.3500050] wd0d: device timeout reading fsbn 9 (wd0 bn 9; cn 0 tn 0 sn 9), x
<damo22> fer ec0, retry 0
<damo22> [ 24.3500050] wd0d: device timeout reading fsbn 10958032 of 10958032-10958039 (
<damo22> wd0 bn 10958032; cn 10871 tn 1 sn 1), xfer f90, retry 0
<damo22>i think the fpu noise is gone
<damo22>thanks etno
<damo22>youpi: i tried this:
<damo22>+ if (!strncmp(parent_task->name, "gnumach", 7) || parent_task->essential)
<damo22>+ new_thread->bound_processor = master_processor;
<damo22>it hangs before INIT:
<damo22>maybe bootstrap task is not marked as essential
<damo22>that did not help
<damo22>ID 067b:2303 Prolific Technology, Inc. PL2303 Serial Port / Mobile Action MA-8910P this usb device is handy for serial
<damo22> https://i2.paste.pics/3d2ac08d9d07f5988e697334dac17150.png my setup :D
<saravia>damo22: I have with window manager to echinus and for shell graphics to emacs <-- for execute programs and for file manager and all <-- and is obligatory required 160MB, good, sure?
<saravia>damo22: in your image I see 1GB <-- of ram minimun require xD!! you could run --> free -hm
<damo22>saravia: im not trying to optimise for small ram, i have 32GB in my machine
<damo22>saravia: this is my linux machine, to develop hurd in qemu
<etno>sneek: later tell azert: this Dell machine I am working with is an Inspiron 1750 (Dual core Pentium T4400). The current trick is to remove the DVD unit from the tray ':-D (there is a firmware upgrade for that unit and I suspect it may solve the hang).
<sneek>Got it.
<damo22>hmm -smp 1 hangs early while probing ahci
<etno>damo22: > i think the fpu noise is gone < thanks for spotting the problem! 👊
<ThinkT510>cool: https://iandouglasscott.com/2024/02/09/hello-hurd/
<azert>damo22: do you think it would be useful a port of this https://man.netbsd.org/psrset.8 or would it come available too late in the boot process? If useful I think I can port it
<damo22>etno: i have a crash with ncdu trying to read /dev/cd0
<sneek>Welcome back azert, you have 1 message!
<sneek>azert, etno says: this Dell machine I am working with is an Inspiron 1750 (Dual core Pentium T4400). The current trick is to remove the DVD unit from the tray ':-D (there is a firmware upgrade for that unit and I suspect it may solve the hang).
<Gooberpatrol66>ThinkT510: wow, that's really cool
<damo22>azert: probably not useful at this point of trying to debug smp
<damo22>we dont reach a shell yet
<azert>Ok, then I’ll not do it for now.
<azert>Maybe the plan is to go for a different interface e.g. the Linux one in the long term
<damo22>azert: something that might be cool is porting podman to hurd
<damo22>to run docker containers natively as subhurds or something
<azert>Doesn’t look like an easy task.. even with qemu, trivial changes to make it run on the Hurd seem to me like touching code that may impact other platforms
<etno>This would be a showcase of how the architecture of the Hurd is great
<azert>Hard to take such responsibility for me
<etno>And then use Hurd as worker node in k8s ... (Ok, I get out.... :-) )
<damo22>why not
<azert>Imagine I make a trivial change and then I break Solaris, I already imagine hordes of sysadmin writing mails insulting me and hurting me to fix it
<azert>Giving 20 minutes deadlines and such
<azert>;)
<damo22>i want to break solaris
<damo22>lol
<damo22>tell them they can switch to hurd
<damo22>:P
<saravia>damo22: nice!, and how you develop hurd <-- are you have scripts for auto compile and see the result? is necessary a interruption point?
<damo22>scripts?
<damo22>make
<damo22>yes, interruption points are in (qemu) and kdb
<damo22>even gdb
<saravia>: o nice, <--- I see, do you have a video example for watch your enviroment doing a little change or console log? <--- excuse me for ask but, I'm web developer and so, I have too much interest for develop a kernel fix or changes <-- I think which I could do creative resolvings xD!!!
<saravia>n_n :D
<damo22>there is a video from fosdem
<azert>etno: did you already try the x64 port on your hardware?
<saravia>damo22: what of that list? --> https://m.fridu.us/youtube.com/results?search_query=fosdem+hurd+develop
<saravia>s/what/wich
<damo22>saravia: i gave this talk https://archive.fosdem.org/2022/schedule/event/dzammit/
<damo22>Samuel T also gave lots of good talks
<etno>azert: not yet, I tried to keep the unknowns to a minimum. The first goal was to get an autonomous machine running only the Hurd. Now, I will pick a next target
<etno>Now->Know
<etno>Bha
<saravia>damo22: how lines have your processor?
<damo22>?
<saravia>damo22: my processor have 8
<damo22>cores?
<saravia>yes n_n
<saravia>:D
<damo22>8
<damo22>but hurd is only using 1
<damo22>because we havent finished smp yet
<damo22>we are very close!
<saravia>^ so, hurd is slow yet?
<damo22>it runs okay on 1 core
<damo22>but large compiling jobs take a while
<saravia>: o so, with smp <-- hurd will be too too fast really?
<damo22>:D
<saravia>m (_ _) m
<saravia>damo22: are you know if the laptops hurd compatible someday will be too expensive U_U....
<damo22>i just ported ACPI v2.0, it should run on more modern hw now
<damo22>but still in i386 mode
<azert>etno: cool. You were mentioning that now you get stuck 1 minutes in the acpi server setup. Did you figure out what it is doing so slow?
<damo22>that is unusual, i havent seen it do that before
<etno>azert: my current guts feeling is that some ACPI routines are doing timeouts, could be because the ACPI code in this machine is buggy (it is often the case apparently)
<etno>damo22: do you if the ACPI server executes ACPI bytecode ?
<damo22>yes it has full AML parser in there and does the _INI stuff i think
<etno>It would be interesting to measure the hang duration, but I would not be surprised if it was 60.000s :-D
<etno>/hurd/acpi must have switches to trace what it is doing. I should simply start with that I guess
<etno>(also, I would love it there was a way to slow down the fans...)
<damo22>we are doing #define ACPI_FULL_INITIALIZATION 0x0000
<damo22>there are other flags to disable stuff
<damo22> // Hack to increase verbosity except parsing AML
<damo22> //acpi_dbg_level = (ACPI_LV_ALL) & ~(ACPI_LV_FUNCTIONS);
<damo22>its compiled in
<damo22>we could make that into a flag for debug
<etno>Maybe I will have time to try it today. I'll let you know !
<damo22>its in libacpica
<saravia`>test
<saravia`>etno: excuse me, why you need a > way to slow down the fans
<saravia`>:D
<damo22>etno: do you see PASS! or OUCH!
<damo22>when acpi finishes
<damo22>hmm maybe you wont see either
<azert>saravia: my guess is that the noise is bothering
<etno>saravia`: what did you say *fssssssshhhh* ??!? :-D
<saravia`>u_u.... <3 < / 3 : P broken heart, I switch like reading only u_u....
<damo22>saravia`: etno couldnt hear you because the fans are too loud
<saravia`>: o oh I see, you say <-- My questions are so basics to diference of another questions in to very low level of programming ideas n_n <3!
<damo22>so, the smp behaviour with -smp 1 has changed
<etno>saravia`: sorry if I wasn't clear. This was just a joke ;-)
<damo22>it gets stuck at ahcisata probe
<damo22>this didnt used to happen
<saravia`>etno: okas, whitout problem for me, n_n Nice to meet you damo22 and etno n_n, I'm a fan xD!! I admire you
<damo22>welcome
<damo22>something is wrong with interrupts i think
<etno>saravia`: :-)
<damo22>i can get further with my zam/fixes patch
<etno>damo22: the ACPI hang duration is precisely 90s, and I could not see the messages when ACPI completes initialisation (too fast)
<damo22>but the login shell never arrives
<damo22>it does not get stuck with -smp X > 1
<damo22>something is weird with interrupts
<saravia`>xb
<damo22>root@zamhurd:~# nproc
<damo22>6
<damo22>but it hangs
<damo22>youpi: do we need another ipi for rescheduled interrupts?
<youpi>rescheduled interrupts? what do you mean?
<damo22>eg in linux there is TIF_NEED_RESCHED
<youpi>that's the ast check, isn't it?
<damo22>could be
<damo22>#define __smp_mb() asm volatile("lock; addl $0,-4(%%" _ASM_SP ")" ::: "memory", "cc")
<damo22>do we need something like this somewhere?
<youpi>we use things like that in various places like locks etc. yes
<damo22>i checked linux source for how they do IPIs, there is no deassert
<youpi>before trying to fix things by poking at random, better observe what actually is happening, whether some threads are indeed waiting for a reschedule on a core, or not
<damo22>it seems like they are, because the machine grinds to a stop but in kdb they are idle
<youpi>but are the threads in the scheduling queues?
<youpi>or just stuck for another reason
<damo22>hmm how do i check
<youpi>before trying to fix something, you need to determine where the bug actually lies
<youpi>by checking the scheduler queues
<youpi>whether it does indeed have threads waiting for a reschedule
<damo22>sometimes it hangs and i cant get into kdb
<youpi>then it's not just a reschedule issue
<youpi>kdb doesn't care about the scheduler
<damo22>what would happen if i got an NMI interrupt?
<damo22>could it hang?
<youpi>damo22: I don't know if we have properly set up a handler that would at least warn that we got an unhandled nmi