IRC channel logs

2024-01-15.log

back to list of logs

<nikolar>so you did get it to work
<gnucode>sure. I am running netsurf right now.
<gnucode>I just #define PATH_MAX 250
<gnucode>of whatever number I chose.
<gnucode>or*
<gnucode>I'm going to try something in the Hurd console real quick.
<gnucode>be right back
<gnucode>well looks like I can update the open_issues/emacs page.
<gnucode>those 3 commands all worked in the console.
<gnucode>youpi: thanks for fixing sudo!
<youpi>I didn't
<damo22>youpi: i am having trouble with 9600 baud console over a real com port
<damo22>i *think* somehow rumpdisk uses 115200 baud so we get mixture of baud rates during boot
<damo22>should we add a parameter to gnumach cli to set the RCBAUD?
<damo22>but since its already hardcoded, can we just bump it to 115200?
<azert>damo22: how come rumpdisk uses the serial directly? Shouldn’t he pass through gnumach?
<youpi>azert: it does pass through gnumach
<azert>He mentioned that it mixed baudrates
<youpi>I know, but that' cannot be rumpdisk's fault
<youpi>rumpdisk just uses printf
<damo22>ok something is setting the baud rate to 115200 after start acpi:
<damo22>or start xxxx:
<damo22>but the startup baud rate is 9600
<damo22>#ifndef PORTSELECTOR
<damo22>#define ISPEED B9600
<damo22>#define IFLAGS (EVENP|ODDP|ECHO|CRMOD)
<damo22>#else
<damo22>#define ISPEED B4800
<damo22>#define IFLAGS (EVENP|ODDP)
<damo22>#endif
<damo22>is ISPEED always one value?
<damo22>i cant find it
<damo22>tty_set_status?
<damo22>kdsetstat
<damo22>does userspace configure the tty?
<damo22>console "@libexecdir@/getty 9600" mach-gnu-color on secure trusted console
<damo22>task loaded: exec
<damo22>
<damo22>start pci-arbiter:��ci��c�i�r�۠�i�t��ll(��� |
<damo22> ���.0000000ݠ�o�|ri��t�(c���996���99����99����999
<gnucode>morning friends!
<etno>ACTION waves
<gnucode>morning etno
<gnucode>sneek later tell solid_black For now, do you suppose it would be hard to package LadyBird for Debian ?
<sneek>Got it.
<etno>Thanks for the offer the other day, gnucode. I would enjoy a peering session one day. For now, my Inspiron still refuses to start any Hurd server, despite me trying to follow the advice I got here :-/
<gnucode>etno: You can always run it in qemu, but I personally cannot get that to work for me. the Hurd is soo much easier to use on this T43.
<dsmith>Easier to use natively instead of qemu, or easier to use than a different os?
<gnucode>dsmith: Well I personally have only been able to edit the Hurd wiki when running Debian.
<gnucode>I can't quite get ikiwiki set up properly on other distributions.
<gnucode>My goal is to edit the wiki using the Hurd. It's much easier to do that on this T43 than on real hardware.
<gnucode>Debian GNU/Linux is an easier way to edit the Hurd wiki.
<etno>I use a qemu VM to rebuild the parts for troubleshooting. Then trying to get that running on real hardware.
<gnucode>also, I've got emacs installed, but I don't have the emacs manual installed.
<gnucode>or the emacs-lisp manual.
<gnucode>anyone know how to install those?
<etno>Ohh, the instruction on which my Inspiron laptop panics is a XSAVEOPT (0f ae) in fp_save. My hardware probably doesn't have it.
<etno>Why did cpuid not say it ? 🤔
<etno>Both XSAVEOPT and XSAVEC are reported available, and both fail; so it may be something about GPU enablement flag ?
<etno>FPU*
<gnucode>hello friends!
<nikolar>hello gnucode
<gnucode>nikolar: what up dude? Guess what? the company I work for uses a proprietary software that is essential to our business.
<nikolar>isn't that the norm
<nikolar>also i guess i added a syscall to v7 unix on pdp11
<gnucode>I work at a hotel, and our property management software just died. Won't be fixed until Wednesday or Friday. I found an open source PMS. I'm learning how to use it right now. Pretty cool.
<gnucode>And it works!
<gnucode>that's pretty cool!
<gnucode>Did you write it in assembly just for fun?
<nikolar>hitch() {
<gnucode>Or did you go straight to binary?
<nikolar> u.u_r.r_val1 = 42;
<nikolar>}
<nikolar>y
<nikolar>full source
<gnucode>nice!
<azert>etno: files on xsaveopt with state on the stack? Only on real hardware ? Probably a problem with alignment
<azert>Should be 64 bytes boundary
<nikolar>gnucode: it's actually very hackable
<etno>azert: the trap says, "invalid opcode". Would it be the case for an alignment issue?
<azert>No, it would be GP
<azert>But I think the bug is there for real
<etno>Well, that is a real clue ! Thanks azert . I will have it print the save location pointer to check
<etno>Hmm, actually, I would better check the alignment, then print something; this is a pretty hot codepath
<etno>azert: the dest pointer should be in one of the registers already, isn't it?
<etno>EDX:EAX if I am not mistaken
<azert>etno: https://www.felixcloutier.com/x86/xsaveopt
<azert>The pointer argument is the value following the assembly instruction
<gnucode>nikolar: that's pretty awesome!
<azert>Just set EDX:EAX to -1 it will probably work
<nikolar>gnucode: sure is
<azert>Like both registers to -1
<azert>There might be other issues
<azert>Like I’m not sure if XCR0 is set by default
<etno>azert: at the beginning of the fp initialisation routine, a comment says that the FPU needs to be enabled to detect it's capabilities, and it sets bits in the control register.
<etno>What puzzles me completely here is that this is not an exotic CPU, it is an Intel pentium T4400. This code must have been used by quite some people, I guess.
<etno>Or, I am the lucky one, with an exotic Pentium :-D
<azert>I think the Hurd stopped working on real hardware at the time of the pentium 3, and then patches were introduced that might have introduced new bugs
<youpi>I did start hacking on the hurd on my pentium M
<youpi>and booted it several times on various iCore etc.
<azert>So we don’t know if it still works on old hardware. We just know it works on few hardwares
<azert>Ok, youpi knows better for sure
<youpi>well, I don't know what people do in various places :)
<youpi>but it's indeed possible that we haven't tested for hardware before pentium 3
<youpi>I mean, recently
<etno>git blame may give interesting insight then
<azert>Could be cool to do it, would the Hurd run on 128mb of ram?
<azert>Well, even if it does it’s not very useful
<youpi>it would, sure
<youpi>you just won't be able to run much software, probably not apt even