IRC channel logs

2024-01-08.log

back to list of logs

<gnucode>so I am working on trying to create emacs commands for git send-email.
<gnucode>It actually should be pretty easy. You can already create patches in magit via highlighting various commits, then "W c". If you specify a directory like /tmp/patches, then 'git send-email /tmp/patches' will let you send the patches.
<gnucode>I just would like to be able to do this via magit W e
<gnucode>And it would be nice to set this up to work with Gnus
<dsmith>A worthy endeavor
<gnucode>dsmith: thanks. wish me luck!
<gnucode>I'm kind of curious why we want to move pthread into libc...
<gnucode>also what is a rumpfs ?
<gnucode>I assume rumpnet is just providing the network drivers.
<youpi>gnucode: because that's what was done for linux
<youpi>and thus -lpthread is not needed any more
<youpi>and thus people are stopping using it
<youpi>thus breaking builds
<youpi>we don't want to fight that
<youpi>rumpfs = filesystems
<youpi>rumpnet = network
<gnucode>ahhh. That makes sense.
<gnucode>if we are using rumpfs would that mean we may start using FFS filesystem?
<gnucode>or no...rumpfs is for drivers. We would still use ext2
<youpi>no for fs
<youpi>so we can use whatever fs bsd supports
<youpi>we already have librumpfs0, we "just" need to plug it