IRC channel logs

2023-09-14.log

back to list of logs

<almuhs>damo22: rechecking my final degree thesis' document, i found some functions which needs implementation
<almuhs>in thread.c , in thread_init(), there are a block #if NCPUS > 1 with a TODO
<almuhs>#if NCPUS > 1
<almuhs> /* thread_template.last_processor (later) */
<almuhs>#endif /* NCPUS > 1 */
<almuhs>in pcb.c , in switch_context(), there are another TODO
<almuhs>#if NCPUS>1
<almuhs>#warning SMP support missing (avoid races with io_perm_modify).
<almuhs>#else
<almuhs>same in stack_handoff()
<almuhs>#if NCPUS>1
<almuhs>#warning SMP support missing (avoid races with io_perm_modify).
<almuhs>#else
<almuhs> /* This optimization only works on a single processor
<almuhs> machine, where old_task's iopb can not change while
<almuhs> we are switching. */
<almuhs> if (old_task->machine.iopb || new_task->machine.iopb)
<almuhs>#endif
<almuhs>added to this, i have some notes about Richard told me that the scheduler lacks of out-of-order support, which could cause problems in a SMP environment
<gnucode>hmmm, do you have to compile unionfs to get it to work on Debian GNU/Hurd ? Or is it available in /hurd/translators?
<damo22>almuhs: i am aware of the TODOs but not the last remark
<damo22>what is out-of-order support?
<almuhs>damo22: out-of-order is a type of paralelism, in which the process instructions are re-sorted to optimize the cpu resources
<almuhs> https://en.wikipedia.org/wiki/Out-of-order_execution
<almuhs>most modern processors includes this feature
<damo22>are you sure this is the meaning in the context of the scheduler?
<almuhs>if i remember well, this feature is make internally by the processor, without needing of the operating system. But the OS need to consider this
<damo22>or does it just mean out of order scheduling
<almuhs>it's other posibility
<gnucode>in the project ideas page, project "Improving Perl or Python Support"... why is it listed that perl is higher priority that python? Just curious
<gnu_srs1>Hi again. Any ideas? http://paste.debian.net/1291826/
<gnu_srs1>Another correct image: http://paste.debian.net/1291904/
<gnu_srs1>Can the hurd-2013 image be recovered?? If so how?
<azeem>what is the actual problem?
<gnu_srs1>The image is no longer a hurd image. It has two partitions, a 500M EFI System and 63.5G Microsoft basic data
<azeem>how do you run it usually, and what happens now if you do so?
<gnu_srs1>Reasonably it should be (and was): two partitions: 83 Linux and one swap area: 82 Linux swap / Solaris.
<azeem>that does not answer my question
<gnu_srs1>I normally run it with qemu. Has there been a break-in? Found nothing in the logs so far.
<gnu_srs1>Trying to run it in qemu: Boot hangs
<azeem>did you download that image recently?
<gnu_srs1>I've upgraded continuously since 2013.
<damo22>gnu_srs1: did you install windows onto that image?
<azert>GNUmoon: regarding https://darnassus.sceen.net/~hurd-web/hurd/translator/writing/example/ , the header file is not required, gets generated by mig
<azert>Also it doesn’t work for me as a passive translator, anyone knows why?
<azert>Is file_name_lookup enough to start the associated passive translator?
<gnu_srs1>damo22: No I did not: Somebody probably broke in to that image and installed Windows? Or broke in to the host box?? But the linux host process running the image was the same.
<gnucode>morning hurd friends!
<gnucode>haha. Someone called me GNUmoon again!
<gnucode>I cloned unionfs just now, and ran make in the directory and got some compile errors. I was kind of hoping to show that off today.
<gnucode>but that's ok.
<gnucode>hmmm, the Hurd locked up on my again...
<gnucode>the mouse stopped moving.
<gnucode>keyboard didn't respond
<gnucode>I had to hard shutoff.
<gnucode>but after I fsck, things seem to be working well again.
<gnucode>I wonder if emacs is leaking memory.
<gnucode>hello hurd people! My meeting went ok.
<xelxebar>gnucode: What meeting did you have?
<gnucode>I met with an old college professor to show off the Hurd.
<gnucode>It was kind of cool, but I think he was just humoring me.