IRC channel logs

2023-09-01.log

back to list of logs

<makads>By the way, GUIX's QCOW2 image I don't have a graphical environment after QEMU installation, how do I install GNOME or XFCE?
<damo22>this is not #guix
<makads>ok
<makads>but
<damo22>not to be rude, but i dont know anything about it
<makads>is guix hurd
<damo22>guix is a package manager
<damo22>you can run guix on any gnu/linux distro
<makads> https://ci.guix.gnu.org/search/latest/image?query=spec:images+status:success+system:x86_64-linux+hurd-barebones.qcow2
<makads>this
<makads>hurd
<youpi>damo22: it's also a distribution
<youpi>makads: I guess they too have documentation that exactly explain "how to install packages"
<youpi>gotta go, bye
<makads>  "Virtual machine image of the standalone Guix System on GNU Hurd."?
<makads>okay
<damo22>makads: they have an image that boots a virtual machine with hurd in it on top of guix
<damo22>its not native hurd
<makads>:') emmm right
<damo22>youpi: what is the fastest algorithm for GPU accelerated DNA sequence alignment? is it some kind of Smith Waterman? i am looking for something fun to implement that i can use at work
<youpi>damo22: I have no idea
<youpi>I just schedule tasks, my research is not about what's inside the tasks :)
<damo22>ok
<jpoiret>damo22: janneke is running Guix/Hurd on bare metal iirc
<damo22>fair enough
<damo22>youpi: do you have ideas for a new scheduler in mach?
<youpi>no
<youpi>I don't think it is the most urgent task to achieve
<damo22>:(
<youpi>possibly it needs some fixing
<youpi>but that's probably just side corners
<youpi>as in: missing smp plumbing
<damo22>ok
<youpi>as a reminder: mach was used in research project on smp support
<janneke>jpoiret: that's right, patiently yet eagerly anticipating some of the new goodies such as rumpnet, >4GB on i386, and whatnotall:)
<youpi>so it's probably just a mere problem of porting the right things on the right x86 bits
<damo22>i dont know what its missing, but i think ext2fs has a strange threading issue
<damo22>causing early hang
<janneke>meanwhile, iwbn if us over at #guix got pull and system reconfigure to actually work :)
<damo22>cool
<azert>damo22 : for dna alignment there is the new minimap2 by the absolute genius Heng Li.
<azert>It’s good for long sequences that are becoming particularly relevant nowadays
<azert>It’s fast on cpu but I’ve seen gpu implementations browsing Google so i wonder if it is faster on gpu
<damo22>azert: why do you keep quitting just when i am replying
<damo22>my old NV Quadro doesnt work on latest cuda, i need 10.2 d'oh
<azert>It’s the problem of phone-chatting but I read the logs
<damo22>azert: i know of minimap2, but i want to implement something simpler that loads genome into gpu ram and runs a full smith waterman alignment algorithm
<damo22>dna is base 4, you can fit 16 dna bases in a uint32_t
<azert>That should be possible
<damo22>yes
<damo22>and fast
<azert>I wonder how you deal with N or other missing/ambiguous, probably trimming or discarding?
<damo22>if a sequence contains an N, you can pretend its A
<damo22>it will not affect the alignment that much
<azert>I’d consider the encoding where you reserve one bit per nucleotide
<azert>So N would be F in exacimal
<damo22>hmm too expensive
<azert>Then you could use the AND bitwise operation instead  of equality
<damo22>you only need 2 bits per nucleotide, since there are 2^2 states
<gnucode>hello hurd people!
<gnucode>also apparently "sudo apt install elpa-git-commit" is causing an apt error.
<gnucode>git-commit.el: 126:1: Error : Cannot open load file : No such file or directory, transient