IRC channel logs

2023-08-29.log

back to list of logs

<damo22>5 multiboot modules
<damo22>Kernel page fault at address 0x0, eip = 0x0
<damo22>Kernel Page fault trap, eip 0x0, code 0, cr2 0
<damo22>hmm why is it trying to execute at 0
<damo22>im on * a823f60d (HEAD -> fixes, zammit/fixes) percpu active_thread
<damo22>#9 0xc100a740 in trap_from_kernel () at ../i386/i386/locore.S:565
<damo22>#10 0xf51d5f88 in ?? ()
<damo22>#11 0xc103a51d in Thread_continue () at ../i386/i386/cswitch.S:95
<damo22>#8 0xc1037f46 in kernel_trap (regs=0xf51d5f88) at ../i386/i386/trap.c:341
<damo22>(gdb) p regs
<damo22>$5 = (struct i386_saved_state *) 0xf51d5f88
<damo22>(gdb) p *regs
<damo22>$6 = {gs = 104, fs = 3238068224, es = 16, ds = 16, edi = 0, esi = 0, ebp = 4112343000, cr2 = 0, ebx = 4112354672, edx = 0, ecx = 8192, eax = 7, trapno = 14, err = 0, eip = 0, cs = 8, efl = 66050, uesp = 3238090901, ss = 3238090848, v86_segs = {v86_es = 0, v86_ds = 0, v86_fs = 3238241565, v86_gs = 4112354672}}
<damo22>so it tried to call a continuation that was actually the address of "regs"
<damo22>(gdb) frame 11
<damo22>#11 0xc103a51d in Thread_continue () at ../i386/i386/cswitch.S:95
<damo22>95 call *%ebx /* call real continuation */
<damo22>(gdb) p $ebx
<damo22>$7 = -182624376
<damo22>F51D5F88
<damo22>i think there is memory corruption with the static allocation in the gs area
<gnucode>hello hurd people!
<gnucode>I guess I am going to try to run i3 on the Hurd. We shall see how well it works.
<gnucode>I only have 1.5 GB of RAM on this machine.
<gnucode>well the Hurd failed to run X.
<gnucode>I think the mailing list talked about it being broken, and has not been fixed yet. I'm not complaining. Just reporting.
<gnucode>I am trying to startx as a regular user. It is possible that in the Hurd you have to start it as root, but I do not know for sure.
<youpi>as mentioned in readmes etc., https://www.debian.org/ports/hurd/hurd-install
<youpi>notably the dpkg-reconfigure x11-common xserver-xorg-legacy part
<gnucode>youpi you are probably getting really tired of telling people: please read the manual. Sorry...
<azert>Premise: I don’t want to set priorities to anyone, but I’ve seen that a few patches got lost on the mailing list and I was wondering if their authors just gave up. This one from damo22 :  https://lists.gnu.org/archive/html/bug-hurd/2023-07/msg00095.html
<azert>And this and the next one of the serie by solid_black : https://lists.gnu.org/archive/html/bug-hurd/2023-07/msg00036.html
<gnucode>hello again friends!
<gnucode>hellos from the hurd on real hardware running X!
<gnucode>This is probably super insecure. I had to configure X such that anybody could start it...
<gnucode>for some reason telling X that only console users could start X did not work for me
<gnucode>and i3 works pretty well. It is noticeably slow, but seems to support my usecase pretty well.
<gnucode>great job Hurd team!
<gnucode>and I have to go help out a friend! I shall talk to ya'll later!
<gnucode>hello again friends!
<gnucode>this is super cool to run the hurd on X!
<nikolar>are you on debian hird
<nikolar>hurd
<gnucode>I am on debian hurd
<gnucode>running on a T43
<nikolar>nice
<gnucode>oh yeah! it probably not super secure.
<gnucode>I had to configure X so that any user could startx
<nikolar>well as long as it works ¯\_(ツ)_/¯
<gnucode>hahaha
<nikolar>i assume it's not a production system of any kind
<gnucode>nikolar: nope. Though it would be cool to actually host a website with it!
<gnucode>nikolar: it's just something to play around with
<nikolar>Oh definitely
<nikolar>Just don't host anything sensitive
<gnucode>yeah, I'm definitely NOT storing my credit card infomation on this computer! :)
<gnucode>I am heading out to work again! See ya!
<azert>I think that at some point GNUMach/Hurd will require/support an iommu, for safety
<azert>I suspect that will be a major thing to develop